802.11s mesh function

I'm testing 802.11s-based mesh function with two Netgear's EX6150 v2 by referring to https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s. But the two nodes can't connect with each other. Below are the operation details about the two nodes.


Node 1:

@ vim /etc/config/wireless


config wifi-device 'radio0'                                                                                                                   
        option type 'mac80211'                                                                                                                
        option channel '11'                                                                                                                   
        option hwmode '11g'                                                                                                                   
        option path 'platform/soc/a000000.wifi'                                                                                               
        option htmode 'HT20'                                                                                                                  
        option disabled '0'                                                                                                                   
                                                                                                                                              
config wifi-iface 'mesh'                                                                                                                      
        option device 'radio0'                                                                                                                
        option network 'mesh'                                                                                                                 
        option mode 'mesh'                                                                                                                    
        option mesh_id 'mymesh'                                                                                                               
        option encryption 'none'                                                                                                              
                                                                                                                                              
config wifi-device 'radio1'                                                                                                                   
        option type 'mac80211'                                                                                                                
        option channel '36'                                                                                                                   
        option hwmode '11a'                                                                                                                   
        option path 'platform/soc/a800000.wifi'                                                                                               
        option htmode 'VHT80'                                                                                                                 
        option disabled '1'                                                                                                                   
                                                                                                                                              
config wifi-iface 'default_radio1'                                                                                                            
        option device 'radio1'                                                                                                                
        option network 'lan'                                                                                                                  
        option mode 'ap'                                                                                                                      
        option ssid 'OpenWrt'                                                                                                                 
        option encryption 'none'

@ wifi
@ logread -l 20 -f
@ iw dev wlan0 station dump
@ iw phy phy0 interface add mesh0 type mp mesh_id mymesh
@ ifconfig -a | grep mesh0
mesh0 Link encap:Ethernet HWaddr B0:39:56:79:B8:62
@ ifconfig mesh0 up
@ ifconfig mesh0 10.0.0.1
root@OpenWrt:~# iw dev mesh0 station dump ////// No station information
root@OpenWrt:~# iw dev mesh0 mpath dump ////// No path information
DEST ADDR NEXT HOP IFACE SN METRIC QLEN EXPTIMEDTIM DRET FLAGS


Node 2:
@ vim /etc/config/wireless

config wifi-device 'radio0'                                                                                                                   
        option type 'mac80211'                                                                                                                
        option channel '11'                                                                                                                   
        option hwmode '11g'                                                                                                                   
        option path 'platform/soc/a000000.wifi'                                                                                               
        option htmode 'HT20'                                                                                                                  
        option disabled '0'                                                                                                                   
                                                                                                                                              
config wifi-iface 'mesh'                                                                                                                      
        option device 'radio0'                                                                                                                
        option network 'mesh'                                                                                                                 
        option mode 'mesh'                                                                                                                    
        option mesh_id 'mymesh'                                                                                                               
        option encryption 'none'                                                                                                              
                                                                                                                                              
config wifi-device 'radio1'                                                                                                                   
        option type 'mac80211'                                                                                                                
        option channel '36'                                                                                                                   
        option hwmode '11a'                                                                                                                   
        option path 'platform/soc/a800000.wifi'                                                                                               
        option htmode 'VHT80'                                                                                                                 
        option disabled '1'                                                                                                                   
                                                                                                                                              
config wifi-iface 'default_radio1'                                                                                                            
        option device 'radio1'                                                                                                                
        option network 'lan'                                                                                                                  
        option mode 'ap'                                                                                                                      
        option ssid 'OpenWrt'                                                                                                                 
        option encryption 'none'

@ wifi
@ logread -l 20 -f
@ iw dev wlan0 station dump
@ iw phy phy0 interface add mesh0 type mp mesh_id mymesh
@ ifconfig -a | grep mesh0
mesh0 Link encap:Ethernet HWaddr B0:39:56:93:1F:35
@ ifconfig mesh0 up
@ ifconfig mesh0 10.0.0.2
root@OpenWrt:~# iw dev mesh0 station dump ////// No station information
root@OpenWrt:~# iw dev mesh0 mpath dump ////// No path information
DEST ADDR NEXT HOP IFACE SN METRIC QLEN EXPTIMEDTIM DRET FLAGS


Both of the two nodes' default main ip address is 192.168.1.1, does this affect the mesh establishment?
Another problem is how to modify the 802.11s-based mesh's parameters configuration files so that it will be configured automatically each time when the device reboots?

Thanks.

Additionally, the openwrt version is the latest branch v18.06.x.

With 802.11s properly configured (and assuming your wireless devices and drivers support 802.11s), it will just come up at boot under OpenWrt 18.06 and later, without any command-line action. wpad-mesh (or likely wpad-full) is required for an encrypted, authenticated mesh.

Some details of how to "properly" configure 802.11s are at https://openwrt.org/docs/guide-user/network/wifi/mesh/batman If you're using the 802.11s routing protocol, you'd want to change option mesh_fwding '0' to enable mesh routing.

All nodes generally get the same wifi-iface configuration. The other interfaces on the devices having the same IP address across routers shouldn't cause a problem with the establishment of the mesh. Once you try to connect them with IP packets, well, that could be a different challenge when it comes to routing. That you're not seeing the mesh connect shouldn't have anything to do with that.

Without seeing more of your config, I'm guessing that you don't have a corresponding, complete network section, so netifd isn't bringing anything up.

Thank you, Jeff.

With 802.11s properly configured (and assuming your wireless devices and drivers support 802.11s), it will just come up at boot under OpenWrt 18.06 and later, without any command-line action. `wpad-mesh` (or likely `wpad-full` ) is required for an encrypted, authenticated mesh.

Some details of how to "properly" configure 802.11s are at https://openwrt.org/docs/guide-user/network/wifi/mesh/batman If you're using the 802.11s routing protocol, you'd want to change `option mesh_fwding '0'` to enable mesh routing.

Yes, I get this point and the mesh network is established successfully finally. I realized it seems the user just needs to define the configuration file such as '/etc/config/wireless' for a simple test about 802.11s-based mesh function after I tried many times with both modifying the configuration file and setting mesh parameters in the command line. Only the mesh network which is the default configuration in '/etc/config/wireless' with the default interface name 'wlan0' could be established successfully while the customized mesh interface 'mesh0' or others fails all the time, it seems the customized mesh interface could never bring up.
And, the mesh interface is always the default 'wlan0' even if I define a new name for the mesh's wifi-iface in the '/etc/config/wireless' file.
Is there any way to customize the mesh's interface name which is not 'wlan0' by modifying the related configuration files like that the iw ci commands does before?
And if I want to modify other parameters likepower level, RF channel.., which configuration files should I pay attention to?
Just refer to the web link you have suggested?

All nodes generally get the same `wifi-iface` configuration. The other interfaces on the devices having the same IP address across routers shouldn't cause a problem with the establishment of the mesh. Once you try to connect them with IP packets, well, that could be a different challenge when it comes to routing. That you're not seeing the mesh connect shouldn't have anything to do with that.

Without seeing more of your config, I'm guessing that you don't have a corresponding, complete `network` section, so `netifd` isn't bringing anything up.

I need to create the mesh network with the bridge function so that I could test the connections between those routers, so I modify all the routers' lan ip with different values. Now the mesh network seems running well.

By the way, I'll quite appreciate if you could give some more guide about the 802.11s-based mesh function with the frequency hopping.

The config that I referenced on that page is based on mine -- it sets the wireless interface name with the config in the /etc/config/wireless section with option ifname 'mesh0'

I'm not aware of how to implement "frequency hopping" for 802.11s mesh. It seems like something of a challenge, as you'd have to configure all the devices to somehow mutually all change channels to the same channel at the same time. This is a good is a reason not to use DFS-impacted channels for 802.11s, or any other application that requires all nodes to be on the same channel.

OK, I will try it, thanks a lot.

One more question, could I configure or reconfigure most of the parameters such as power level, RF channel... and the others for 802.11s mesh in the /etc/config/wireless file? Could I find a detailed guide somewhere for how to configure this configuration file?

:+1:

https://openwrt.org/docs/guide-user/network/wifi/basic

@CS999 you could also use OLSR by following this guide.

https://justingoetz.net/docs/docs_openwrt/olsr/adhoc-wpa.html

Some changes are needed with the guide as it was for previous version of the Luci interface. Not major I found for example that the mesh interface needs to made in the interfaces section. You will see when you get to that step

Thanks a lot. @markbirss

I also bought a Netgear EX6150v2, and installed OpenWRT 18.06.1 and tried to configure mesh using OLSR (ad-hoc mesh) and 802.11s

It seems the wireless chipset prefer 802.11s ?

Here is a freifunk 802.11s script for 18.06.1 im busy trying
https://jenkins.kbu.freifunk.net/files/node-config/doc/

*bump" and hi there :slight_smile:

Did anyone of you succeed in using Ex6150 as a WiFi extender?
I would be thrilled to know how!

Marc

Nevermind, not needed for me anymore :sweat_smile: