802.11s and AP on radio0 works great until it doesn't

On latest OpenWrt 18.06.1, r7258-5eb055306f, I have a network running with radio0 functioning as both an 802.11s mesh point as well as a master AP using two different SSIDs on the same 2.4Ghz radio- the device is an Archer C20 AC750 (which is using mt7620-pci). It works great, fast, and almost perfect, but I am noticing that a client, in this case an Android, will eventually disconnect and become unpingable, reporting the AP as "internet not connected". There are no errors anywhere, it is a silent failure.

This is such a simple configuration, just adding two wireless devices to the same radio interface that I feel its hardly worth posting, but:

/etc/config/network ->

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdac:98a8:26fd::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option mtu '1500'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '0c:80:63:92:63:61'

and /etc/config/wireless ->

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option channel '1'
	option country 'IN'
	option legacy_rates '0'
	option htmode 'HT40'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option encryption 'none'
	option mode 'mesh'
	option mesh_id 'Guruji_Provides_Mesh'
	option mesh_fwding '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid '2nd Encrypted Net'
	option network 'lan'
	option key 'makeitwork'
	option disassoc_low_ack '0'
	option encryption 'psk2'

I have tried messing with MTU, encryption on/off/different, Fragmentation Threshold, and RTS/CTS Threshold with no change.

There seems to be no debugging info or error info of any kind anywhere, not quite sure how to go about debugging this. Any help would be much appreciated. Thank you!

How does it behave with no encryption on the AP?

The encryption doesn't make any impact either way, not on the mesh or the AP.

Perhaps it a issue with that specific Wifi chipset? I found Atheros/Qualcom to handle mesh and ap better that Mediatek

I am pretty much thinking the same thing. Over time, I am not noticing the same behavior on the Archer C7; however, oddly, I am also not noticing it when the connected client is a Pixel C tablet.

1 Like