802.11r - Missing required pairwise in pull response

Hey there,
i found the following lines in my log and im not sure whats going on there, somehow hostapd seems to be sending PUSH/PULL packets over network with missing fields?

My network is using 802.11r with wpa2 and radius authentication.

Tue Dec 10 12:30:35 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from b4:fb:xx:xx:xx:xx
Tue Dec 10 12:30:35 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from b4:fb:xx:xx:xx:xx
Tue Dec 10 12:30:35 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from b4:fb:xx:xx:xx:xx
Tue Dec 10 12:30:36 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from b4:fb:xx:xx:xx:xx
Tue Dec 10 12:30:36 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from b4:fb:xx:xx:xx:xx
Tue Dec 10 12:32:18 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from 80:2a:xx:xx:xx:xx
Tue Dec 10 12:32:18 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from 80:2a:xx:xx:xx:xx
Tue Dec 10 12:32:19 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from 80:2a:xx:xx:xx:xx
Tue Dec 10 12:32:19 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from 80:2a:xx:xx:xx:xx
Tue Dec 10 12:32:19 2019 daemon.notice hostapd: FT: Missing required pairwise in pull response from 80:2a:xx:xx:xx:xx

My r0kh and r1kh format is the new one specified by hostapd:

list r0kh '<MAC address>,<NAS Identifier>,<256-bit key as hex string>'
list r1kh '<MAC address>,<R1KH-ID>,<256-bit key as hex string>'

I cant really figure out whats wrong here

1 Like

Did you ever figure out the reason? We have the same problem here, yesterday the setup worked just fine with FT and entries like
WPA: FT authentication already completed - do not start 4-way handshake

Today I see
FT: Missing required pairwise in pull response from

Same client that did FT yesterday, it is puzzling.

I’ve seen the same. I believe these messages disappeared when I set:


option rsn_pairwise 'CCMP'
option rsn_preauth '1'