802.11r (Fast-Roaming) in LUCI

I want to setup 802.11r since I already have several LEDE routers installed to provide wireless coverage in the entire house.

To quick sum up:
Linksys WRT1900ACS with LEDE SNAPSHOT r5917 (David502 version)
TP-Link WDR4300 with LEDE Reboot 17.01.4 r3560
Ubiquiti AP-AC-LR (with Ubiquiti firmware though which to my surprise is a derivate of OpenWRT AA)

I can find documentation on the OpenWRT wiki what parameters to add for getting 802.11r implemented, but I also see screenshot that it should be available for configuration in the LUCI interface.

Am I missing some packages, has 802.11r been removed, or do will only show up in LUCI when feature is enabled in UCI?

1 Like

I have never seen these options in LUCI. Do you happen to have link to that screenshot?

The best source of information that I was able to find and successfully got it up and running with, was this Reddit topic: https://www.reddit.com/r/openwrt/comments/515oea/finally_got_80211r_roaming_working/

1 Like

You need to install the wpad package (the default wpad-mini does not include 802.11r support). Once you install wpad, the 802.11r options should appear on Luci.


Thx mchen96.
That did the trick.

Was it stable for iPhones, Mac books, etc ? I had that set up but had to disable it as it wasn't stable for Apple devices but windows and android works fine.

Probably because windows and android weren't using it

LOL, yeah.

For anyone finding this thread, the configuration for OpenWRT-18.06 and later has been greatly simplified. Adding option ieee80211r '1' to a wifi-iface stanza should be sufficient for most users.

I've been using this configuration approach as a patch for months now and it has been very stable and usable for iOS devices. No more dropped / hung FaceTime sessions!

1 Like

And what gave you the idea ?

Because I spent a bunch of time and tried to get 802.11r to work and there wasn't a single device in my house that used it :smirk:

And what gave you the idea that those devices wasn't using it ? It worked fine for me even when I had file transfer and moving around and those are failing now that I disabled Ft.

It was a while ago, I remember that the logs didn't change, and the transitions took the same amount of time... also I started looking for listings of device specs, and found no support.

For YOUR windows and android devices, or for all windows and android devices ? If your logs didn't show, have you consider the possibility that you reconfigured ? just saying.....

I don't do windows... and as I say I searched the web extensively for android support and found that it pretty much required a 2017 device or newer, Samsung, maybe a few others. 802.11r is poorly supported in anything but maybe the latest devices. You will also see plenty of advice on Cisco and various forums about turning off 802.11r because there are too many devices that won't work with it on. Current recommendations from Cisco are to create a separate SSID for 802.11r capable devices.

I'm not saying anything at all definitively, except that for my extensive collection of devices none of them worked. FT was detected in wifi analyzer, i'm pretty sure it was configured correctly, but the client has to support it. It came out in 2008, devices I have up to about 2015 didn't support it.

EDIT: the one thing I know has it right there in the spec is that iOS and Apple devices in general support it. which is suspicious that those are the only devices you have that were unstable.

1 Like

Then you are clearly mistaken. Samsung supports 802.11r since the S4 and Notes 4 . That would means that it's available 4-5 years old. I know for a fact because I validated wifi roaming (setup with Cisco Wireless solutions) using a Samsung S4 when I was still in the business.

I tested 802.11r (Lede on TP-Link Archer C7 v2 ) with Notes 4 and other devices. And yes, you could validate and log does show the transition, and also there are apk on app store that allows you to validate if it connects with 802.11r .

My point however in my posts is that when you state broad statements like "Android and Windows doesn't support 802.11r" as facts, you are clearly misleading others and in many situation discourage others from doing their own testings and furthering the development of these technology.


Isn't it better to clearly stick to facts and what you KNOW for facts instead of comments for the sake of comments with misleading statements ? If you don't know for sure, won't it be better to just state that you don't know, such as which Samsung phone you tested with , e.g. S1 or S2 or some low end ones made for 3rd world countries.

That's why I said probably. As in it seems likely. If I knew it wasn't using it I'd have said windows and Android don't support it, something I know is false. There are many many more devices than samsung and many devices just still don't support it. Apple had been at the forefront of getting that support out there.

In any case sorry if my brief statement misled anyone, just beware that support is not by any means assured.

I tested with Moto g3, g4, Kindle fire 7, Kindle fire hd8, and a Ubuntu laptop, and maybe a middle of the road LG phone and a Dell tablet. None used FT. That's not exactly zero data.

Here's mid 2017 request for support in Motorola handsets https://forums.lenovo.com/t5/Moto-Z-Force/Request-for-802-11r-support/td-p/3727285

Here's a spec shootout showing LG G5 doesn't support it.


It is just not that common except in high end devices: apple and samsung mostly.

Is there any roaming for unencrypted wifi?
I guess 802.11r only works in wpa2 networks, right?

You can already roam between networks with the same SSID without 802.11r. It just speeds the crypto/auth handshake.

1 Like

Thanks for your fast response!

Ok, but what about WDS? I‘ve just read, that I‘d need it for a seamless handover?