802.11r doesn't work on MT7622?

Hi everyone,

I'm going to build my first experimental seamless WiFi network based on 2 routers: Xiaomi AX3200 (Redmi AX6S) and old TL-WDR4300. I would like to perform some experiments with 802.11r as it's a common scenario when I walk between floors during the Zoom call, so transition lag is critical here.

I know that 802.11r/k/v and so on is not a silver bullet that solve everything, but would like to try.

Currently I have Xiaomi AX3200 (OpenWRT 23.05.3 stable) on the first floor, TL-WDR4300 (OpenWRT 22.03 stable) on the second. They are wired connected at 1gbps, TL-WDR4300 configured as dumb WiFi AP. Both devices have the same SSID and encryption options.

So here are current configs (my wireless network works on 2.4ghz only for now so I'll cut everything related to 5ghz):

TL-WDR4300:

root@OpenWrt_2nd_floor:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option cell_density '0'
        option htmode 'HT40'
        option channel '6'
        option noscan '1'
        option log_level '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option key 'MyPassword'
        option ssid 'ironnet24'
        option mode 'ap'
        option ieee80211r '1'
        option mobility_domain '123F'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option encryption 'psk2'

AX3200:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option channel '6'
        option band '2g'
        option htmode 'HT40'
        option cell_density '0'
        option country 'PA'
        option txpower '20'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'ironnet24'
        option encryption 'psk2'
        option key 'MyPassword'
        option ieee80211r '1'
        option mobility_domain '123F'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

AX3200 has wpad-mbedtls 2023-09-08-e5ccbfc6-6 installed (but tried wpad-openssl as well)
WDR4300 wpad-openssl 2022-01-16-cff80b4f-19.3

The issue is that Android Wifi Scanner shows that there is no 802.11r support on AX3200.

Any ideas what's wrong and how to make AX3200 set up network with 802.11r enabled?

Thanks in advance

Rebooting both routers and re-adding WiFi for Android phone did the trick - now FT is shown on WiFi Monitor and works perfect when I move between APs.
Thanks everyone for attention!