802.11ax wifi AP mPCI-E cards

I just bought the exact same card (MT7921K) but I'm only getting 20-30Mbps. Do you know what the issue might be? I'm running 22.03 in Proxmox 7. I tried with my MacBook Air as well as a Windows machine with AX200. It seems the bit rate is stuck at 54Mbps max and Windows is reporting it's using 802.11a instead of ac or ax that I set it to.

I found the problem. Apparently I disabled WMM mode without reading the text below that clearly warns about possible limitations.


Does anyone know if OpenWRT supports this M.2 Wifi 6 wireless card ?

On the product page it says that it supports Linux. I see the chipset it is Qualcomm Atheros WCN6856 so I assume the driver is ath11k.

On the Linux ath11k driver page https://wireless.wiki.kernel.org/en/users/drivers/ath11k#supported_devices I see that only WCN6855 is listed as supported but not WCN6856.

Kind regards,

Similar question: I have a Turris Omnia, which has mPCIe slots. I'm thinking to replace the 2.4GHz card with a Wifi 6e card. Any suggestions? Apparently the AW7915-NPD works but I can't find it from any seller I'd trust in the US (e.g., Amazon or similar top-tier site with a reasonable return policy). Unfortunately most cards on Amazon don't reveal their true chip set, so it's a long slog through reviewer comments looking for someone who runs Linux.

Read the reviews, it's usually posted, although there's no guarantee you'll be getting the same hw as the other buyer(s).

I guess it is compatible with WCN6855 but without a PCI ID its hard to tell.

I just spent 30 minutes on Amazon. It seems 99% of cards use an Intel chipset requiring iwlwifi drivers which aren't in the kernel until 5.10. I'm still running a 5.4 kernel due to being on 22.03 due to unrelated issues that boil down to nftables/firewall4 don't work with 3 packages I use.

Intel is a no go for AP anyway.

1 Like

Thanks for the tip lest I'm tempted to try it. So there is this AsiaRF card that seems like it would work, but it's not 6 GHz.


I just installed cheap MT79231K WiFi6E card in my x86 box and it works fine in AP mode in 802.11ax mode (with MT7921E) driver. It probably works in 6GHz band as well but I have no device to test it with.
I tested it with iperf3 client on 80MHz channel with iPhone 13 to iperf3 server running on router itself. I was able to hit 800Mbit/sec. I believe I paid 12 buck for the card and couple bucks more for M.2 to mini PCI-E

Found this card with MT7922

1 Like

I have checked now and the PCI ID for this WNFQ-269AX(BT) - WiFi 6/6E M.2 E wireless card is shown below:

I tried several Linux distro but I did not manage to load the firmware for this card although the ath11k_pci driver seems to be loaded.

Well, it is using the WCN6855 PCI ID.
What do you mean by you did not manage to load the FW?

Sorry for not being very clear.
I was testing the card it using an old Archlinux live ISO released last year in july 2022 and initially the dmesg log showed a message

ath11k_pci: probe of 0000:02:00.0 failed with error -95

Then I tried then with a recent Archlinux ISO running kernel 6.2.13 and the card is now detected properly and firmware is loaded

dmesg | grep ath11k
[   38.374925] ath11k_pci 0000:02:00.0: BAR 0: assigned [mem 0x7fc00000-0x7fdfffff 64bit]
[   38.374953] ath11k_pci 0000:02:00.0: enabling device (0000 -> 0002)
[   38.375306] ath11k_pci 0000:02:00.0: MSI vectors: 32
[   38.375313] ath11k_pci 0000:02:00.0: wcn6855 hw2.1
[   39.749474] ath11k_pci 0000:02:00.0: chip_id 0x12 chip_family 0xb board_id 0xff soc_id 0x400c1211
[   39.749481] ath11k_pci 0000:02:00.0: fw_version 0x110b196e fw_build_timestamp 2022-12-22 12:54 fw_build_id WLAN.HSP.1.1-03125-QCAHSPSWPL_V1_V2_SILICONZ_LITE-3.6510.23
# ip addr show wlan0 
7: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 00:0e:8e:bc:49:af brd ff:ff:ff:ff:ff:ff

I have a new question now
In the specification it is saying that it supports DBDC (Dual-band, Dual-concurrent) mode, but with Tri-band capability (2.4GHz, 5GHz, and 6GHz). WNFQ-269AX(BT) is able to concurrently run 2.4GHz with 5GHz, or 6GHz.

I'm not sure how to enable DBDC so I can run two SSID concurrently one for 2.4 GHz and another for 5/6Ghz using this wireless card.

I plan to use it on OpenWRT in AP mode on an x86 PC.

Thank you.

There is nothing to enable, if the card is properly fused to have the correct board_id then BDF will configure everything.

That doesn't look like the case here as 0xff is just the fallback board_id

I've had fun wit similiar card, just installed all qc drivers and it magicaly showed up, but i've runned out space on my ssd (need to resize partition) and cannot get rest of packages needed to make it work, maybe later today i'll find some time to play with this setup since x86 with wireless card is the only way to get some real speeds not slowed down because of some not supported or not working hw accelerations in openwrt.

So if the board_id is set to 0xff this means that this card cannot run in DBDC mode or does not support it at all ?

No idea, it's going to be whatever is set in the default BDF, but as far as I know it really should have a different ID than 0xff.

What does iw phy show you?

This is the output of the iw phy command. I uploaded the text output to pastebin since it was large and I could not add it here.

Well, if its registering just one wiphy then its not dual band concurrent, at least not with that BDF.

Cause, BDF is the central place for configuration, without the correct one being loaded you end up with sane defaults.

For more info, check this saga with QCN9074 cards that were not properly fused.

Someone test this card with openwrt ?