6in4 fails with Command failed: Invalid argument

Hi all, I'm trying to setup HE Tunnelbroker opn OpenWrt.

I set my tunnelbroker as such in /etc/config/network

config interface 'tunnelbroker'
	option proto '6in4'
	option peeraddr '216.66.80.26'
	option ip6addr '2001:xxx:xxx:xxx::2/64'
	option tunnelid 'xxx'
	option username 'xxx'
	option password 'xxx-xxx'
	option mtu '1472'
	list ip6prefix '2001:xxx:xxx::/48'
	option auto '0'

When the tunnel is set to autostart my log is flooded with

Fri May  6 21:10:15 2022 daemon.notice netifd: Interface 'tunnelbroker' is setting up now
Fri May  6 21:10:15 2022 daemon.notice netifd: tunnelbroker (31211): Command failed: Invalid argument
Fri May  6 21:10:36 2022 user.notice 6in4-tunnelbroker: update failed
Fri May  6 21:10:36 2022 daemon.notice netifd: Interface 'tunnelbroker' is now down

Just to ask the obvious, do you have a globally routed IP address XOR cgNAT (are the IPv4 addresses shown for OpenWrt's WAN interface and those returned by an external service the same)?

Yes, my public ip is a standard static IP that routes to me

Do you allow Ping (ICMP Echo-Request) from the Tunnel Check server?

(This is a very obscure requirement in some HE documentation.)

Not sure why this is here.

???

What other settings do you see?

(If you think option auto has something to do with auto starting, it doesn't - you can remove it.)

LuCI sets the auto option whenever you turn on/off 'Bring up on boot'.

If I visit https://lg.he.net/ and ask them to ping me, it doesn't fail, so I assume it wouldn't be any different for the tunnel check server.

1 Like

I'm still having the same tunnelbroker (23908): Command failed: Invalid argument error when attempting to run the tunnel.

I've tested just running a v6v4tunnel under a Windows VM and it does work, so the configuration issue is somewhere in my OpenWRT setup.

For completeness, my entire /etc/config/network is attached below.

/etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda2:e51a:7fa5::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'pppoe-WAN'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option netmask '255.255.0.0'
        option ipaddr '192.168.1.1'
        list dns '1.1.1.1'

config interface 'WAN'
        option proto 'pppoe'
        option device 'eth1'
        option username 'xxx'
        option password 'xxx'
        option ipv6 'auto'

config interface 'tunnelbroker'
        option proto '6in4'
        option peeraddr '216.66.80.26'
        option ip6addr '2001:xxx:xxxx:xxx::2/64'
        option tunnelid 'xxxxxx'
        option username 'xxx'
        option password 'xxx'
        option mtu '1472'
        list ip6prefix '2001:xxx:xxxx::/48'
        option auto '0'

Do you have applied the rule?

config rule
        option src 'wan'
        option name 'Allow 6in4'
        list src_ip '216.66.80.26'
        option family 'ipv4'
        option target 'ACCEPT'
        list proto 'ipv6'
2 Likes

Thanks for your help, however even after applying the rule I still get the same error


Tue May 24 19:37:06 2022 daemon.notice netifd: Interface 'tunnelbroker' is setting up now
Tue May 24 19:37:06 2022 daemon.notice netifd: tunnelbroker (2883): Command failed: Invalid argument
Tue May 24 19:37:08 2022 user.notice 6in4-tunnelbroker: update 1/3: nochg my.public.ipv4.address
Tue May 24 19:37:08 2022 user.notice 6in4-tunnelbroker: updated
Tue May 24 19:37:08 2022 daemon.notice netifd: Interface 'tunnelbroker' is now down

Try to change the name from tunnelbroker into something short, like henet.

2 Likes

Wow! I didn't think that was the issue all this time.

Thanks for your help!

1 Like

There is a 15-char limit in the interface name, and by adding the 6in4- prefix you overrun it.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.