5GHz WiFi issues with WRT1200AC running OpenWrt 21.02.x

The AMSDU trick doesn't work for me. I still notice some sort of WiFi instability (need to switch my device's WiFi connection Off then On again to restore the connectivity), plus my Braava robot still can't connect to my AP.

Very nice to read that!
But the WRT1200AC is equipped with a 88W8864 chip, which makes this router different to the WRT3200ACM on a hardware point of view. Your custom builds won't work for me, as far as I understand.

You could compile an image for WRT1200AC using the branch. We use wireless drivers from backports-5.7.5 which might also have an effect on this device.

Curses. Nothing is ever easy :slight_smile:

Have you looked at this?

Thanks for sharing.

As I wouldn't get too far from official releases for this production router (I'm not a developer), I prefer to stick to the 19.x branch for the moment. I'll try future 21.x updates when they will be available.

@Just1M Thank you for posting this and you are not only. I have been a long time user of DD-WRT since my original WRT54G. I recently jumped to OpenWRT 20.02.0 & also tried 20.02.1 for my WRT1200AC as I wanted better stability. I have also been trying to figure out why my 5 GHz WiFi devices (android cell phones and windows 10 laptop) were dropping connections and just stating connected with not internet for weeks now. The only workaround I had was to disconnect the WiFi and reconnect, which is very annoying.

Is there a proper way to report this issue as a bug to be fixed in 20.02.X?

In the meantime, I will install 19.07.8 to see if that resolves these issues and report back.

Update: I have been running 19.07.8 with wpad-openssl using 5Ghz AC and 2.4Ghz N with WPA2-PSK/WPA3-SAE Mixed Mode for a week now with no issues.

1 Like

In the same boat, had to downgrade back to 19.07.8. Hope issues with 21 can be resolved soon.

1 Like

I've been having this sort of problems too with the WRT1200AC. used to run WRT54G's in WDS mode and stable for a very long time until 1 fried up, replaced them with the former and I tried to add a dumb AP to my setup, started to discover all sort of issues , particually with the 5Ghz modem.

I tried to apply about everything I saw here on the forum to try to solve it. I'm using 2 different SID's between 2.4 and 5 , all my devices fall back to the 2.4 band/sid but the performance isn't really great there either on fast downloads it grind to a halt, but the 2.4 connection atleast seems to be stable

When I reboot the modem, I can see the 5Gh SID present, I can connect to them fine, using 3 laptops, an older one, one a few year, and another one 4 weeks old. They all show this problem, the oldest laptop "sees" the 5Gz a tad longer. Using Ubuntu 20.04 on the oldest and the newest, a windows10 laptop as well and also samsung S10 and a Oneplus6T , they all show the same behavior. It takes about 10 minutes to see them all use the 2.4Ghz SID instead of the 5Ggh

I tried release 21.02.x , 21.01 . I actually upgraded a while back from 19.x-is release because I wanted to create a bridge with a localport + wan port, that was working in 19.x , but moving towards the new switchport stuff , I couldn't get this to work. I just ended up throwing a real switch in the mix, but now that I'm diving deeper into this I'm discovering a lot more. The dump AP I added was functional, but all the sudden my laptops connected to the modem upstairs (2 floors up), and then swapped back and so on on the 5Gh band. I'm going to try to downgrade to a version in the 19.x branch to see if I can make it work there. One thing which is pretty cool, it's documented really well in the site here, I just discovered that it has 2 boot partitions.

I'm going to try the 19.07.7 release to see if that one is stable enough. Thanks for all the work though on openwrt, I really like it and hope that maybe the description of this issue helps:

PS:
OpenWrt 21.02.1 (Linux 5.4.154) - version that has issues
OpenWrt 21.02.0 (Linux 5.4.143) - same problem
OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-22.025.78315-f3debdc

Tested 19.07.7 and this one also has issues. I've been testing various settings and looking at the graphs, also tested cabled connection and downloaded a debian CD as well as large shape file archives (~1.5G) and lookin at how the graphs behave. I started rsync'ing the files between 2 laptops on the wifi and I in nowhere get the speeds I'm supposed to, being 5 meters from the AP with both.
Tried this:

  • no encryption : no difference
  • set width from 80 to 40Mhz : this seems to kinda take away the bottom peaks in the transfer, so the transfers don't totally stall anymore. Switching to 20Mhz width and the problem re-appears
  • using different channels , 52 and 64 : both are totally free in my area, no difference
  • using N instead of AC , this slows it down , but not by a lot

I'm reaching 1,544,384.23 bytes/sec on an rsync over 5GHz ...
The 2.4Ghz channel I'm not testing it anymore, it looks like it's suffering from the same problem but as expected, it penetrates further in my house, my TV is wired so netflix is limited to the WAN speed but I never had issues there, even watching 4K.

Took some screenshots of the graphs while transfering:

The drops are noticeable in the transfer I see the rate drop to very low levels and the file size on the receiving side isn't progressing. Now I understand how 5GHz works, number of antenna's, distance etc. The modem is in clear view of both laptops. laptop to laptop transfer , I would expect to see this to be faster than download test from the internet (1 is a linode machine I know transfers very fast , the other is the closest debian mirror)

Things I'll try is to install the stock firmware from linksys/cisco and test the hardware with it and see how this could make a difference. reluctantly though. But I'll add information here once collected.

UPDATE:
Quite the bummer, the stock firmware shows me the same issue , transfers are way too slow for the advertised speed rsync the full file :

GRB_20211216_30000B500_Shapefile.zip
    785,158,784 100%    3.76MB/s    0:03:19 (xfr#1, to-chk=0/1)

I've never actually ran this firmware , flashed open-wrt when it came out of the box, I never realised how pathetically non-featureless this firmware actually is, can't even select the channel I know is empty, only goes to 42 . There is like nothing to tune in this stock thing

Since I have 2 of those, I can exclude the hardware since I swapped both , and now pretty much can exclude the firmware too. So is it my expectation that is way off ?

Reading as sold:

The Linksys WRT1200AC AC1200 Dual-Band Smart Wi-Fi Wireless Router is a simultaneous dual-band 2 x 2 Gigabit router, which supports 256-QAM modulation, allowing a maximum data rate of 400 Mbps on the 2.4 GHz band and up to 867 Mbps on the 5 GHz band.

Even theoretical max: 867Mbps is 108.37.MB/s which is a far cry away from my average 2.10MB/s transfer speeds (even multiply by 2 since i'm doing wifi-wifi transfers).

With the stock firmware doing a 5GHz -> 2.4GHz transfer between laptops is the worst, drops down to have MB/s at times, it's sick

glenn@zenny:~/$ rsync -av --progress GRB_20211216_70000B500_Shapefile.zip.1 glenn@192.168.1.177:
sending incremental file list
GRB_20211216_70000B500_Shapefile.zip.1
    144,965,632  42%  382.92kB/s    0:08:30

I'm truly out of idea's here what the cause is.

root@router1:~# cat /sys/kernel/debug/ieee80211/phy1/mwlwifi/info

driver name: mwlwifi
chip type: 88W8864
hw version: 7
driver version: 10.3.8.0-20181210
firmware version: 0x0702091a
power table loaded from dts: no
firmware region code: 0x30
mac address: 00:25:9c:14:22:b8
2g: enable
5g: disable
antenna: 2 2
irq number: 74
ap macid support: 0000ffff
sta macid support: 00010000
macid used: 00000001
radio: enable
iobase0: dd8384dc
iobase1: 7921cfbe
tx limit: 768
rx limit: 64
qe trigger number: 22413

root@router1:~# cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info

driver name: mwlwifi
chip type: 88W8864
hw version: 7
driver version: 10.3.8.0-20181210
firmware version: 0x0702091a
power table loaded from dts: no
firmware region code: 0x30
mac address: 00:25:9c:14:22:b9
2g: disable
5g: enable
antenna: 2 2
irq number: 73
ap macid support: 0000ffff
sta macid support: 00010000
macid used: 00000001
radio: enable
iobase0: 8e3cc2c2
iobase1: 9723d730
tx limit: 768
rx limit: 64
qe trigger number: 22607

It seems like you are using the same mlwifi chip type as my Linksys WRT1900ACS https://openwrt.org/toh/linksys/wrt1900acs eg. Marvell 88W8864, which had significant firmware problems and issues with the 21.02.x release which should be fixed on the 21.02.2 release. Have a look at this thread:

You could try using the latest snapshot release candidate for your device so have a look at:

For the 5GHz Problem this could be for example that you use a Channel with DFS (Radar Detection) I think depending also on the country you are, but probably you have the same issues I had with my Linksys WRT1900ACS.

Also a look in the logs would be helpful, for example under GUI -> Status -> System/Kernel Logs.

Hi,
Thanks for the pointers. In the mean time I also flashed dd-wrt on it, and the problems are the same, all my linux laptops seem to cope better, but the windows10, he sometimes loses either of the links,2.4 and 5 and even when it connects he can't seem to get internet connectivity. Especially after going to standby mode when it returns, can't get it to work, a reboot does the trick there.

dd-wrt did give me a lot of options to play with and I did determine I also have a regulatory issue with the channels indeed. So the solution there is to stick to the lower channels of the 5GHz band. e.eg 36, 40, 44, 48 , then the clients see the SID. They should be DFS-free. I live fairly close to an airport so I was also starting to think that the DFS channels are to steer away from.

The copy between laptop (new/old) seems limited by the older not supporting the ac standard, I need to go in mixed mode. using VHT80 on 5GHz and VT40 on 2.4GHz seems to double the transfer rate, so I got it up a bit, but still unstable, also my Oneplus phone seems to suffer from disconnects, pretty awesome when playing the odd poker hand :wink:

I'm going to try the latest snapshot this week. I actually also picked up a EA8300 and a MR8300 since I could only find 1 EA8300 left in Belgium online. But these 1200AC's, I also want them to work, so not giving up there.

Thanks for the suggestions!

The most stable I got this one with dd-wrt settings now is this, but I do prefer openwrt:
(the channels is now 40, not 60 anymore)

UPDATE: I've installed the snapshots on both WRT1200AC's , The reception seems ok , stability too but I think I've hit another problem. The drivers in use are CT's at the moment. Among the things I learned in this forum is that even though the capabilities include mesh support, the abandoned drivers do not, which I figured , ok no mesh... let's do WDS instead. But I cannot get the WDS nodes to connect to eachother. Using a wifi scanner I can see the WDS SID of 1 of both routers, but not the other.

They are identical though, I cloned the config/packages and made the minor changes before restoring the second one (ip, name) and followed the WDS guide to try all sorts of settings. Weirdly enough, the kernel log option in luci is not there, but I'm more of a cli person anyway, dmesg and logread do not really help me.
I do have the impression that they seem to not stop working but I haven't been using the wifi enough. They do work fast, the gui is flying, I have a EA8300 , MR8300 and 2 WRT1200AC's running and I can notice the difference. I'm having different issues with all of them, that exactly what I'm trying to do is just not working/supported and most seem to be a driver problem. But the EA/MR issue is off-topic here and I'm documenting it to start a new thread.

But it was worth testing out these snapshots. If only I could get WDS to work on these 2 WRT's I would be very happy. Only thing left to try is change the drivers.

@gplv2 Thanks for all the info and testing. I plan to update my WRT1200AC sometime this month from 19.07.8 to 21.02.2 snapshot. I am only using as single AP with no WPS on a non DFS 5GHz channel here. I will post and let everyone know how it goes. And, thanks to everyones hard work and communication.

1 Like

Hey,

Let me know if you want me to test this, the new routers (EA/MR) have replaced the 1200AC's here (thought I did my homework enough to have selected good alternatives). Seems that just the MR8300 covers the house enough so my kids mobile phone download limits doesn't get TikTokked in 4 days :stuck_out_tongue:

So for the moment, I can live with how it's setup here, the AC1200's I was thinking of using them to provide a backhaul to the upper floor (3 floors). I have a vertical coverage problem instead of a horizontal one. It's here that the EA/MR really have a problem, they can't even see eachother standing 5 meters away. I installed the 1200's to doublecheck this problem. So I'm tackling a few things at the same time, in that process learning a lot. But as I said, the WRT1200's are standing here not performing any real duties. I was one of those guys that bought those coming from WRT54G's being so happy with those devices until 1 fried up after many years. (rip my precious)

I'm going to keep researching/messing with the 1200's till I get WDS to work , not ready to give up.

Give me a ping when I can help

Got somewhere here. Seems I got the WDS to work in AP/Client mode , my ultimate goal would be AP/AP mode if possible. But I noticed some quite important thing to make it work is this:

  • for 5GHz : do not use a DFS channel. Switching to a non-DFS channel seems to do the trick, I didn't change too much else that can explain why it works all the sudden.
  • for 2.4GHz : worked out of the box, scan/join seems to have worked

I'm now looking into the interface setup, the extra added interface sta (on the AP node) confuses me a bit.

Here are "tze results" of the Belgian jury :slight_smile:

router3 (192.168.1.10) : AP
router4 (192.168.1.11) : WDS client (for both networks)

root@router3:~# iwinfo 
wlan0     ESSID: "dd-wds"
          Access Point: 00:25:9C:14:22:B9
          Mode: Master  Channel: 48 (5.240 GHz)
          Center Channel 1: 46 2: unknown
          Tx-Power: 23 dBm  Link Quality: 70/70
          Signal: -39 dBm  Noise: -91 dBm
          Bit Rate: 400.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan0.sta1 ESSID: unknown
          Access Point: 00:25:9C:14:22:B9
          Mode: Master (VLAN)  Channel: 48 (5.240 GHz)
          Center Channel 1: 46 2: unknown
          Tx-Power: 23 dBm  Link Quality: 70/70
          Signal: -39 dBm  Noise: -91 dBm
          Bit Rate: 400.0 MBit/s
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "wds2g"
          Access Point: 60:38:E0:0C:3D:6C
          Mode: Master  Channel: 1 (2.412 GHz)
          Center Channel 1: 1 2: unknown
          Tx-Power: 20 dBm  Link Quality: 70/70
          Signal: -25 dBm  Noise: -80 dBm
          Bit Rate: 144.4 MBit/s
          Encryption: none
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

wlan1.sta1 ESSID: unknown
          Access Point: 60:38:E0:0C:3D:6C
          Mode: Master (VLAN)  Channel: 1 (2.412 GHz)
          Center Channel 1: 1 2: unknown
          Tx-Power: 20 dBm  Link Quality: 70/70
          Signal: -25 dBm  Noise: -80 dBm
          Bit Rate: 144.4 MBit/s
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

root@router3:~# 

assoclist:

root@router3:~# iwinfo wlan0 assoclist
00:25:9C:14:22:B7  -39 dBm / -91 dBm (SNR 52)  540790 ms ago
	RX: 400.0 MBit/s, VHT-MCS 9, 40MHz, VHT-NSS 2        12 Pkts.
	TX: 400.0 MBit/s, VHT-MCS 9, 40MHz, VHT-NSS 2      1001 Pkts.
	expected throughput: unknown

root@router3:~# iwinfo wlan1 assoclist
00:25:9C:14:22:B6  -25 dBm / -95 dBm (SNR 70)  251950 ms ago
	RX: 144.4 MBit/s, MCS 15, 20MHz                   11 Pkts.
	TX: 144.4 MBit/s, MCS 15, 20MHz                 1021 Pkts.
	expected throughput: unknown

root@router4:~# iwinfo 
wlan0     ESSID: "dd-wds"
          Access Point: 00:25:9C:14:22:B7
          Mode: Client  Channel: 48 (5.240 GHz)
          Center Channel 1: 46 2: unknown
          Tx-Power: 23 dBm  Link Quality: 70/70
          Signal: -35 dBm  Noise: -93 dBm
          Bit Rate: 400.0 MBit/s
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "wds2g"
          Access Point: 00:25:9C:14:22:B6
          Mode: Client  Channel: 1 (2.412 GHz)
          Center Channel 1: 1 2: unknown
          Tx-Power: 20 dBm  Link Quality: 70/70
          Signal: -29 dBm  Noise: -79 dBm
          Bit Rate: 144.4 MBit/s
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

router4 assoclist

root@router4:~# iwinfo wlan0 assoclist
00:25:9C:14:22:B9  -35 dBm / -93 dBm (SNR 58)  860 ms ago
	RX: 400.0 MBit/s, VHT-MCS 9, 40MHz, VHT-NSS 2     12799 Pkts.
	TX: 400.0 MBit/s, VHT-MCS 9, 40MHz, VHT-NSS 2        13 Pkts.
	expected throughput: unknown

root@router4:~# iwinfo wlan1 assoclist
60:38:E0:0C:3D:6C  -29 dBm / -81 dBm (SNR 52)  810 ms ago
	RX: 144.4 MBit/s, MCS 15, 20MHz                12903 Pkts.
	TX: 144.4 MBit/s, MCS 15, 20MHz                   13 Pkts.
	expected throughput: unknown

So I must say, this looks promising tbh, I haven't done a single performance test yest, I really want stability first. But the snapshot release does seem to be more functional , it looks to me that the backported module is really working a lot better:

for both routers:

[   11.202450] Loading modules backported from Linux version v5.15.8-0-g43e577d7a2cb
[   11.209976] Backport generated by backports.git v5.15.8-1-0-g83f664bb
[   11.234157] <<Marvell Mac80211 Wireless PCIE Network Driver version 10.3.8.0-20181210>>
[   11.242280] pci 0000:00:01.0: enabling device (0140 -> 0142)
[   11.248074] ieee80211 phy0: priv->pcmd_buf = 57ea595d  priv->pphys_cmd_buf = 5fc81632
[   11.282236] ieee80211 phy0: fw download start
[   11.399514] ieee80211 phy0: FwSize = 118776 downloaded Size = 118776 curr_iteration 65497
[   12.358225] ieee80211 phy0: fw download complete
[   12.358240] ieee80211 phy0: device node: pcie@1,0
[   12.363615] ieee80211 phy0: pcmd = 57ea595d
[   12.381242] ieee80211 phy0: firmware version: 0x702091a
[   12.732222] ieee80211 phy0: firmware region code: 30
[   12.771176] ieee80211 phy0: 2G disabled, 5G enabled
[   12.776102] ieee80211 phy0: 2 TX antennas, 2 RX antennas
[   12.781663] pci 0000:00:02.0: enabling device (0140 -> 0142)
[   12.787479] ieee80211 phy1: priv->pcmd_buf = e95cc350  priv->pphys_cmd_buf = bfb26cbb
[   12.792266] ieee80211 phy1: fw download start
[   12.910812] ieee80211 phy1: FwSize = 118776 downloaded Size = 118776 curr_iteration 65511
[   13.868233] ieee80211 phy1: fw download complete
[   13.868265] ieee80211 phy1: device node: pcie@2,0
[   13.873569] ieee80211 phy1: pcmd = e95cc350
[   13.891249] ieee80211 phy1: firmware version: 0x702091a
[   14.241235] ieee80211 phy1: firmware region code: 30
[   14.277960] ieee80211 phy1: 2G enabled, 5G disabled
[   14.282896] ieee80211 phy1: 2 TX antennas, 2 RX antennas

I wonder if there is a more recent firmware for these wifi modules, I messed around with some but failed to load them as they were wrong ones.

Now I still have to check connectivity, they are now standing 2 meters from eachother. But the good news is this:

My setup is now:

MR8300 (WAN) -> mesh with EA8300 . This mesh only works when they are very close to eachother, that's the off-topic problem, but it does work , but not far away.
The EA8300 has/had both the 1200's plugged in via ethernet cable in it's lan ports: router3 and router4. When I unplug router4. it keeps working now! so I can confirm that this WDS mode seems to do what it is supposed to do.

All WDS's are bridged to the LAN ports. Looking at the packet count, the 2.4Ghz wds is selected for this link (wlan1). both TX/RX values rise when I type in commands over the WDS bridge.

Disabling the 2.4GHz wds radio's: keeps working and the counters rise on the 5GHz bridge, but of course, fact that I don't loose my ssh shells is already proof that it works.

This is really good news. I hope to be able to make AP - AP mode to work , afaik this should be possible too.

The backports of those drivers gets an A++

Hi all.
Very nice to see some possible progress about this issue.

Since the 21.02.2 version has been released 3 days ago, I think I'm going to test it on my side. I will try to keep you posted with my feedback.

Thanks everyone!
Justin

Hello,

Version 21.02.2 installed on monday morning, 5GHz WiFi band not functional any more since wednesday evening. Don't know what's happening and if it's related with the driver or not, but that's exactly the kind of problem I had with previous 21.x releases.

# iwinfo
wlan0     ESSID: "Home2"
          Access Point: 24:F5:A2:24:B9:A9
          Mode: Master  Channel: 149 (5.745 GHz)
          Center Channel 1: 155 2: unknown
          Tx-Power: 13 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -89 dBm
          Bit Rate: unknown
          Encryption: mixed WPA2/WPA3 PSK/SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "Home1"
          Access Point: 24:F5:A2:24:B9:A8
          Mode: Master  Channel: 6 (2.437 GHz)
          Center Channel 1: 6 2: unknown
          Tx-Power: 20 dBm  Link Quality: 67/70
          Signal: -43 dBm  Noise: -90 dBm
          Bit Rate: 92.5 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

wlan1.sta1 ESSID: unknown
          Access Point: 24:F5:A2:24:B9:A8
          Mode: Master (VLAN)  Channel: 6 (2.437 GHz)
          Center Channel 1: 6 2: unknown
          Tx-Power: 20 dBm  Link Quality: 66/70
          Signal: -44 dBm  Noise: -90 dBm
          Bit Rate: 72.2 MBit/s
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

Restarting the 'radio0' interface doesn't seem to help.
If someone can help troubleshooting this (s)he's welcome!

Justin

Try with just WPA2. see this if > 1 SSID on a radio.

2 Likes

Fresh 22.03-rc4 install. Can't get the 5GHz working either.

Avoid DFS channels, at least for testing. Using DFS channels implies at least 60s wait time before the channel may go up - and mwlwifi has never been good dealing with DFS to begin with (meaning it may fail if a radar is detected).

it's been a day and there isn't any radar on this frequency around here (plus the AP is in the basement)