5GHz Wifi AP does not show up (TL WDR4300)

Hello all

I am trying to use a TL WDR4300 with OpenWRT 19.07 (TP-Link TL-WDR4300 v1, Atheros AR9344 rev 2, OpenWrt 19.07.2 r10947-65030d81f3 / LuCI openwrt-19.07 branch git-20.057.55219-13dd17f) to create some WiFi extensions in another building where I get the Internet only with WiFi. The main router is an Orange Livebox 4 (dual band).
I have set up the LAN interface of the OpenWRT device to be static (in another subnet than the main router's LAN/WLAN).
On the OpenWRT device, I have scanned the available WiFi networks and joined the OpenWRT to the WiFi networks of the main router: I then have 2 Wireless clients, one in the 2,4GHz and one in the 5GHz. The wireless clients do work.

I have then created 2 wireless access points, one in the 2,4GHz and one in the 5GHz.
I have configured the networks accordingly, configured the FW to allow all traffic between the WWAN and LAN networks, with masquerading enabled.
The 2,4GHz AP shows up and I can connect devices to it, and the traffic is correctly routed/NATed.

The problem I have is that the 5GHz AP does not show up and no device can use it.
I have set the country code for the 5GHz driver to be FR (this is where I live).
No change.
I have set it to be IN (INdia) and the AP then sometimes shows up, but it is not stable (and it is not allowed here anyway).

I understand that this is certainly related to channel assignments/configuration.
The 5GHz Wifi Client uses N mode, channel 100 and 20MHz width.
I tried to set the 5GHz AP to use the same settings, I tried to play with the parameters, with no luck so far.

I could use some help or resources. I have a decent understanding of the logical layers in the network config, but I may miss some understanding of the physical implications, especially with channel assignments...

Thanks in advance for your help!

No advice for this problem? Maybe I am doing something wrong...

I have a similar problem as you can read here. Did you check log file?