5GHz not working on RT-AC88U

I have recently bought an RT-AC88U and flashed OpenWRT, everything seemed fine first. However, when I turn on the 5GHz it doesn't show up. The only way I can get it to show up on other devices is using channel 36, which someone pointed out in another thread on this forum. If I try connecting, however, it seems to still fail. I could not really make out why. Sometimes it says IP configuration fails, sometimes it says no Internet. I assume it has something to do with DHCP therefore. Does anybody know what I could be doing wrong or have any advice on troubleshooting this problem? I assume we can rule out the antennas being fried as they show up when using channel 36 (or am I in the wrong here)?

Read up from the vendor about the features of the device, don't play with the wifi settings to much. Set your zone in the main administration spot.
Pending on where you are, possibly that device supports WPA3. You should set to 80mhz, that is US an Ca standard. The 160 range don't use that, leave it, wireless G is old and and bounces around all over the place and down everywhere down the street.. Usually that gets shut off, You can just Maybe ADD another wifi access in luci in 5 g range for another lan from away Guest for example, if it supports it.
you can set wpa2-wpa3 mix on a separate br-lan. Roku boxes all use WPA2.
It is a very nice router, don't worry about all the fancy setting they say, as long as you have a secure WPA3 you should be good. By the looks on the spec sheet it supports Wifi 5, which is WPA3.
If that is the only device you have set the 2.4 for stuff you don't care about and set for WPA2-WPA3 mixed. 5G set WPA3 only.

Try setting it to auto and give it 5 minutes to do a DFS check, then paste the system log starting with the radio entries that follow. Remove any MAC addresses.

In the meantime:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

It is all Broadcom but they usually flag it if they cannot get FOSS for it.

Sometimes when the firmware is built there can just be a setting that needs a tweak, that is probably why the 5 g is not on. 80mhz WPA3 only, or mixed if you want, don't flip through all the channels there might only be 2-3 channels that work

When you play with the Wifi settings disable it, then tweak it, reboot.
Your messing stuff up if you don't disable the wifi first, work from the ethernet when you do that stuff

This is the output of the commands you asked for:

root@OpenWrt:~# ubus call system board
{
	"kernel": "6.6.73",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 0 (v7l)",
	"model": "ASUS RT-AC88U",
	"board_name": "asus,rt-ac88u",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "24.10.0",
		"revision": "r28427-6df0e3d02a",
		"target": "bcm53xx/generic",
		"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
		"builddate": "1738624177"
	}
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf0:ae84:ea38::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'extsw'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option type 'bridge'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option country 'CH'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country 'CH'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Notspot'
	option encryption 'psk2'
	option network 'lan'
	option key 'PASSWORD REDACTED'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option disassoc_low_ack '0'
	option network 'lan'
	option wmm '0'
	option key 'PASSWORD REDACTED'
	option ieee80211w '0'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Notspot_Guest'
	option encryption 'psk2'
	option key 'PASSWORD REDACTED'
	option network 'lan'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

1 Like

UPDATE: After some tinkering (I didn't really change much tbh) it just started working. It only works using WPA2-PSK though and not on auto mode, only when channel 36 is selected. It is, however, incredibly slow. I only reach around 20Mbit/s while I reach slightly over 100Mbit/s over 2.4GhZ. This should be the other way around right? Both are well under my data plan with my ISP so I'd rather expect something around a few hundred Mbit/s. Does anyone know why that could be the case?

Whatever changed is in the log; as pretty as your router is it does not contain pixie dust.

Well, that sucks.

Broadcom.

You have us in the dark without logs. The radios have no configuration errors, that I see.

1 Like

Whats the country being used in?

Switzerland, country code is CH. It's set for the wifi.

1 Like

I'm quite busy right now so I only had a quick glance at the logs and was able to find this:

Tue Feb 11 20:17:29 2025 user.info kernel: [   14.343569] kmodloader: done loading kernel modules from /etc/modules.d/*
Tue Feb 11 20:17:29 2025 kern.warn kernel: [   14.469416] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.txt failed with error -2
Tue Feb 11 20:17:29 2025 kern.warn kernel: [   14.480025] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.clm_blob failed with error -2
Tue Feb 11 20:17:29 2025 kern.warn kernel: [   14.490493] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.txcap_blob failed with error -2
Tue Feb 11 20:17:29 2025 kern.warn kernel: [   14.490752] brcmfmac 0001:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.clm_blob failed with error -2
Tue Feb 11 20:17:29 2025 kern.warn kernel: [   14.511386] brcmfmac 0001:01:00.0: Direct firmware load for brcm/brcmfmac4366b-pcie.txcap_blob failed with error -2
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.813834] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.825027] brcmfmac: brcmf_c_process_txcap_blob: no txcap_blob available (err=-2)
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.832894] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.834154] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4366/3 wl0: Nov  5 2018 03:11:08 version 10.28.2 (r769115) FWID 01-801fb449
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.844028] brcmfmac: brcmf_c_process_txcap_blob: no txcap_blob available (err=-2)
Tue Feb 11 20:17:29 2025 kern.info kernel: [   14.867289] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4366/3 wl0: Nov  5 2018 03:11:08 version 10.28.2 (r769115) FWID 01-801fb449

Could this be the problem? And, if yes, does anybody know what could fix it?

Another thing I noticed was that 5GhZ actually works when WMM is disabled. Otherwise it shows up, when on channel 36, but cannot be connected to. At least it works in combination with WPA2-PSK (WPA3 doesn't). The rest is all default settings. But disabling WMM makes my connection incredibly slow as it seems.

I'll have a look at the rest of the logs tomorrow and hopefully find out about what's going on.

So I was finally able to go through the whole log and redact everything.

This is the complete system log after a reboot with only the 5GHz radio enabled, and WMM enabled (this doesn't allow me to connect to the WiFi actually, although I tried anyway hoping it would enable me to see the error caused by WMM). When WMM is disabled it works, but is very slow. For some reason wired connections may be disconnected while I try to connect to the 5GHz radio. Might be a problem with DHCP. However, this doesn't seem to happen every time I try to connect for some reason.

Unfortunately the log was too large to upload here, so I uploaded it to my own webserver:
https://noelaeby.me/file_host/redacted_wmm_openwrt.txt

Do you see what might be causing the problem?

I had a look at the original thread by the guys who initially made this router work with OpenWRT. It seems they were able to achieve far better speeds. Do you think I should try an older version of OpenWRT maybe to see if it works better? Maybe this could help resolve the issue.

Thanks to you guys for all the help!

To show you a, fairly, uneventful boot (I installed SAMBA but I do not use it):

Wed Feb 12 09:23:54 2025 daemon.err collectd[3194]: Sleeping only 2s because the next interval is 477886.799 seconds in the past!
Wed Feb 12 09:23:56 2025 daemon.info hostapd: phy0-ap0: STA router IEEE 802.11: authenticated
Wed Feb 12 09:24:01 2025 daemon.notice hostapd: phy1-ap0: ACS-COMPLETED freq=5180 channel=36
Wed Feb 12 09:24:02 2025 daemon.notice netifd: Network device 'phy1-ap0' link is up
Wed Feb 12 09:24:02 2025 kern.info kernel: [   34.043888] br-lan: port 3(phy1-ap0) entered blocking state
Wed Feb 12 09:24:02 2025 kern.info kernel: [   34.049478] br-lan: port 3(phy1-ap0) entered forwarding state
Wed Feb 12 09:24:02 2025 daemon.notice hostapd: phy1-ap0: interface state ACS->ENABLED
Wed Feb 12 09:24:02 2025 daemon.notice hostapd: phy1-ap0: AP-ENABLED
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]: [2025/02/12 09:24:10.722640,  0] ../../source3/nmbd/nmbd_become_lmb.c:398(become_local_master_stage2)
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]:   *****
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]:
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]:   Samba name server OPENWRT is now a local master browser for workgroup WORKGROUP on subnet 192.168.1.1
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]:
Wed Feb 12 09:24:10 2025 daemon.err nmbd[3921]:   *****
Wed Feb 12 09:24:11 2025 daemon.info hostapd: phy0-ap0: STA 7c:2c:67:28:71:44 IEEE 802.11: associated (aid 1)
Wed Feb 12 09:24:11 2025 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED 7c:2c:67:28:71:44 auth_alg=sae
Wed Feb 12 09:24:11 2025 daemon.info hostapd: phy0-ap0: STA 7c:2c:67:28:71:44 WPA: pairwise key handshake completed (RSN)
Wed Feb 12 09:24:11 2025 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.216 7c:2c:67:28:71:44
Wed Feb 12 09:24:15 2025 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.216 7c:2c:67:28:71:44 espressif
Wed Feb 12 09:24:39 2025 daemon.info hostapd: phy1-ap0: STA 8c:ec:7b:ba:6d:24 IEEE 802.11: authenticated
Wed Feb 12 09:24:40 2025 daemon.notice hostapd: phy1-ap0: STA-OPMODE-N_SS-CHANGED 8c:ec:7b:ba:6d:24 2
Wed Feb 12 09:24:40 2025 daemon.info hostapd: phy1-ap0: STA 8c:ec:7b:ba:6d:24 IEEE 802.11: associated (aid 1)
Wed Feb 12 09:24:40 2025 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED 8c:ec:7b:ba:6d:24 auth_alg=sae
Wed Feb 12 09:24:40 2025 daemon.info hostapd: phy1-ap0: STA 8c:ec:7b:ba:6d:24 WPA: pairwise key handshake completed (RSN)
Wed Feb 12 09:24:40 2025 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED 8c:ec:7b:ba:6d:24

Little of 'do as I say, not as I do but my DHCP MACs are random so I only redacted my router's MAC.

The last reports from the radio are:

Tue Feb 11 20:17:38 2025 daemon.info hostapd: phy1-ap0: STA REDACTED_MAC IEEE 802.11: associated
Tue Feb 11 20:17:38 2025 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED REDACTED_MAC auth_alg=open
Tue Feb 11 20:17:38 2025 daemon.info hostapd: phy1-ap0: STA REDACTED_MAC WPA: pairwise key handshake completed (RSN)
Tue Feb 11 20:17:38 2025 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED REDACTED_MAC
Tue Feb 11 20:17:38 2025 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) REDACTED_IP REDACTED_MAC
Tue Feb 11 20:17:38 2025 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) REDACTED_IP REDACTED_MAC
Tue Feb 11 20:17:39 2025 daemon.err odhcp6c[2572]: Failed to send SOLICIT message to ff02::1:2 (Address not available)

So, the radio does connect. Then it drops a WiFi device:

Tue Feb 11 20:20:28 2025 daemon.info hostapd: phy1-ap0: STA REDACTED_MAC IEEE 802.11: disassociated
Tue Feb 11 20:20:28 2025 daemon.notice hostapd: phy1-ap0: AP-STA-DISCONNECTED REDACTED_MAC
Tue Feb 11 20:20:28 2025 daemon.info hostapd: phy1-ap0: STA REDACTED_MAC IEEE 802.11: disassociated

Did you disconnect on purpose?
@psherman, would you have a look at the logs and provide some feedback on the VLANs?

I say VLANs but that is because of all the WiFi APs. I do not see them.

Not trying to discourage you but have a look at this disclaimer about Broadcom routers:
https://openwrt.org/meta/infobox/broadcom_wifi

I know your router has Opensource drivers but how well they perform I do not know.
There probably is no support for things like WPA3 and 160 MHz channel width so use only basic settings.
Also there might not be support for all country codes better use US to start with.

In the end you might be better off using another third party firmware which uses the Broadcom proprietary drivers :frowning:

2 Likes

no issues with the network config, except maybe a minor unrelated nit about the fact that the wan interface has a bridge line that should not be there.

^^^ I suspect this is spot on, and likely the reason for the issues experienced.

2 Likes

Here it is:

[The only other device that has both Broadcom chips.]

(https://openwrt.org/toh/linksys/ea9500_v1)
The issue:
https://openwrt.org/docs/techref/hardware/soc/soc.broadcom.bcm47xx#wifi_drivers

They, usually, put that warning on every device they cannot get to work so the ASUS wiki needs an update.