5ghz networks not associated, sysupgrade not working

Model: Ubiquiti LiteBeam AC Gen2
Architecture: Atheros AR9342 rev 3
Target Platform: ath79/generic
Firmware Version: OpenWrt 23.05.0 r23497-6637af95aa / LuCI openwrt-23.05 branch git-23.236.53405-fc638c8

Hello, I am having quite a lot of problems that I am finding difficult to solve by myself.

  1. All of sudden the 5ghz has stopped working in client mode, scanning works fine but once is connected to a network it shows it as "Not Associated". Tried most of the country codes, channels, etc. 2.4ghz works fine.

  2. The device factory reset everytime is rebooted.

  3. It's not possible to downgrade using sysupgrade from both luci and ssh. Tried multiple openwrt versions but It has not effect whatsover.

root@OpenWrt:/tmp# sysupgrade -v -n openwrt-22.03.6-ath79-generic-ubnt_litebeam-
ac-gen2-squashfs-sysupgrade.bin
Mon Oct  9 22:19:09 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed
root@OpenWrt:/tmp# Connection to 192.168.1.1 closed by remote host.
Connection to 192.168.1.1 closed.
root@OpenWrt:/tmp# mtd -r write openwrt-22.03.6-ath79-generic-ubnt_litebeam-ac-g
en2-squashfs-sysupgrade.bin firmware
Unlocking firmware ...
Writing from openwrt-22.03.6-ath79-generic-ubnt_litebeam-ac-gen2-squashfs-sysupgrade.bin to firmware ...      
Rebooting ...
Connection to 192.168.1.1 closed by remote host.
Connection to 192.168.1.1 closed.

The most important issue to solve would be the 5ghz.
Thank you.

There is a bug that affects certain UI kit that prevents the system from properly writing to the flash storage... quite annoying:

The current solution is to use 22.03.6, installed using the factory image and TFTP.

Do i have to reinstall the ubiquiti firmware to install the factory image?

No, you can directly install the factory image of 22.03.6 (via tftp)