5ghz channel "Unknown"

Hi.

Recently been using OpenWRT - so kind of new to all of this.

However randomly a few of the routers I have installed lose 5ghz connectivity

5ghz      ESSID: "<REDACTED>"
          Access Point: <REDACTED>
          Mode: Master  Channel: unknown (unknown)  HT Mode: NOHT
          Center Channel 1: unknown 2: unknown
          Tx-Power: 24 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: -92 dBm
          Bit Rate: unknown
          Encryption: mixed WPA2/WPA3 PSK/SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: embedded [MediaTek MT7981]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

If I disable and re-enable the wlan1 interface, it choses a new channel and starts working again.

The channel setting is on auto - is that not recommended?

I imagine this is DFS related ( i can't tell you what the channel was on previously) but its not likely there was an actual RADAR in the area

Does anyone have any troubleshooting steps I can take to track this down?

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05-SNAPSHOT, r23851-eda76b336b
 -----------------------------------------------------

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@Router1:~# ubus call system board
{
	"kernel": "5.15.155",
	"hostname": "Router1",
	"system": "ARMv8 Processor rev 4",
	"model": "Cudy WR3000 v1",
	"board_name": "cudy,wr3000-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05-SNAPSHOT",
		"revision": "r23851-eda76b336b",
		"target": "mediatek/filogic",
		"description": "OpenWrt 23.05-SNAPSHOT r23851-eda76b336b"
	}
}
root@Router1:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd0d:9e5b:86a9::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'pppoe'
	option proto 'pppoe'
	option device 'wan'
	option username 'PPPOEUSERNAME'
	option password 'PPPOEPASSWORD'
	option ipv6 'auto'

root@Router1:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wifi'
	option channel 'auto'
	option band '2g'
	option htmode 'HE20'
	option disabled '0'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '<REDACTED>'
	option encryption 'sae-mixed'
	option key '<REDACTED>'
	option ifname '2.4ghz'
	option ieee80211r '1'
	option nasid '2.4ghz'
	option mobility_domain '4f57'
	option ft_over_ds '0'
	option ieee80211k '1'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option proxy_arp '1'
	option wps_pushbutton '1'
	option ft_psk_generate_local '0'
	option reassociation_deadline '20000'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/18000000.wifi+1'
	option channel 'auto'
	option band '5g'
	option htmode 'HE80'
	option disabled '0'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<REDACTED>'
	option encryption 'sae-mixed'
	option key '<REDACTED>'
	option ifname '5ghz'
	option ieee80211r '1'
	option nasid '5ghz'
	option mobility_domain '4f57'
	option ft_over_ds '0'
	option ieee80211k '1'
	option wnm_sleep_mode '1'
	option wnm_sleep_mode_no_keys '1'
	option bss_transition '1'
	option proxy_arp '1'
	option wps_pushbutton '1'
	option reassociation_deadline '20000'

root@Router1:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	list dhcp_option '125,00:00:0D:E9:1C:04:06:38:30:41:46:43:41:05:0C:38:30:41:46:43:41:32:34:32:37:33:36:06:04:43:75:64:79'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@Router1:~# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option flow_offloading '1'
	option flow_offloading_hw '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'pppoe'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include 'cwmp'
	option path '/etc/firewall.cwmp'
	option reload '1'

config include 'twamp'
	option path '/etc/firewall.twamp'
	option reload '1'

config include 'port_hook'
	option path '/etc/firewall.portmap'
	option reload '1'

config include 'service_hook'
	option path '/etc/firewall.service'
	option reload '1'

config rule
	option name 'cwmp'
	option target 'ACCEPT'
	option dest_port '7547'
	option src 'wan'

config rule
	option name 'mactelnet'
	option target 'ACCEPT'
	option dest_port '20561'
	option src 'wan'

config rule
	option name 'remoteaccess_ssh'
	option target 'ACCEPT'
	option dest_port '22'
	option src 'wan'

config rule
	option name 'remoteaccess_web'
	option target 'ACCEPT'
	option dest_port '80'
	option src 'wan'

config rule
	option name 'web_ci'
	option target 'ACCEPT'
	option dest_port '7681'
	option src 'wan'

root@Router1:~# 

This is the 2nd router to exhibit this issue (same build), so im sure it will happen again at some time. Happy to run any other tests while the issue is "live"

I'd start by upgrading to a stable release.

https://firmware-selector.openwrt.org/?version=23.05.3&target=mediatek%2Ffilogic&id=cudy_wr3000-v1

1 Like

It's usually recommended to set an explicit channel, you might very well hit a DFS event if auto settled on a DFS channel (which is likely), logread should tell you more about it.

That should be 30-120s new auto-select max if radar is hit, not permanent DoS

10 minutes under some circumstances, but 120s might already feel 'permanent' to many users.

2 Likes

If one roams bands it is unnoticeable. (*) My tv stutters once a week but no clicking service needed

Thanks.

I'll udate to the stable build - not sure how i missed that!

Regarding DFS - my suspicion is that it thinks theres a RADAR and then dies.

What i'll do when i find this again is note the time of the interface channel being unknown then come back 30 minutes and reconfirm thats the case.

Why i think this is that there was nothing in logread, which makes me think that it was in this state for a while before I picked it up

It should be crealy writeen in the logread as DFS-RADAR-DETECTED

Why do you think that? It can be anywhere. Radar is probably much more common than you think.

Also, to be safe, any signal not recognised as wi-fi will be assumed to be radar. This can include weak signals from neighbours, noise from microwave ovens, unexpected actual radars like the lane-keeping system on some modern cars, weather satellites passing 300Km overhead and more.

Weather radars make 3d cloud map 50km around airfields.
You can disable DFS with hostapd parameter but i'd recommend manual tuning
iw reg set 'BE' ; iw list

....
                Frequencies:
//80MHz no-dfs
                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
//80MHz DFS somewhat weaker. 
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
//80MHz DFS stronger channel
                        * 5500 MHz [100] (26.0 dBm) (radar detection)
                        * 5520 MHz [104] (26.0 dBm) (radar detection)
                        * 5540 MHz [108] (26.0 dBm) (radar detection)
                        * 5560 MHz [112] (26.0 dBm) (radar detection)
//another DFS stronger
                        * 5580 MHz [116] (26.0 dBm) (radar detection)
                        * 5600 MHz [120] (26.0 dBm) (radar detection)
                        * 5620 MHz [124] (26.0 dBm) (radar detection)
                        * 5640 MHz [128] (26.0 dBm) (radar detection)
// not 80MHz strong - see last band
                        * 5660 MHz [132] (26.0 dBm) (radar detection)
                        * 5680 MHz [136] (26.0 dBm) (radar detection)
                        * 5700 MHz [140] (26.0 dBm) (radar detection)
OUCH                        * 5720 MHz [144] (13.0 dBm) (radar detection)
// 80MHz super weak or 40MHz ok
                        * 5745 MHz [149] (13.0 dBm)
                        * 5765 MHz [153] (13.0 dBm)
                        * 5785 MHz [157] (13.0 dBm)
                        * 5805 MHz [161] (13.0 dBm)
// not 80MHz again
                        * 5825 MHz [165] (13.0 dBm)
                        * 5845 MHz [169] (13.0 dBm)
                        * 5865 MHz [173] (13.0 dBm)
                        * 5885 MHz [177] (disabled)

In EU you can use

option channels '36 100 116` 

If you are knocked off both strong channels you can add 52, if you have 100Mbps internet you can add whole plenty of strong 40MHz channels.

Weather radars make 3d cloud map 50km around airfields.

I guess this was meant for @ryanistryin , but yes.

Indeed, but is illegal in the EU as far as I know, not that anyone would notice until a plane crashed on their heads :skull_and_crossbones:

https://w1.fi/cgit/hostap/tree/hostapd/hostapd.conf#n216
Which law it breaks?

Regulation:
https://eur-lex.europa.eu/legal-content/EN/TXT/PDF/?uri=CELEX:32022D0179

Penalties vary from country to country.

Actually, your link describes how to disable the use of DFS channels, not how to disable DFS ....