5GHz channel selection in Germany

Dear forum members,

I am using the latest 19.07.5 release on my TP-Link RE450(EU) V.1.0. I would like to use the auto feature for the channel selection to choose a 5 GHz channel.

I selected Germany as country but openwrt chooses to select channels > 140 which are not supported / allowed for unlicensed indoor use in Germany and which my clients do not find when searching for available network connections. How can I force openwrt to only choose channels <= 140 for 5GHz?

Channels 140 - 144 are allowed in germany.

Check this post for limiting channels

Thanks, but channels > 140 are only allowed for Short Range Devices with a maximum of 25mW and all my WLAN devices from different manufacturers only work up to channel 140 and do not find any networks operating above nor can I select channels > 140. So I would assume that in Germany WLAN supports only channels up to 140 and channels above it are only to be used by other network types (Bluetooth, NFC).

And still: why does openwrt choose channel 149 which is out of scope anyway because > 5,725 GHz

Maybe the whole problem is because you forgot to select the country code in advanced settings? The guess is that your router is capable of 30 dBm and defaults to the US country code, where 149 is indeed the lowest channel where this high transmit power is legal to use.

Actually, World (00) is a valid setting, and initiating Tx is not permitted on that country setting. Therefore, if World is set, you cannot be an AP. Nontheless, the OP noted:

Can we verify this?


Unless something has changed, per this:

It should pick Channel 32.

  • That's the range in which DFS is required; not the top limit of the allow range - which I assume matches the rest of Europe. This makes the last channel 173.
  • OpenWrt uses the same regdb as maintained upstream, so all devices using it behave in this manner.

Lastly, regdb:

country DE: DFS-ETSI
	(2400 - 2483.5 @ 40), (100 mW)
	(5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
	(5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW, wmmrule=ETSI
	(5470 - 5725 @ 160), (500 mW), DFS, wmmrule=ETSI
	# short range devices (ETSI EN 300 440-1)
	(5725 - 5875 @ 80), (25 mW)
	# 60 GHz band channels 1-4 (ETSI EN 302 567)
	(57000 - 66000 @ 2160), (40)
  • please confirm if you are setting: 20, 40 or 80 MHz bandwidth
  • please confirm your power setting

Thanks for all the replies. Yes, Country Code is DE - Germany, I am on 80MHz bandwith and on "driver default" which is currently 26dBm. I was not aware that "Auto Channel" just picks the first available channel without any intelligence. I decided to manually select channel 128 and keep it that way.

At the moment I am a bit confused if it is allowed to use channel 144 in Germany.

I have set the channel on my access point (AVM FRITZ!Repeater 3000) to "auto", the channel 132 is selected.

Channel 132 with 80Mhz -> Channel 132, 136, 140, 144

Channel 132 (5650-5670 MHz)
Channel 136 (5670-5690 MHz)
Channel 140 (5690-5710 MHz)
Channel 144 (5710-5730 MHz)

In Germany, according to the Bundesnetzagentur, the ranges 5.150 MHz - 5.350 MHz and 5.470 MHz - 5.725 MHz must be used.
So Channel 144 would not be allowed anymore (5730 MHz is larger than 5725 MHz) , therefore also the combination Channel 132 with 80Mhz would not be allowed, do I see that correctly?

On Wikipedia Channel 144 is displayed as green in Europe?
According to Heise also only the channels (channel 100 to 140) are allowed. https://www.heise.de/ct/artikel/Technische-Kniffe-beim-Gigabit-WLAN-1897988.html?seite=all

Why is channel 144 used by Openwrt in germany?