5GHz channel scanning does not work on TP-Link Archer C2600

Can anyone help?

From ssh, where wlan0 is the 5GHz radio
iwinfo wlan0 scan
immediately returns
Scanning not possible

iwinfo wlan1 scan
returns a list of over 50 cells on the 2.4GHz band after about 3 seconds.

Getting the scanning working is important to me as I live in a very densely populated area and have seen as many as 160 cells on the 2.4GHz band.

I have seen that channel scanning of 5GHz occasionally works when I disable the 5GHz SSID. However this is not consistent. Sometimes scanning continues working even after the SSID is re-enabled. Other times, scanning does not work when the SSID is disabled.

Currently running 21.02 and this issue was also present in 19.07.

Scanning while being tuned into a DFS channel can be tricky (also depending on your regulatory region), this is more complex than 2.4 GHz.

Regulatory region is SG / Singapore

I tried setting the 5GHz channel to 36 and tried iwinfo wlan0 scan. I found that it worked about 1 time in 3 (i.e. did not return Scanning not possible).

Of course, what I found is that there are about 20 other cells on channel 36 (all 80MHz wide) and about 20 cells on channel 149 (again 80MHz). The channels in between are the Singapore DFS channels and are mostly unused in my neighbourhood.

So I see your point about the DFS making it complex, but believe that there is still an issue with scanning 5GHz even when not on a DFS channel.

I don't experience this issue with any of the 4 C2600 I have.

Using 21.02.0. Regulatory domain is CA. Saw no issues w/19.07.x.

I'm using 40MHz wide bands on non DFS channels as the spectrum is not crowded where I am. DFS has always been a pain. I've only seen those channels used a couple of times. Almost anything trips the routers into sensing a radar pulse and jumping to non DFS channels. I see the same behaviour with the C2600's and with some ath79 devices I have around.

Scanning works all the time, through terminal (ssh) and through Luci.

I don't have anything special in config. Here it is in case it helps you:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '157'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT40'
        option country 'CA'
        option beacon_int '200'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key '...'
        option ssid '...'
        option wpa_disable_eapol_key_retries '1'
        option disassoc_low_ack '0'

Hello, I had the same issue and like Slh said, needed to first fixed a non-dfs channel, such as 149/161/165/etc, then scanning worked.

For my installation, even when locked on a non-DFS channel, scanning work only 1 time in 3. I believe that there is more to this issue but do not have the knowledge to investigate more deeply.

Sorry, didn't see the title reads C2600.


1 Like