5GHz auto channel issue

Hi All

i have ZBT WE1326 router with OpenWrt 18.06.5. All works fine except one thing.

When i set channel to auto on 5GHz interface the Wi-Fi does not show up.

Could you please help me to start troubleshooting what might be wrong in my case?

I donn't really know where to start looking...

Thank you.

You should post your wireless config so someone can check for any other mistakes, but "auto" generally should not be chosen as it doesn't do anything except pick the first channel.
Try setting it just to 36.

2 Likes

Thanks for your reply.

I would like the channel to be selected automatically as i live in the enviornment with many 5GHz access points around so i would prefer that it would select the less occupied channel automatically.

Any hints how to get the Wi-Fi config so i could post it here?

Thank you.

WIFI Advanced -> program your Country as FR , BE, US, CN , …

Your expectation: AUTO should search for a channel within the legally allowed range that is not croweded and provides best performance.

Reality: "Auto" only selects the first available channel (as defined by the hardware constraints and legal limitations, not any more advanced channel survey) - not more, not less.

5 Likes

At the command line, cat /etc/config/wireless and post here. Mindful to redact any passwords.

As tmomas said though, the reality is quite different to what you're hoping for.

To be complete, there is an ACS algorithm, but it needs to be compiled in and I don't know if this works well...


This thread has more detailed analysis, but you'd need to compile your own image.

Thank you for all your replies. For some reason i thought that todays routers are using some sort of algorithms to select best channel.

Anyway, here is my config:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option legacy_rates '1'
        option htmode 'HT20'
        option country 'ES'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option key 'password'
        option wpa_disable_eapol_key_retries '1'
        option disassoc_low_ack '0'
        option ssid 'network'
        option short_preamble '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option legacy_rates '0'
        option country 'ES'
        option channel '36'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'network'
        option disassoc_low_ack '0'
        option encryption 'psk2+ccmp'
        option key 'password'
        option wpa_disable_eapol_key_retries '1'

Anybody can figure out why auto on radio1 is not working in my case?

I'm puzzled: using v18.06.4 my 4040 has "auto" both on 2.4GHz (HT20) and 5GHz (VHT80) and it is using channel 6 and channel 52.

Granted, on 5Ghz the radar scan could be the reason but... which other constraints could cause it to use channel 6?

I have just noticed that while on auto set on 2.4GHz it did not take first channel. Yesteday it was on channel 8, today it is on channel 7.

So it looks like there is something what causes channel selection this way...

Channel 6 is often the default in 2.4 GHz band, since it's often 1, 6, 11 the 3 channels that do not interfere each other with 20 MHz width

Channel 52 instead of 36 cannot be for the DFS, since actually channel 36 is the only one DFS free on 80 MHz width

You can find some DFS issue relaed info here: https://www.signorini.ch/?p=974

1 Like

Thanks, I played around a bit and went for 11 / 124(122).

with pandorabox firmware ( openwrt clone ) i have a similar problem with last firmare 19.02

with old version 18.07 not this problem

test with another OpenWRT version