5 GHZ Wireless AC IPV6 performance VERY SLOW on OpenWrt Trunk

I've got a Windows 7 PC on Internet #1 and another Windows 10 PC on Internet #2

I have 2 - Tenda U12 AC1300 USB 3 adapters plugged into USB 3 ports on each machine

The 2 Tenda U12's connect to a TP-Link Archer C7 V3 flashed with latest OpenWRT Trunk (12/31 image build)

The Tenda U12's are connected 5GHZ & IPV6 to the TP-Link Archer C7 V3

The only thing the TP-Link Archer C7 V3 does is connect the 2 Tenda U12's -- this router is not connected to the internet.

The reported speeds are showing around 600-800mbps connection rates and getting 90% signal

Problem is when I'm doing file sharing and transferring the files, I get anywhere from 10-20 MB/s rates

Even at 50% performance (400mbps) -- shouldn't I be getting close to 50 MB/s transfer rates?

Am I missing some settings or is there anything to tweak?

Only reason I'm using these via the TP-Link Archer C7 V3 router is that the adapters don't support ad-hoc mode for some reason

The adapters are using the latest WHQL drivers and have no issues with connection.

Password protected Shares in each Windows and using WPA2-PSK for encryption.

Any help/suggestions on how to get faster transfer rates?

  • Wait...what does this have to do with OpenWrt?
  • And did you see this:

Screenshot from 2019-12-31 16-03-12

https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500

Odd...they should.

From that Nat Performance page:

The WLAN↔LAN throughput of Archer C7 2.0 with OpenWrt Chaos Calmer RC3 was measured to be substantially lower than that of the native firmware. (450 to 500Mbps with OpenWrt vs. 750 to 800Mbps with native firmware, both measured under conditions close to ideal).

I'd be happy with 450-500mbps performance.

If I'm barely hitting 20 MB/s (less than 200mbps) then I can't figure out if it's some configuration issue or something else I'm not seeing.

Can you run top -d 1 on the router over ssh and see how much idle CPU is still available?

I tried IPV4 and IPV6 -- no difference in speeds on either.

I even tried a LEDE Optimized build I found doing Google searching and no difference.

I flashed the router back to a Beta build I found online for the TP-Link Archer C3 and instead of 10-15 MB/s, I was able to get around 20-25 MB/s transfer rates - same setup.

I am wondering if the wireless adapter drivers are not the greatest either.

But I can live with the 20-25 MB/s transfer rates with the stock Beta firmware for now.

OpenWrt is using CPU for routing while the stock could using HW acceleration. If there is no idle CPU left, that is your max speed. You still have not provided the CPU utilization info.

1 Like
Mem: 64460K used, 58920K free, 788K shrd, 4932K buff, 14008K cached
CPU:  40% usr   0% sys   0% nic   0% idle   0% io   0% irq  60% sirq
Load average: 0.64 0.34 0.25 3/63 4968
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
    7     2 root     RW       0   0%  36% [ksoftirqd/0]
 4966  2222 root     R     3036   2%  18% [luci]
 1240     1 root     S     2192   2%   9% /sbin/rpcd -s /var/run/ubus.sock -t 30
 2222     1 root     S     1364   1%   9% /usr/sbin/uhttpd -f -h /www -r OpenWrt -x /cgi-bin -t 60 -
  606     1 root     S     1268   1%   9% /sbin/ubusd
 4967  4691 root     R     1208   1%   9% top -d 1
 4938     2 root     IW       0   0%   9% [kworker/0:1-eve]
 2500     1 root     SN    4288   3%   0% /usr/sbin/collectd -C /tmp/collectd.conf -f
 2338     1 root     S     2480   2%   0% /usr/sbin/nmbd -F
 3559  3414 root     S     2472   2%   0% /usr/sbin/cifsd --n
 3414     1 root     S     2444   2%   0% /usr/sbin/cifsd --n
 2337     1 root     S     2432   2%   0% /usr/sbin/smbd -F
 4191     1 root     S     1824   1%   0% /usr/sbin/hostapd -s -n phy0 -g /var/run/hostapd-phy0/glob
 1115     1 root     S     1728   1%   0% /usr/sbin/wpa_supplicant -s -n phy1 -g /var/run/wpa_suppli
 1114     1 root     S     1728   1%   0% /usr/sbin/hostapd -s -n phy1 -g /var/run/hostapd-phy1/glob
 1113     1 root     S     1728   1%   0% /usr/sbin/wpa_supplicant -s -n phy0 -g /var/run/wpa_suppli
 1462     1 root     S     1704   1%   0% /sbin/netifd
    1     0 root     S     1588   1%   0% /sbin/procd
 1542     1 root     S     1444   1%   0% /usr/sbin/odhcpd
 2539     1 dnsmasq  S     1340   1%   0% /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf.cfg01411c -k -x
 1195     1 root     S     1244   1%   0% /sbin/logd -S 64
 4691  4681 root     S     1216   1%   0% -ash
 1916  1462 root     S     1208   1%   0% udhcpc -p /var/run/udhcpc-eth0.2.pid -s /lib/netifd/dhcp.s
 3475     1 root     S<    1208   1%   0% /usr/sbin/ntpd -n -N -S /usr/sbin/ntpd-hotplug -p 0.openwr
 4681  1380 root     S     1144   1%   0% /usr/sbin/dropbear -F -P /var/run/dropbear.1.pid -p 22 -K
 1380     1 root     S     1076   1%   0% /usr/sbin/dropbear -F -P /var/run/dropbear.1.pid -p 22 -K
 3557     1 root     S     1048   1%   0% /usr/sbin/vnstatd --nodaemon

The above was taken during a file transfer of 8GB ISO file.

The connections on the Windows 7 and Windows 10 PC's both show connected at 867 Mbps

I took the capture about 3 mins into the transfer. Average transfer in Windows was showing around 15-16 MB/s transfer rate.

Here you go: 100% CPU usage.

Do you have LuCI open and it is auto refreshing? You could free up some CPU here.

1 Like

Yes LUCI was open while I was doing that but it looks like it is what you suggested above and the CPU is maxed out.

I've got multiple routers, so I'll just have to use stock with this one for the internal WiFi LAN connection to maximize the bandwidth I get.

Luckily I got these cheap!

you're using 5ghz on archer to transmit and receive simultaneously and that cuts your bandwidth at least by half. then ath10k driver is not that advanced as stock driver resulting in more bandwidth loss. and finally it is running on newer kernels that are resource hungry and non-optimized like stock 2.6 kernel that probably run with some proprietary hw offload technique. what performance do you get if you connect one PC with cable?

The main need for my setup is it has to be a wireless connection.

LAN wired performance is probably better, but since those 2 computers already have the LAN ports used for the internet connections, I only have wireless avalable to connect them.

last thing you could try is connecting one of them to 2.4 network

Unfortunately that would not solve the issue. I actually had 2 wireless N USB devices hooked up to the 2 computers via ad-hoc connection and they were topping off at around 10mbps transfer rates.

My hope was to use the 5GHZ band in order to get at least double or more the bandwidth, but it seems the router is maxed out at that point.

I'm good with the 15-25 MB/s transfer rate how it is as I'm just using them to backup files to each computer.

By the way, for just regular internet access, the Archer C7 V2/V3 models have been quite awesome.

Internet #1 is at 50 MB/s max download, and Internet #2 is at 100 MB/s max download, so the routers work perfectly fine for those speeds.

ad-hoc/p2p are often limited in driver to 20mhz mode. just got the idea you might achieve high throughput if you can set up TDLS connection