5 GHz Network randomly stops working on TP-Link TL-WDR3600 v1

Hi!

I configured my TP-Link TL-WDR3600 v1 to use both, 2,4 GHz and 5 GHz. Previously I used the same ESSID for both bands, but since I recently changed the names to distinguish the two bands, I realized, that the router seems to randomly turn off 5 GHz.

When I restart the router and do a scan with a separate device, I sometimes can see the 5 GHz wifi coming online, but when I check back a couple of hours later, only the 2,4 GHz wifi is online.

Even in the routers own channel analysis I cannot see the wifi it should provide.

Please check the screenshots below to see my config.

I also have a secondary router (TP-Link TL-WDR4300 v1) in another room. This one works as expected.

Can you help me to figure out how to keep 5 GHz on the WDR3600 online?

Thank you in advance for your help and please let me know if I can provide more information!

Channels 116-132 overlap with Weather or Doppler Radar. I recommend choosing a channel between 36-48 (UNII-1) or 149-161 (UNII-3), so you avoid anything DFS.

Thank you @KrypteX!

Is this also the case for Europe (I live in Austria)?

I found this information https://www.rtr.at/TKP/was_wir_tun/telekommunikation/spectrum/bands/5000MHz/Spektrum5GHz.de.html

For Europe/ ETSI, only ch36-ch48 don't need DFS (yes, ch149-ch173 don't need it either, but those are short range channels, at severely reduced txpower - maybe good enough for single-room-coverage, but not normal usage).

I see!

Unfortunately most other channels are used already (see image below).

However, do you think my less than ideal channel choice is related to the problem that the wifi signal isn't visible, even when I stand right next to the router?

Also, why does Luci say for my second 5 GHz SSID (called "RoboterParty", see image above) "Wireless is not associated"?

Here's an image of the WDR3600's channel analysis on 5 GHz:


Note that

  • my other router's networks are both visible
  • the WDR3600's 5 GHz networks are not present even for the router itself.

https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt?id=HEAD#n667
Or you can see channels in iw list
More or less:

option channels='36 42 100 108 116 124'
option channel='auto'

so, if I get you right, @brada4, channel 124 is okay...?

I just switched to channel "auto" which had the effect that the wifi is working - at least for the moment...

Still don't understand what seemed to be the problem...

ch124 is allowed, but a DFS channel, which isn't what you appear to want.

1 Like

I see! One problem might be, that I don't know what DFS is :slight_smile:

Previously I had my WDR4300 on channel 124 and the "problematic" WDR3600 on channel 116. Also then, the WDR4300 worked and the WDR3600 didn't, so the channel switch didn't do the trick...

I will now try to find out what DFS is

You need to set channels option besides channel 124 so that it can escape DFS. 36 is quite busy and unlikely to be selected even in full range ACS.

I see. Thank you!

I now switched to channel "auto". Maybe this is even the best idea...?

One additional question:

In order to use 802.11r Fast Transition, is it a good idea to use the same ESSID for all participating networks or is it also possible to have different names?

Thank you once more!

There is no need whatsoever for fast transition. Modern operating systems roam freely without extra crypto tweaks.
Not ONLY set channel to auto, it may land in 13dBm upper channels, you need to set explicit "channels" option to exclude those weak ones.

1 Like

Is this possible in Luci or would I need to do that in the config files?

In principle, I don't mind too much about weak channels, as I cover 75 m² with two routers :slight_smile:

Would you say Fast Transition does more harm than good or is it still a good legacy for older devices?

You need to edit config file /etc/config/wireless , in wifi position over "channel" in 5ghz radio, press o (letter small OWW)
in new line type
(tab) option channels '.....' (esc):wq
then restart interface from luci

or install nano.

1 Like