4x AP + 802.11s + batman-adv = network crash

Hi. I have mesh network consisting of 4x Cudy x6 running latest stable OpenWRT, 3 of them running as batman-adv (including vlans) wireless clients and the last one is a gateway bridged as a trunk to my wired LAN thorough one of LAN ports. Until I had just 3 AP whole network was quite stable, but after adding fourth to the mesh for about a minute everyting runs fine, but after a minute ping between mesh points start increasing up to thousands of ms and the whole mesh crashes. If I disconnect one of AP from power, no matter which one, after a while mesh start working again with resonable ping and peformance. All APs have the same config except hostname and lan IP, 3 of them configured as batman client, last as batman server. Since few days I'm trying to debug this problem but nothing helps and I'm running out of ideas. Any help?

Exaxmple config of one of APs:

cat /etc/config/network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4d:ce47:87fd::/48'
        option packet_steering '1'

config device 'device1'
        option bridge_empty '1'
        option ipv6 '0'
        option multicast_querier '1'
        option name 'br-lan'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        option type 'bridge'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.10.1'
        option broadcast '192.168.10.255'
        list dns '192.168.10.1'
        option device 'bat-vlan1'
        option delegate '0'
        option ipaddr '192.168.10.5'

config device 'device2'
        option ifname 'br-lan'
        option ipv6 '0'
        option name 'br-lan.1'
        option type '8021q'
        option vid '1'

config bridge-vlan 'bridge_vlan1'
        option device 'br-lan'
        list ports 'bat0.1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'
        option vlan '1'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option bridge_loop_avoidance '1'
        option hop_penalty '30'
        option delegate '0'
        option gw_mode 'client'
        option aggregated_ogms '1'
        option defaultroute '0'

config interface 'batmesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option defaultroute '0'
        option delegate '0'

config device 'device3'
        option ipv6 '0'
        option name 'bat-vlan1'
        list ports 'bat0.1'
        option type 'bridge'

config device 'device4'
        option ipv6 '0'
        option name 'bat-vlan3'
        list ports 'bat0.3'
        option type 'bridge'

config device 'device5'
        option ipv6 '0'
        option name 'bat-vlan4'
        list ports 'bat0.4'
        option type 'bridge'

config device 'device6'
        option name 'lan4'

config interface 'home'
        option device 'bat-vlan1'
        option proto 'none'

config interface 'Kids'
        option proto 'none'
        option device 'bat-vlan4'
        option delegate '0'

config interface 'LAN4_MANAGEMENT'
        option proto 'static'
        option device 'lan4'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config device
        option name 'm-11s-0'
        option ipv6 '0'

config device
        option name 'bat0'
        option ipv6 '0'