4G router randomly stopped working. "No internet" error, WiFi works (ZBT-S600, Quectel RM-502Q 5G)

Hello - I would appreciate any help with my ZBT-S600 modem / router combo, running openwrt chaos calmer 15.06.1 - 21.0425_173900 (manufacture OEM build). Working with a Quectel RM-502Q 5G Modem.

When I got it, I set the apn to T-Mobile and everything worked fine for months. Randomly, the internet stopped working and I kept on getting a "no internet" error, "connected with no internet" it stated. I am very, very new to this so unsure how to proceed. I never changed anything but the APN and it worked fine. I factory reset it, set the apn and it does not work.
I can confirm it's not the SIM as it works fine on other routers.

I learned how to pull the configuration files, so here are the firewall, DHCP, wireless and network config files. If any errors, I would appreciate if you can teach me how to edit the files.

Thank you

	"kernel": "4.4.60",
	"hostname": "Router",
	"model": "Qualcomm Technologies, Inc. IPQ807x\/AP-HK09",
	"release": {
		"distribution": "OpenWrt",
		"version": "Chaos Calmer",
		"revision": "21.0425_173900",
		"codename": "chaos_calmer",
		"target": "ipq\/ipq807x_64",
		"description": "OpenWrt Chaos Calmer 15.05.1"

/etc/config/firewall

config defaults

	option syn_flood '1'

	option input 'ACCEPT'

	option output 'ACCEPT'

	option forward 'REJECT'

	option disabled '0'



config zone

	option name 'lan'

	list network 'lan'

	option input 'ACCEPT'

	option output 'ACCEPT'

	option forward 'ACCEPT'



config zone

	option name 'wan'

	list network 'wan'

	list network 'wan6'

	list network '4g'

	list network 'cellular'

	option input 'REJECT'

	option output 'ACCEPT'

	option forward 'REJECT'

	option masq '1'

	option mtu_fix '1'



config forwarding

	option src 'lan'

	option dest 'wan'



config rule

	option name 'Allow-DHCP-Renew'

	option src 'wan'

	option proto 'udp'

	option dest_port '68'

	option target 'ACCEPT'

	option family 'ipv4'



config rule

	option name 'Allow-Ping'

	option src 'wan'

	option proto 'icmp'

	option icmp_type 'echo-request'

	option family 'ipv4'

	option target 'ACCEPT'



config rule

	option name 'Allow-IGMP'

	option src 'wan'

	option proto 'igmp'

	option family 'ipv4'

	option target 'ACCEPT'



config rule

	option name 'Allow-DHCPv6'

	option src 'wan'

	option proto 'udp'

	option src_ip 'fe80::/10'

	option src_port '547'

	option dest_ip 'fe80::/10'

	option dest_port '546'

	option family 'ipv6'

	option target 'ACCEPT'



config rule

	option name 'Allow-MLD'

	option src 'wan'

	option proto 'icmp'

	option src_ip 'fe80::/10'

	list icmp_type '130/0'

	list icmp_type '131/0'

	list icmp_type '132/0'

	list icmp_type '143/0'

	option family 'ipv6'

	option target 'ACCEPT'



config rule

	option name 'Allow-ICMPv6-Input'

	option src 'wan'

	option proto 'icmp'

	list icmp_type 'echo-request'

	list icmp_type 'echo-reply'

	list icmp_type 'destination-unreachable'

	list icmp_type 'packet-too-big'

	list icmp_type 'time-exceeded'

	list icmp_type 'bad-header'

	list icmp_type 'unknown-header-type'

	list icmp_type 'router-solicitation'

	list icmp_type 'neighbour-solicitation'

	list icmp_type 'router-advertisement'

	list icmp_type 'neighbour-advertisement'

	option limit '1000/sec'

	option family 'ipv6'

	option target 'ACCEPT'



config rule

	option name 'Allow-ICMPv6-Forward'

	option src 'wan'

	option dest '*'

	option proto 'icmp'

	list icmp_type 'echo-request'

	list icmp_type 'echo-reply'

	list icmp_type 'destination-unreachable'

	list icmp_type 'packet-too-big'

	list icmp_type 'time-exceeded'

	list icmp_type 'bad-header'

	list icmp_type 'unknown-header-type'

	option limit '1000/sec'

	option family 'ipv6'

	option target 'ACCEPT'



config include

	option path '/etc/firewall.user'



config rule

	option src 'wan'

	option dest 'lan'

	option proto 'esp'

	option target 'ACCEPT'



config rule

	option src 'wan'

	option dest 'lan'

	option dest_port '500'

	option proto 'udp'

	option target 'ACCEPT'



config include 'qcanssecm'

	option type 'script'

	option path '/etc/firewall.d/qca-nss-ecm'

	option family 'any'

	option reload '1'

/etc/config/network



config interface 'loopback'

	option ifname 'lo'

	option proto 'static'

	option ipaddr '127.0.0.1'

	option netmask '255.0.0.0'



config globals 'globals'

	option ula_prefix 'auto'



config switch

	option name 'switch0'



config interface 'lan'

	option ifname 'eth0 eth1 eth2 eth3'

	option force_link '1'

	option type 'bridge'

	option proto 'static'

	option ipaddr '192.168.1.1'

	option netmask '255.255.255.0'

	option ip6assign '60'

	option multicast_querier '0'

	option igmp_snooping '0'



config interface 'wan'

	option ifname 'eth4'

	option proto 'dhcp'

	option apn_status '1'

	option apn 'fast.t-mobile.com'



config interface 'wan6'

	option ifname 'eth4'

	option proto 'dhcpv6'

/etc/config/dhcp



config dnsmasq

	option domainneeded '1'

	option boguspriv '1'

	option filterwin2k '0'

	option localise_queries '1'

	option rebind_protection '1'

	option rebind_localhost '1'

	option local '/lan/'

	option domain 'lan'

	option expandhosts '1'

	option nonegcache '0'

	option authoritative '1'

	option readethers '1'

	option leasefile '/tmp/dhcp.leases'

	option resolvfile '/tmp/resolv.conf.auto'

	option localservice '1'



config dhcp 'lan'

	option interface 'lan'

	option start '100'

	option limit '150'

	option leasetime '12h'

	option force '1'

	option dhcpv6 'server'

	option ra 'server'



config dhcp 'wan'

	option interface 'wan'

	option ignore '1'



config odhcpd 'odhcpd'

	option maindhcp '0'

	option leasefile '/tmp/hosts/odhcpd'

	option leasetrigger '/usr/sbin/odhcpd-update'

/etc/config/wireless



config wifi-device  wifi0

	option type	qcawificfg80211

	option channel	36

	option country	CN

	option macaddr	f8:5e:3c:16:87:3b

	option hwmode	11axa

	option htmode	HT80

	# REMOVE THIS LINE TO ENABLE WIFI:

	option disabled 0



config wifi-iface

	option device	wifi0

	option network	lan

	option mode	ap

	option ssid	WIFI6-5G-16873C

	option encryption none

	



config wifi-device  wifi1

	option type	qcawificfg80211

	option channel	auto

	option country	US

	option macaddr	f8:5e:3c:16:87:3a

	option hwmode	11axg

	option htmode	HT40

	# REMOVE THIS LINE TO ENABLE WIFI:

	option disabled 0



config wifi-iface

	option device	wifi1

	option network	lan

	option mode	ap

	option ssid	WIFI6-16873C

	option encryption none

	option disablecoext 1

My guess is that as you can pull config files from the router, your problem is not between the router and your client devices, but in the connection between the router and ISP.

And there is likely not much that we can do, as it sounds like the ISP has taken ancient OpenWrt version and has modified it. 15.05 has been unsupported for years. They have probably introduced proprietary 3G modem drivers and config there, so it may deviate from the normal current day stuff.

You could search the forum about 3G modems etc.

Googling for that device, it sounds like modern ipq8072 based device, but as the OpenWrt support for ipq807x is still under construction, they have likely used an old Qualcomm QSDK as the base. (Ancient OpenWrt, lots of modifications).

Are you saying the firmware is too old for it to work? It definitely looks like a bare bone / old OpenWRT. But it’s strange because it was working fine for months. I don’t think it’s any issues with the ISP since the SIM card works fine with other routers running OpenWRT. Any suggestions? Any idea if I can update the firmware on this without bricking it?

I’ll add, it’s using a Quectel RM-502Q 5G chip

As hnyman implied, this device isn't supported by OpenWrt at this point - the whole target architecture isn't (and while efforts for adding ipq807x support is underway for other non-4g devices, this one is totally unknown so far). Given that this firmware is obviously built upon Qualcomm's vendor (Q)SDK and heavily modified by ZBT, there's nothing we could do here.

Please talk to ZBT and/ or your seller.

1 Like

Your problem may be in the 4G cellular drivers (provided by your vendor), their interaction with the ISP hardware and protocols. "SIM card" is just the identification tool. It does not have much to do with the actual traffic protocols.

With the possible help from the OpenWrt forum, your best bet is to look for modem config advice

I edited the message subject to include the model, so that this may raise intesrest in somebody who knows about your device/chip.

1 Like

In the logs there may be things that explain what is happening.

If you open a terminal window to the device use the commands dmesg and logread to look for problems.

Thank you for the help. I’ve attached the logs. Truthfully, I have no idea how to read any of this. Logs had too many characters so I attached a link to the code.

Dmesg logs:
https://ctxt.io/2/AABgdv3GFw

Logread logs:
https://ctxt.io/2/AABgjW2PFw

So it seems like a solution could be to move the modem to a router that supports a more current version of openWRT?

I can't see anything that leaps out in there, although there are quite a few things reporting challenges ans errors. You may have also missed the relevant time period - reviewing them straight after boot or maybe a /etc/init.d/network restart would make sense.

Does a ping www.microsoft.com work on the router? That should go straight to to the WAN port, which might help clarify if it is an internal problem.

Also, is it the case that there is no graphical interface if you open a web browser to the router IP address?

Newer device / firmware would be good thing generally.