4G internet is not working after upgrade to 22.03.2

Hello,
Trying to figure out why my internet is not working over 4g.
I am using Huwawei E3372 as CDC network device

[ 18.570644] cdc_ether 1-1:1.0 eth1: register 'cdc_ether' at usb-1b000000.usb-1, CDC Ethernet Device, 00:1e:10:1f:00:00

Interface configured as DHCP client:

config interface 'LTE'
        option proto 'dhcp'
        option device 'eth1'
        option auto '0'

Device:

eth1      Link encap:Ethernet  HWaddr 00:1E:10:1F:00:00
          inet addr:192.168.8.152  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:10ff:fe1f:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2646 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91133 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:445871 (435.4 KiB)  TX bytes:9710215 (9.2 MiB)

Ping:

root@OpenWrt:/etc/config# ping 192.168.8.1
PING 192.168.8.1 (192.168.8.1): 56 data bytes
64 bytes from 192.168.8.1: seq=0 ttl=64 time=24.659 ms
64 bytes from 192.168.8.1: seq=1 ttl=64 time=24.244 ms
64 bytes from 192.168.8.1: seq=2 ttl=64 time=24.029 ms
root@OpenWrt:/etc/config# ping 192.168.8.151
PING 192.168.8.151 (192.168.8.151): 56 data bytes
64 bytes from 192.168.8.151: seq=0 ttl=64 time=0.392 ms
64 bytes from 192.168.8.151: seq=1 ttl=64 time=0.276 ms

ip route:

root@OpenWrt:/etc/config# ip route
default via 192.168.8.1 dev eth1  src 192.168.8.151
192.168.0.0/24 dev br-lan scope link  src 192.168.0.1
192.168.8.0/24 dev eth1 scope link  src 192.168.8.151

ip a:

root@OpenWrt:/etc/config# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 74:da:88:e9:b7:97 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::76da:88ff:fee9:b797/64 scope link
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 74:da:88:e9:b7:97 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.1/24 brd 192.168.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd70:52fe:ed5c::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::76da:88ff:fee9:b797/64 scope link
       valid_lft forever preferred_lft forever
8: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 74:da:88:e9:b7:97 brd ff:ff:ff:ff:ff:ff
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 74:da:88:e9:b7:98 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::76da:88ff:fee9:b798/64 scope link
       valid_lft forever preferred_lft forever
10: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 74:da:88:e9:b7:97 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::76da:88ff:fee9:b797/64 scope link
       valid_lft forever preferred_lft forever
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 74:da:88:e9:b7:96 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::76da:88ff:fee9:b796/64 scope link
       valid_lft forever preferred_lft forever
12: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 00:1e:10:1f:00:00 brd ff:ff:ff:ff:ff:ff
    inet 192.168.8.157/24 brd 192.168.8.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::21e:10ff:fe1f:0/64 scope link
       valid_lft forever preferred_lft forever

firewall settings:

/etc/config# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'LTE'

config forwarding
	option src 'lan'
	option dest 'wan'

But as a result still:

root@OpenWrt:/etc/config# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss
1 Like

you should amend the title as it says " 4G internet is now working after upgrade to 22.03.2"

Thank you! Fixed

1 Like

can you ping something on the internet like 1.1.1.1, 8.8.8.8 or 9.9.9.9 ?

no:

root@OpenWrt:/etc/config# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss

Modem connection up?

Yes, I see IP assigned to device:

eth1      Link encap:Ethernet  HWaddr 00:1E:10:1F:00:00
          inet addr:192.168.8.152  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:10ff:fe1f:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2646 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91133 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:445871 (435.4 KiB)  TX bytes:9710215 (9.2 MiB)

I haven't worked with e3372 but having a 192.168.8.x ip means LTE is up?
Could you check via some AT/telnet/curl command ?

I do believe if it get IP then it works. I don't know any command that can help me to diagnose LTE connection :frowning:

Google it up. Lots of pages with this


yes it is connected, checked via internal Web-browser of modem

well you could try and check if the modem's service works in a computer plugged directly in usb

The reason was in SIM card. Don't know what happened but it stopped to receive IPv4 WAN address. I tried different SIM card of the same provider and everything works now. Going to replace bad SIM card. Closing the topic, thank you all for helping.

1 Like

2nd SIM has same result :frowning: Tried this on Windows PC without any luck. So obviously openwrt has noting to do with it.

192.xxx is the LAN side.

You could have DHCP on the LAN and no WAN IP.

Start with the basics. Bring up your WAN and troubleshoot from there.

Possible problems:

  1. Modem may still not be connected. On 192.168.8.1 there may be some diagnostics like ping, dns test (on 192.168.8.1). Test 8.8.8.8 from there.

  2. Sim card cannot be used in modem (restricted by mobile provider). Some operators block internet access by modem's IMEI and/or TTL. Check sim card in cell phone.

  3. Sim card is in roaming, but roaming is not enabled.

192.168.8.1 is IP of modem interface.

Replaced the SIM card and it is solved the problem