4G Internet connection intermittent dropping after some hours

Hi,

Here is my equipment:
Router: we826-t2 - Zbtlink ZBT-WE826 (16M)
Architecture: MediaTek MT7620A ver:2 eco:6
Quectel EP06-A
OpenWrt Firmware Version: OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256
I deactivated wi-fi since I do not need it.
Only one device (Raspberry pi 4) is connected via a lan port.

My mobile provider Fizz.ca and I'm located in Quebec city.

My problem: Randomly, after several hours, the connection to the internet is dropped. If I restart the router, the connection is working back again for several hours then drop again. It is very annoying.

Is there a kind of detailed log I could activate somewhere so that I could try to find what is really happening? I had a look at the System Log and Kernel Log however there is no indication of any problems there.

Thanks in advance for any help you may provide.

is it regular, like clockwork ?

some ISPs kill the connection after X hours.

check logread after connection runs out, then get comfortable with log restarting wan interface. Then post anomalous log entries preceding disconnect.

No, it is not regular.

Ok, I will try this.
Is there a way to get a detailled log on the modem/4g side ?
The current log seems very summary.

Please show your modem interface configuration. No pictures please.

1 Like

Here is the content of the file /etc/config/network
Let me know if you need more info
(P.S.: This morning I disabled ipv6 to see if it helps)

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd7:683d:023b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'f8:5e:3c:41:06:ff'
        option ipv6 '0'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'monModem4gLte'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'mobile.bm'
        option auth 'none'
        option pdptype 'ipv4'

config device
        option name 'eth0'
        option ipv6 '0'

My question was about one interface only.
You can try switching the modem to ECM and then it will become responsible for maintaining the connection on its own. How to configure: https://openwrt.org/docs/guide-user/network/wan/wwan/ethernetoverusb_cdc
Alternatively you can use it in QMI or MBIM mode, see https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle
In this case you will need something like watchcat that will monitor the connection and restart the modem in case of failure. There is no need to reboot the router and interface restart does not always help.
Make sure your modem firmware is up-to-date.

Is it better to use ECM ? If yes, I could try to do that tonight.

For now, I'm using QMI and I also installed watchcat to reboot/restart the interface in case of ping not working. This is a temporary solution since rebooting is a patch and it is not 100% proof anyway.

Finally, it seems that Fizz.ca is not working well in this area (L'Ange Gardien near Quebec city). I changed to Koodo and it works well now. (I also changed my config to ECM as you suggested).

Bye.