2nd LAN Port (LAN2) on AVM 7330 (7320) does not work

WAN is on dsl0
there is no eth1 as with avm firmware.

The config below is just after flashing openwrt-18.06.1-lantiq-xway-avm_fritz7320-squashfs-sysupgrade.bin and reboot. No changes - only set password for ssh access.

root@OpenWrt:~# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 08:96:d7:XX:XX:XX brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 08:96:d7:XX:XX:XX brd ff:ff:ff:ff:ff:ff
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 08:96:d7:XX:XX:XX brd ff:ff:ff:ff:ff:ff
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:baXX:XXXX::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option firmware '/lib/firmware/adsl.bin'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'dsl0'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 '1'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr '08:96:d7:XX:XX:XX'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

Unsupported Functions: DECT, LAN2

I know - this edit is from myself.

You did that edit after you have confirmed that it isn't just a configuration error?

eth1 does not show up in default setup (just booted after flashing - nothing changed, only set password to be able to access via ssh).
There is a simmilar problem to be found with google with the avm 7312 and the 10/100 phy - maybe the same problem?

i don't think that it's a configuration error as i'm using default configuration and there is no (official) place to tell openwrt that there is a second phy on the NIC.

Okay - lets start over.

This 7330 is not my first embedded device i'm analyzing and yes i know that LAN2 is NOT supported by the kernel at the moment. It's no configuration error as the kernel doesn't even see the second LAN Port. So my edit in the WIKI is correct for the moment.
I don't think installing a kmod will help as the driver is loaded but it seems that it does not recognize the second phy. But nevertheless i am asking here if anyone can help me with the necessary changes for enabling. I'm new in openwrt development so that i don't know where i can change the parameters needed to enable the second phy.

With AVM Firmware and Kernel:

[    0.300000] [avmnet] [avmnet_cfg_init] Driver version: 6.137.1.1  -
Revision 1496:3362  -  Mi 8. M\xffffffc3\xffffffa4r 12:37:40 CET 2017
[    1.360000] {avmnet_cfg_netinit}
[    1.370000] [avmnet] No config found for HWRev 179, HWSubRev 2,
Profile-ID 0, trying base config for HWSubRev
[    1.380000] [avmnet] No config found for HWRev 179, HWSubRev 2,
trying base config for HWRev
[    1.380000] {avmnet_mac_ar9_init} Init on module mac_ar9_0 called.
[    1.400000] {avmnet_mac_ar9_init} Init on module mac_ar9_1 called.
[    1.420000] [avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(0): 0x424001
[    1.420000] [avmnet] [avmnet_mac_ar9_setup] mac_nr: 0, vlan_reg:
0x4070001
[    1.550000] [avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(1): 0x424001
[    1.550000] [avmnet] [avmnet_mac_ar9_setup] mac_nr: 1, vlan_reg:
0x4070001
[    1.700000] [avmnet_set_macaddr] Setup Mac Addr for Device(eth0):
08:96:d7:XX:XX:8a
[    1.710000] [avmnet_set_macaddr] Setup Mac Addr for Device(eth1):
08:96:d7:XX:XX:8b

With OpenWrt Kernel:

[    0.591118] libphy: Fixed MDIO Bus: probed
[    0.603190] libphy: ltq_mii: probed
[    0.605570] Generic PHY 1e180000.etop-ffffffff:00: attached PHY
driver [Generic PHY] (mii_bus:phy_addr=1e180000.etop-ffffffff:00, irq=-1)

There are several other things not working: Only USB on the backside is recognized, the one at the side only has power. The second serial Port is not recognized (not bad because not populated on the board at all).

It seems the buttons are handled within https://openwrt.org/docs/guide-user/hardware/hardware.button#procd_buttons but no configuration with uci initialized.

That Telephony is not working is OK for me as this is a really complex thing which should be looked at seperate.

Did you get the 2nd LAN port to work? I installed v18.06.2 on a Fritz!Box 7320. The second LAN port didn‘t show up.

No - i did not get the 2nd LAN port working. Not on 7330 nor 7320.

But the second USB Port should work if you build your own firmware from GIT Master as there is a patch for it in the repository.

Thanks for the information. I‘ll try it.

You asked for help to enable the LAN2?
I am interessted in enabling the LAN2 at 7230/7330 too.

What can we do to achieve it?

2nd port would be nice

im no coder - played around with /firmware/openwrt/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7320.dts ,no luck so far

(search for ar8035 & ar8030 datasheet)
specs:

LAN1 > Atheros AR8035
> single port 10/100/1000 Mbps Ethernet PHY
> RGMII MAC interface
> Co-layout support with 802.3az 10/100M PHY-AR8030

LAN2 > Atheros AR8030-A, SK4P7.4D 1242 CN
> single port 10/100 Mbps Ethernet PHY
> RMII MAC interface

Is there an internal switch?

https://openwrt.org/toh/views/toh_admin_vlan?dataflt[Brand*~]=avm

OEM_EVA_AVM bootlog:
..
Atheros 8035 detected
Atheros 8030 detected
Unknown SPI device: 0xFF 0xFF 0xFF
ifx_spi_flash_init: Found no serial flash device
IFX SWITCH API, Version 1.1.8.5
SWAPI: Registered character device [switch_api] with major no [81]
[avmnet] No config found for HWRev 188, HWSubRev 2, Profile-ID 0, trying base config for HWSubRev
[avmnet] No config found for HWRev 188, HWSubRev 2, trying base config for HWRev
{avmnet_mac_ar9_init} Init on module mac_ar9_0 called.
{avmnet_mac_ar9_init} Init on module mac_ar9_1 called.
[avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(0): 0x424001
[avmnet] [avmnet_mac_ar9_setup] mac_nr: 0, vlan_reg: 0x4070001
[avmnet] [avmnet_mac_ar9_setup] IFX_AR9_ETH_CTL(1): 0x424001
[avmnet] [avmnet_mac_ar9_setup] mac_nr: 1, vlan_reg: 0x4070001
[avmnet_set_macaddr] Setup Mac Addr for Device(eth0): 24:65:11:bd:fc:27
[avmnet_set_macaddr] Setup Mac Addr for Device(eth1): 24:65:11:bd:fc:28
eth: port 0 force normal CON t0
[avm_power] eth: port 1 force throttle CON t0
[avm_power] eth: port 2 force throttle CON t0
[avmnet] [avmnet_power_config] tried to set mode for port 2
[avm_power] : ethernet switch failed
[avm_power] eth: port 3 force throttle CON t0
[avmnet] [avmnet_power_config] tried to set mode for port 3
[avm_power] : ethernet switch failed
..

OpenWrt patches:

Dont know if its already upstream: This patch Atheros phy AR8035-A switch support (Philippe DUCHEIN, 4 years ago)

https://openwrt-devel.openwrt.narkive.com/l08xHWo0/patch-atheros-ar8035-a-support

OpenWrt ar8035 patches

https://git.openwrt.org/?p=openwrt%2Fopenwrt.git&a=search&h=HEAD&st=commit&s=ar8035

dual-PHY-on-single-MDIO-bus?

https://bugs.openwrt.org/index.php?do=details&task_id=2240

It there any news about the support of Atheros AR8030-A to activate the second LAN Port?
Without that support, i have to throw the router away :confused:
I don't know about kernal changes or something else :frowning:

update: sorry false positive - FritzBox7320 has different network controllers.

Theese are 2 Lantiq PEF7071V V1.3 NICs 1Gibt ports (LAN1 and LAN2).

LAN1 is working, LAN2 does not work.

FritzBox7330SL has mentioned:

LAN1 > Atheros AR8035 > 1Gbit port > working
LAN2 > Atheros AR8030-A, SK4P7.4D 1242 CN 10/100 Mbps port > not working

no progress so far :confused:

Do you have tested it with 19.07?

EDIT: If yes, is the 7320 affected too?

Unluckily I have to confirm this issue :frowning:

Has someone observed issues with LAN 1 too?

and

FS#2240 - Lantiq: AVM FRITZ!Box 7320 only one ETH port is working

Many thought. I thought I had read somewhere about issues with LAN1. But I didn't found it again. I hope the fix will be included soon :slight_smile:

But nothing new about LAN2 :frowning:

The fix doesn't fix the problem, so there's still some work to do.