25MB/s WiFi network, down to 1MB/s when Client mode on LEDE

I need to expand my WiFi network, by adding an additional router in client mode and connecting some wired machines to it. I have a Comtrend WAP-5813N with a fresh LEDE 17.01.2 flashed on it

  • If I connect my RTL8814AU Alfa Network USB dongle in a PC around the additional router ubication, I get the whole 25MB/s in Speedtest.
  • If I connect my android phone (OnePlus One) around the router ubication, I get around 21-22MB/s.
  • If I connect my laptop, with an old realtek 11g NIC, I get 16-18MB/s
  • If I connect my LEDE router, I hardly get 1MB/s (most of the tests I keep getting 0.5MB/s), making it unusable.

I just enable in LuCi the radio0 (the only wireless radio the router has), make a scan, connect to my WiFi typing my WPA passphrase and applying the changes. The router connects correctly to the WiFi and repeat it through the LAN ports (I get my main router WAN IP in internet), but the speeds are ridiculous compared to the rest of my wireless devices connecting via WiFi to my network. I guess the wireless card of the router (BCM4322 802.11b/g/n mini-pci) is bad, but it cannot be that bad.

So, I tried connecting an old ADB P.DG A4001N1 with LEDE 17.01.2 on it and I am getting exactly the same results, not even 1MB/s no matter how close I am from the WiFi source.

Once discarded that it is a hardware/router issue. What can I be doing wrong? Should I try another LEDE/OpenWRT build?

Thanks so much.


I just flashed the OpenWRT Chaos Calmer 15.05.1 (2016 March) and with this firmware it gets 20MB/s.


Can you try flashing snapshot?
It could be solved after 17.01.2 was released