Hi,
I had already switching problems on the ZyXEL XGS1250-12 with OpenWrt 23.05.X ... so I tried 24.10.0. Unfortunately I dont get any lan port running/connecting. Only serial works.
- How can I install an old OpenWrt version if I dont have any ssh/luci connection?
did you keep the config between 23.05 and 24.10? If so, try resetting your device to defaults -- from the serial terminal, issue the following command:
firstboot -y && reboot
Then see if you can access the device (it will be in the default config after that; so be sure to unplug it from your network, the only connection should be between your computer and the XGS1250-12).
If it still isn't working, use serial to grab the configs:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:

Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
Thank you for the fast help!
Yes, I did the reset already.
ubus call system board
{
"kernel": "6.6.73",
"hostname": "OpenWrt",
"system": "RTL9302B",
"model": "Zyxel XGS1250-12 Switch",
"board_name": "zyxel,xgs1250-12",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "24.10.0",
"revision": "r28427-6df0e3d02a",
"target": "realtek/rtl930x",
"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
"builddate": "1738624177"
}
}
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd4d:ab5:387e::/48'
config device 'switch'
option name 'switch'
option type 'bridge'
option macaddr 'f4:4d:5c:7b:11:ce'
config bridge-vlan 'lan_vlan'
option device 'switch'
option vlan '1'
option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8 lan9 lan10 lan11 lan12'
config device
option name 'switch.1'
option macaddr 'f4:4d:5c:7b:11:ce'
config interface 'lan'
option device 'switch.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
cat /etc/config/dhcp
cat: can't open '/etc/config/dhcp': No such file or directory
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
Ok... so in the default state, the address is 192.168.1.1.
Does your computer have an IP address in that subnet? If not, set your computer's Ethernet port to 192.168.1.5 (subnet mask 255.255.255.0) and then see if you can ping the switch (192.168.1.1). Make sure that there aren't any other network interfaces active on your computer (turn off WiFi if it's enabled now).
If that doesn't work, we'll try something else.
WiFi is off. I configured LAN manually.
ping shows unreachable network.
The switch doesnt even show light indication of than lan port.
Yeah, looks like it.
How can I install another OpenWrt version (old one or snapshot) if I have only serial access?
You can drop into uboot shell and connectivity should be working there if you run rtk network on
. Then you can boot and install via tftp, see https://openwrt.org/toh/zyxel/xgs1250-12#booting_openwrt_from_ram
How can I go into uboot shell? Is it the Serial + STRG+C + Eneter (looks like I am in OpenWrt with ssh)?

root@OpenWrt:~# rtk network on
-ash: rtk: not found
Btw: fw_printenv
shows:
bootcmd=rtk network on; boota
Thank you, @antanas !
I was able to do the tftpboot:
tftpboot 0x84f00000 192.168.1.10:openwrt-23.05.5-realtek-rtl930x-zyxel_xgs1250-12-initramfs-kernel.bin
Using rtl9300#0 device
TFTP from server 192.168.1.10; our IP address is 192.168.1.1
Filename 'openwrt-23.05.5-realtek-rtl930x-zyxel_xgs1250-12-initramfs-kernel.bin'.
Load address: 0x84f00000
Loading: #################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
#################################################################
###########
done
Bytes transferred = 6829343 (68351f hex)
Whats the next step? reboot command does not exist...
Check help
command it will show you whats available. I don't remember exactly but it's probably bootm
that would boot the loaded image
Thank you so much!
Yes, it was bootm
. Now I reverted back to an older OpenWrt version 
1 Like