24.10.0 - WRT1900ACS - Lan interface after boot down

I'm trying to get 24.10.0 running on my Linksys WRT 1900ACS. I'm coming from 19.x, haven't imported any settings, and have since flashed various images (19.x, but also 23.05.5) and hope that all the old settings are gone.

Under 19.x, the plugged-in Ethernet cable (LAN1) is reliably detected (tested, by downgrading), but not under 23.x and 24.x. Very often (but not always), the connection is lost after booting (rebooting or restarting). It's always there during booting, but unfortunately not at the end.

I have to unplug and replug the cable several times until the interface finally connects.

Since it works with the old images, I don't suspect a hardware error at this time.

Does anyone have any ideas? Thanks for any tips.

Best regards, Volker

Can you show outputs of

ubus call system board
cat /etc/config/network

(replace secrets like passkeys and mac addresses with ABC)
Likely your brand new wan is still somehow kept in br.lan

I've done further testing and found that the issue appears to be more complex than initially assumed. It only occurs with certain devices. I'm having problems with my old MacBook Pro (connected directly to the Linksys) and when the router is connected to a manageable switch (HP 1820-24G). However, when the router is connected to the Ethernet port of a Thunderbolt hub on another Mac (Caldigit TS3plus) or a small switch (Netgear GS116), the link is reliably detected.

About the data (I haven't configured practically anything in the current test environment yet)

ubus call system board
{
	"kernel": "6.6.73",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Linksys WRT1900ACS",
	"board_name": "linksys,wrt1900acs",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "24.10.0",
		"revision": "r28427-6df0e3d02a",
		"target": "mvebu/cortexa9",
		"description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
		"builddate": "1738624177"
	}
}
cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd31:71f4:769f::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.133.10'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'c6:41:1e:31:e7:ab'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'username'
	option password 'pass'
	option ipv6 'auto'