23.05.x : wireless not associated


Since I have installed on the Dlink2640 the 23.05.x I noticed a strange effect on the wifi 5GHz (MediaTek MT7615E 802.11ac/n).
If I change the country, channel, power or bandwidth, I get that only the main wifi 5GHz works, while for all the other wifi 5 GHz I defined returns error of "wireless not associated".
I also noticed that, if I keep everything at default and I enable the 160 MHz channels, after 5-10 min, the wifi disappear and I get again the same issue.

This was not working with the 22.03.x, so I guess it's a matter of drivers. Is there any log I can share to help diagnosing the issue?

This is what I see (I tried with Canada as country, just as example)

Mode: Master | SSID: <edited>
BSSID: <edited>
Encryption: WPA3 SAE (CCMP)
Channel: 0 (0.000 GHz)
Tx-Power: 24 dBm
Signal: 0 dBm | Noise: -92 dBm
Bitrate: 0.0 Mbit/s | Country: CA

I did a clean installation of OpenWRT 23.05. and 23.05.02 to be sure it was not a problem of updates.


As stated on: https://openwrt.org/toh/d-link/dir-2640_a1
At the bottom is written: MT7615N 5 GHz Problems - see [Solved] OpenWrt on MT7621/MT7615N devices with 5GHz problems

So better read this 1st and see: The 22.03.3 Stable release appears to have least amount of problems as of January 2023. But, expect a loss in routing performance since it does not include arinc9's patches.

Conclusion: There are some issues regarding 5GHz Wifi, so better stay on 22.03.3


I don't think 160 MHz is possible. MT7615E 160Mhz available or not?

Ive also experienced 5ghz not working on 23.05.2 on my pi4 using a mediatek mt7612u dongle. 5ghz works well on 22.03.5. This is in STA mode, i have not tested ap mode.

Thank you both for the clarifications.

I made multiple trials and I finally made it working (on the 80MHz). I had to select the channel 149, so that I can set the 24 dBm (the maximum of the router).

Mode: Master | SSID: <edited>
BSSID: <edited>
Encryption: WPA3 SAE (CCMP)
Channel: 149 (5.745 GHz)
Tx-Power: 24 dBm
Signal: -53 dBm | Noise: -92 dBm
Bitrate: 837.7 Mbit/s | Country: CA

I did a quick test on a DIR-2640 rev.A1 running stable release 23.05.0; several weeks? ago and did not encounter any issue during the three days I had it available to me.
Packages included were irqbalance, banip and adblock.

With that said,
I did not try WPA3 but configured with WPA2-PSK (AES) and due to high wifi density in the city, did not bother with 160 channel width and instead kept it at 80.

Good luck.

The issue happens not on the primary wifi, but on the others.

On the 5GHz I have 3 wifi: 1 for the ISP, one that connects, via Wireguard, to my router in Italy and another tht connects to a server I use often.

The first one is fine, the second and the third one have the issues.