23.05 for MikroTik RouterBoard RB951Ui-2HnD

HI there,

I wanted to upgrade my MikroTik RouterBoard RB951Ui-2HnD. But in the device page, It is said “Warning - Mikrotik has made some changes on the board and recently ordered units are no longer supported.” That is why I am at 19.07.10.

But in the downloads page of OpenWrt, in can see these files for the same exact model.

Initramfs file:-

https://downloads.openwrt.org/releases/23.05.0/targets/ath79/mikrotik/openwrt-23.05.0-ath79-mikrotik-mikrotik_routerboard-951ui-2hnd-initramfs-kernel.bin

Squashfs Sysupgrade file:-

https://downloads.openwrt.org/releases/23.05.0/targets/ath79/mikrotik/openwrt-23.05.0-ath79-mikrotik-mikrotik_routerboard-951ui-2hnd-squashfs-sysupgrade.bin

Please help.
Thanks in advance.

If you are on 19.07.10 then you should have no issue tftpbooting the initramfs and seeing how it performs before deciding to flash it.

1 Like

Hello,
Sorry for the late reply.
So I have tried to TFTP booting the initramfs file. But the file gets sent using TFTP, and then the flash LED blinks for hours and if I reboot it, It comes back to OpenWrt 19.07.

I have tried on an out-of-the-box condition device. Same issue. But is flashes OpenWrt 19 fine.

Thank you.

I suspect the issue was, I was using a 12V adapter for flashing. When I tried the 24V adapter, it stared flashing for all the devices.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.