23.05 Can't connect to internet, ip route command doesn't bring a line starting with default

I was at 22.03.05 version, everything was totally fine. Now I flashed 23.05, cannot connect to the internet anymore since I flashed 23.05. I have Asus RT-N18U router I use as my main router, connected to the GPON. No weird configs, no VPN's etc. Just default config. I don't even have WIFI because of Broadcom chipset.

For example pinging google.com brings this:
ping: bad address 'google.com'

Then I setup the internet as PPPOE as what my ISP requires, exactly the same setup which worked in 22.03.05. But now exact same setup doesn't work. Here is my ip route command in 23.05:
192.168.2.0/24 dev br-lan scope link src 192.168.2.1

And my /etc/config/network file is like this below. I have written personal data as SECRET. Also wan.35 is required for my ISP requires vlan id 35.


config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'
option ula_prefix 'SOMEIPV6PREFIX'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'

config device
option name 'wan'
option macaddr 'SECRET'

config interface 'wan'
option proto 'pppoe'
option device 'wan.35'
option username 'SECRET'
option password 'SECRET'
option ipv6 'auto'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

Also I flashed back 22.03.05, a working configuration I had and did ip route. It brings this. I removed the ip's and wrote someip1 and someip2 instead. Cuz those might be personal data.


default via someip1 dev pppoe-wan

someip1 dev pppoe-wan scope link src someip2

192.168.2.0/24 dev br-lan scope link src 192.168.2.1

Whereas in 23.05 my ip route is like this:
192.168.2.0/24 dev br-lan scope link src 192.168.2.1

You can try to upgrade preserving the working configuration.

1 Like

I already did that, didn't work. My setup isn't complicated either I don't run anything like VPN s and stuff. I only have ntfs-3g installed.

Do you have your PPPoE connection established?
What is in your system log after you restart wan in Luci?
What ifstatus wan gives you?

2 Likes

If you read the logs you'll likely see "Timeout waiting for PADO packets", which means the basic link between the WAN port and the ISP is not working.

  • modem not connected to fiber / DSL line or the line is dead
  • Ethernet cable not connected
  • Problem with the VLAN

Assuming the first two are check OK, there was another thead here about someone having problems with DSA on a Broadcom chip after upgrading.

2 Likes

It fails to establish that connection. Can't get my IP address from the ISP.
System log after I restart the wan:

Sat Oct 14 23:35:22 2023 daemon.notice netifd: Interface 'wan' is now down
Sat Oct 14 23:35:22 2023 daemon.notice netifd: Interface 'wan' is disabled
Sat Oct 14 23:35:22 2023 daemon.notice netifd: Interface 'wan' is enabled
Sat Oct 14 23:35:22 2023 daemon.notice netifd: Interface 'wan' is setting up now
Sat Oct 14 23:35:22 2023 daemon.info pppd[5315]: Plugin pppoe.so loaded.
Sat Oct 14 23:35:22 2023 daemon.info pppd[5315]: PPPoE plugin from pppd 2.4.9
Sat Oct 14 23:35:22 2023 daemon.notice pppd[5315]: pppd 2.4.9 started by root, uid 0
Sat Oct 14 23:35:23 2023 daemon.warn odhcpd[1281]: No default route present, overriding ra_lifetime!
Sat Oct 14 23:35:37 2023 daemon.warn pppd[5315]: Timeout waiting for PADO packets
Sat Oct 14 23:35:37 2023 daemon.err pppd[5315]: Unable to complete PPPoE Discovery
Sat Oct 14 23:35:37 2023 daemon.info pppd[5315]: Exit.

ifstatus wan gives this:

{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "pppoe",
	"device": "wan.35",
	"data": {
		
	},
	"errors": [
		{
			"subsystem": "pppoe",
			"code": "CONNECT_FAILED"
		}
	]
}

Then your problem is one step before PPPoE - you probably have no Ethernet connection on WAN. See @mk24 answer above.

I don't know what do you mean exactly. Physically there is no problem, I went back to 22.03.05, everything is working there. Now I am at 23.05 again, nothing works again. I have not changed the cables at all. Problem isn't physical.

I would suggest installing a fresh new 23.05 without preserving any config and then only enabling PPPoE to see if it comes up: there could be some minor differences in network config file that need to be added to the config from 22.03.

It is not about physical connectivity. My understanding the issue is related to the internal switch.
This is probably the topic mentioned earlier: DIR-890L Openwrt - #19 by mk24

I flashed then performed reset, and tried that way. Isn't it the same way as you said? That didn't work either way. I am very close to solving this btw, got an issue on github too: https://github.com/openwrt/openwrt/issues/13691

1 Like

A post was split to a new topic: Cannot connect to internet with Linksys MR8300 on 23.05.2