23.05.5 ax53u wifi "getting IP" loop and dual mode

Hi.
Total noob here. Have no idea about linux or networking. Please, be gentle.

Installed 23.05.5 factory on my asus ax53u using instruction
have 2 problems:

  1. Major one. I have "getting IP" loop when attemp to connect to any radio module.
    I had one successful connection to 2.4MHz one, but, sadly missed exact settings. For me it looks like "I changed nothing".
    Tried both radios separately and simultaneously. Same result.
    Tryed different security protocols, for a moment stay at reccomended WPA2/WPA PSK
    changed country
    had to set up MAC. Does MAC have to be same everywhere in device? OpenWRT allows to set it to all devices individually.

Where should I look?

  1. In stock firmware Asus have both wifi modules working as one. I don`t know logic behind it, it not visible for user. As i saw in some avices I setted both modules with same sequrity protocol/ssid/password but it looks not right. they both stay im master mode. it not visible if they coordinated how it expected to be.

Am I wrong and this is how it supposed to be? or I indeed need to make additional settings?

What do you mean in "dual mode" -- are you talking about using both wifi radios?

Let's take a look at your configuration:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thx for fast response. Lucky me. Little busy myselth, I will give info, that You ask, few hours later.

ubus call system board

{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "ASUS RT-AX53U",
        "board_name": "asus,rt-ax53u",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}


cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd24:c457:9fef::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option name 'wan'
        option macaddr 'f_________5' /changed

config device
        option name 'lan2'
        option macaddr 'f_________5' /changed

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option country 'RU'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '_______'
        option encryption 'psk-mixed'
        option key '_______'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid '_______'
        option encryption 'psk-mixed'
        option key '_______'
        option macaddr 'f_________5' /changed'

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

cat /etc/config/firewall

config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Start by removing all of the 802.11r related lines (i.e. the last 3 in each stanza), and also change psk-mixed to WPA2 (psk2). If 802.11r is enabled on any other APs, be sure to disable it there (if this is your only AP, it shouldn't be used anyway).

Reboot and test again. If it doesn't fix things, I'm seeing something strange here which I've seen before but I don't know how or why this occurs...

Notice how the network is in single quotes ('), but the other lines don't show that... they should all be in single quotes. I'm not sure if this is related to the issue, but we'll investigate that if the other things don't fix the problem.

Thx.
When You say "remove lines" How I supposed to do this?
I use GUI so have no idea what command I should use.
The tool probably same - PuTTY, but I dont know linux\OpenWRT commands

I use the vi text editor on the command line to do these things, but you can also do it via the GUI if you want... in that case, just change the encryption type and then disable all the 802.11r stuff that you enabled.

ok, I dont know what happened.
before i even tryed Your instruction to make it clean, i dropped all MACs except WAN in devices (using GUI) and after reboot i lost all connections to router. I coudnt connect to it througth GUI and ssh. while it visually not froze.
Thank god, hard reset made me a deal, i connected to Luci, turned on wifi 2.4 WPA/WPA2 and bang - it works on first try.

Do not use WPA/WPA2. Use only WPA2. WPA(1) is not secure.

Ok it looks like I got it. In GUI when You setting general settings You can turn off this little flag.
When "I did nothing" at very begining I actually by mistake made additional network, removed default one instead of it, and to make it "as it was" removed this flag from another default network, making it "unspecified" (this is what it shows when all flags removed.

Looks like, I disconnected wifi from network.
I just repeated it and got same result.

You was perfectly on point here. Nice catch.

I will switch to WPA2(or 3 as others advise) only.

BTW, my second question still remains.
Are 2 Radios on same ESSID coordinate each other automaticly by OpenWRT default mechanisms, or I had to make additional adjustments?

Yeah, but I'm slightly embarrassed that I missed the fact that there were no networks associated with the SSIDs :face_with_open_eyes_and_hand_over_mouth:

What do you mean "coordinate each other"?

As ADs of all kind says, router choose to what radio connect client depending on signal and in MU-MIMO it even adjust signal on individual antenas using phase adjustment to make it stronger in device location. Obviously for such fuctionality radios have to be coordinated between each other. Otherwise it will be simple FIFO or smth.

In the case of MIMO, yes, the chipset takes care of that (low level, in hardware). Between bands, though -- that is actually a client side process.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.