[23.05.2] WDR4900 v1.3 network issues, wifi instable

Hi there,
I already posted a similar issue with this device a while ago and received help, but I think the WDR4900 v1.3 does not work properly (with 23.05.2 compared to previously used 22.03.5) and I assume it is due to my network setup (after switching to DSA I might made mistakes).

The WDR4900 (v1.3) acts as dumb AP but runs way worse than with 22.03.5 - handover from another AP to this does not work properly (did not experience this with 22.03.5); last night the routers network interface stopped working and device was unreachable - a reboot helped.
OpenWRT version:

OpenWrt 23.05.2 r23630-842932a63d

Following setup (btw, same concept as with 22.03.5):

  • the network consists of 4 VLANs (lan (id 5), media (id 3), tech (id 6), dns (id 4)), first three are important for WDR4900
  • the WDR4900 provides 3 WIFIs/SSIDs (main, media, tech) connected to the 3 VLANs on same channel; SSID and channel are same to the other AP
  • the WDR4900 is connected to managed switch via LAN port lan4; the switch is then connected to main router (Archer C7 (v5) on 23.05.2/swconfig) which provides DHCP, DNS, firewall rules etc.
  • the WDR4900 acts as sane server (scanner connected via USB) included in VLAN 5 (lan) - that works quite well

I still face the issue I mentioned in other thread:

  • WIFI clients changing from the other AP to this one have issues connecting to it on all networks

To make the VLAN working with DSA (after several trial&error rounds) I use one br-lan with brdige VLAN filtering enabled and the interfaces are then connected to br-lan.VLAN_ID.

Below some config file extracts - /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '-CUT-'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'
	option bridge_empty '1'

config interface 'lan'
	option device 'br-lan.5'
	option proto 'static'
	option ipaddr '192.168.0.6'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	list dns '192.168.40.40'

config device
	option name 'wan'
	option macaddr '-CUT-'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option auto '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:u*'
	list ports 'lan3:u*'
	list ports 'lan4:t'

config device
	option name 'br-lan.1'
	option type '8021q'
	option ifname 'br-lan'
	option vid '1'
	option ipv6 '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'lan4:t'

config interface 'tech'
	option proto 'static'
	option device 'br-lan.6'
	option ipaddr '192.168.60.6'
	option netmask '255.255.255.0'
	option gateway '192.168.60.1'
	list dns '192.168.40.40'

config interface 'media'
	option proto 'static'
	option device 'br-lan.3'
	option ipaddr '192.168.30.6'
	option netmask '255.255.255.0'
	option gateway '192.168.30.1'
	list dns '192.168.40.40'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'lan2:u*'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'

/etc/config/wireless (almost unchanged from 22.03.5)

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'ffe09000.pcie/pci9000:00/9000:00:00.0/9000:01:00.0'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'media'
	option mode 'ap'
	option ssid 'sonos-11an'
	option encryption 'psk2'
	option key '-CUT-'
	option macfilter 'allow'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '9'
	option hwmode '11g'
	option path 'ffe0a000.pcie/pcia000:02/a000:02:00.0/a000:03:00.0'
	option htmode 'HT20'
	option counry 'DE'
	option txpower '20'
	option country 'DE'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WIFI-media'
	option encryption 'psk2'
	option key '-CUT-'
	option macfilter 'allow'
	option network 'media'
	list maclist '-CUT-'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WIFI-main'
	option encryption 'psk2'
	option key '-CUT-'
	option macfilter 'allow'
	option network 'lan'
	list maclist '-CUT-'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WIFI-tech'
	option network 'tech'
	option encryption 'psk2'
	option key '-CUT-'

Anything else I can provide? Any help is highly appreciated - many thanks in advance. I would like to avoid downgrading back to swconfig/22.03.5 again.

As I still faced issues with wifi clients being not able to receive IP address via VLANed network when they reappeared to wireless network (eg mobile phone moving around and switching from one AP to another), I switched back to

OpenWrt 22.03.6 r20265-f85a79bcb4

and having no issues anymore.

As main router (and AP) is on 23.05.2 (but w/o DSA support yet), it works well now.

Questions are:

  • is this DSA and/or platform (here: mpc85xx) specific?
  • is this an issue with DSA devices connected with non-DSA devices? (Can not imagine as there should be no differences on network layer level)
  • anyone face similar/same issues with DSA supported platforms; specifically WDR4900?