22.03.2 MAC conflict

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'sta'
        option encryption 'psk2'
        option network 'wifiwan'
        option disabled '0'
        option ssid 'mysssid'
        option key 'mypwd'
        option macaddr '00:xx:xx:xx:yy:80' <<<<<<<<<< required dirty hack
config interface 'wifiwan'
        option proto 'dhcp'
        option metric '30'
        option defaultgateway '1'
        option ipv6 '0'
config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option defaultgateway '1'
        option metric '10'
        option ipv6 '0'
        option disabled '0'

wan (eth1) and wifiwan (wlan0) receive the identical MAC, usually. Which then results in same IP, in case eth1 is connected to same upstream router as wlan0 (wifiwan).
To avoid this, I have to use the dirty hack.

That creates a loop, not advisable.

What is not advisable ?
I am using these two connections to the upstream router for failover.
Having different metrics. Worked in 21.02.3, BTW.

The loop.

Then I guess they're connected simultaneously?

If it was one at a time, it wouldn't be a problem.

Connected simult. Because mwan3 checking periodically. But app only uses one of them, of course. Anyway, to use identical MAC can also be problematic in other scenarios, I suspect.