22.03.0 no Network > Switch menu

Hello,
My setup: Plusnet Hub 1 (BTHH5A) currently running openwrt 21.02.3. Works fine without problem as main VDSL router. I have several of these routers as they can be used as WAP's so I setup one of them as a hot spare in case the main one went down.
I saw the new upgrade was available to 22.03.0 and thought that I would try and upgrade the spare router to this first. Not so straightforward as previous upgrades and had to do a factory reset eventually. I have now configured the spare router with the correct setting except one.
In 21.02.3 there was Network >switch menu. I had used this to convert the WAN port to a 5th LAN port and this worked fine.
In 22.03.0 there is no switch menu so how do I go about changing the WAN port to be an additional LAN port ?

Thanks

Your device has probably transitioned to a DSA based configuration instead of swconfig.

More than likely, you just have to remove the wan port from wan and wan6 network interfaces and then add it under the br-lan.

Post your /etc/config/network file and we can give you specifics.

I used Teraterm to get the config file and struggled a bit. Hope the following makes sense.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd82:4f44:1d8

config dsl 'dsl'
        option annex 'a'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr '30:24:78:e8:de:b

config device
        option name 'lan2'
        option macaddr '30:24:78:e8:de:b

config device
        option name 'lan3'
        option macaddr '30:24:78:e8:de:b

config device
        option name 'lan4'
        option macaddr '30:24:78:e8:de:b

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
- network 2/55 3%


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd82:4f44:1d8

config dsl 'dsl'
        option annex 'a'
        option ds_snr_offset '0'

config device
- network 2/55 3%


        option name 'lan2'
        option macaddr '30:24:78:e8:de:b0'

config device
        option name 'lan3'
        option macaddr '30:24:78:e8:de:b0'

config device
        option name 'lan4'
        option macaddr '30:24:78:e8:de:b0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'

config device
        option name 'dsl0'
        option macaddr '30:24:78:e8:de:b1'

config interface 'wan'
        option device 'dsl0'
        option proto 'pppoe'
        option ipv6 '1'
        

- network 55/55 100%

Thanks

You need to add 'wan' to the list of ports in br-lan. ("wan" is the red port)

You can do it from the web ui: network->interfaces and select the devices tab then click configure br-lan and add switch port wan to the bridge ports.

Thanks both for the info. I have configured as suggested and the red WAN port is working fine as an additional LAN port.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.