22.03.0 network fails on WRT32X (mvebu) after install

On my Linksys WRT32X I have 19.07.8 running perfectly. When I installed 22.03.0 I didn't know about the DSA multiple bridge failure issues, so I learned the hard way. I hadn't set wireless up yet and the only port working didn't have access to SSH or luci, so I switched back to my 19.07.8 partition.

Now each time I install 22.03.0 the network fails entirely a few minutes after the install reboot. DHCP works fine, but luci, SSH, and pings stop working to the router (default ip and it is totally unresponsive. While time is a factor, I have determined that it stops working any time I go to the Network -> Interfaces tab. Just loading that page causes the problems.

Here were my exact steps for my Linksys WRT32X:

  • Installed 22.03.0 the first time via SSH: sysupgrade -F -n -v openwrt-22.03.0-mvebu-cortexa9-linksys_wrt32x-squashfs-factory.img
  • Booted 22.03.0 and it worked fine, spent a lot of time configuring it, no problems.
  • Set up LAN port 4 on a Guest Network - it worked until I rebooted, then I ran into the multiple bridge failure on the WRT32X so LAN ports 1-3 didn't work, and only port 4 guest network without access to router worked, so now I'm locked out.
  • Triple restarted to get back to 19.07.8 partition.
  • Installed 22.03.0 again via SSH: sysupgrade -F -n -v openwrt-22.03.0-mvebu-cortexa9-linksys_wrt32x-squashfs-factory.img
  • Was re-configuring and after a few minutes the router became unresponsive.
  • Triple restarted back to 19.07.8 partition and re-installed 22.03.0.
  • Verified that after 22.03.0 install and boot, if I go to Luci and hit Network -> Interfaces page router immediately becomes unresponsive.
  • Triple restarted again to get back to 19.07.8 and every time I re-install 22.03.0 the router always becomes unresponsive per steps above.

Turns out the odd behavior had to do with a potential corruption on one of my partitions on the WRT32X. I re-imaged 3 times with the factory image (19.07.8 Partition 1 -> installed OEM on Partition 2, then OEM on Partition 2 -> installed OEM on Partition 1, then just in case installed OEM again from Partition 1 -> Partition 2 so it was installed from OEM and not OpenWRT) and that cleared the problem. I then installed 22.03.0 factory image via OEM and it works.

I was inspired by Linksys WRT32X - Partition Swap Issue

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.