21.02 MT76 driver with packet buffer hack for MT7613 devices

Multiple people owning hardware with MT7613 have reported unstable behaviour on the 5 GHz radio (MT7613), resulting in the radio being still up but clients being unable to use the network. The issue is known and documented (GitHub issue #518) but no proper fix exists, except for a hack. Since it's no proper fix, it didn't make it into 21.02.

You can find the driver package including the hack here:

If you're not sure your device is affected, you can find a list of MT7613 devices supported by 21.02 below.

  • I-O Data WN-DX1200GR
  • Linksys E5600 v1
  • TP-Link Archer A6 v3
  • TP-Link Archer C6U
  • TP-Link EAP235-Wall v1

In master there's also support for the TP-Link Archer C6 v3, but master is a moving target so you'll understand I am not providing packages for that.

4 Likes

Hello @Borromini
While installing this driver, should we uninstall any of the already installed packages?

am asking because I installed this package on 2 dumb aps with openwrt and the problem persists, but differently. More than one devices can connect, but, at some point, 5ghz network loses traffic. Devices are still connected or, sometimes, get disconnected, but even when they are connected traffic is not going through.

1 Like

The package has a higher revision number than the original one so no need to remove the old package. The files will be overwritten.

You did reboot right?

Yes, i rebooted many times. I have 2 dumb aps connected to a vm running pfsense as the dhcp server. On 2.4ghz i have 4 cameras and 6 iot devices. On 5ghz i tried adding a mi tv stick, my pc, 2 phones, and a raspberry pi as another streaming device. 5ghz is very unstable, losing traffic to hosts. If i kick a host that lost traffic and it connects to the other ap it works for a while, but in the end it will still fail.
The 2 aps use different channels for radios and they are all running with 802.11r enabled.

It might be that the patched code is in the kmod-mt7615-common binary, I've uploaded a fresh build that includes that kmod as well. Could you try again replacing both kmods?

I've also uploaded images for 21.02.1.

I tried both on 21.02.0 and 21.02.1 and I get:

root@OpenWrt:/tmp# opkg install ./kmod-mt7615-common_5.4.154\%2B2021-06-06-22b69033-5_mipsel_24kc.ipk
Package kmod-mt7615-common (5.4.154+2021-06-06-22b69033-4) installed in root is up to date.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.154-1-c2d5d384e80f344e45bdd99ebe8cdbf5) for kmod-mt7615-common

and

root@OpenWrt:/tmp# opkg install ./kmod-mt7615e_5.4.154\%2B2021-06-06-22b69033-5_mipsel_24kc.ipk
Package kmod-mt7615e (5.4.154+2021-06-06-22b69033-4) installed in root is up to date.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.4.154-1-c2d5d384e80f344e45bdd99ebe8cdbf5) for kmod-mt7615e

L.E.
I am just going with the flow, and, until now, it seems it is working.
L.l.e.
And it is back to not working anymore unfortunately.

Hello everyone, I just got started with 7628+7613 dual-frequency routing, but I have been having difficulty finding 7613 wireless driver on the Internet. Is the driver of this chip compatible with other chip drivers or what is the situation