21.02 HH5A DSL Network device is not present

Hello,
I hope you can advise. I am a long time user of OpenWRT since WRT54G days, but have upgraded to several BT HH5A devices running 18.06 nicely for a few years. I recently bought another as a testbed - because few things ever go to plan - and flashed it with the latest stable image OpenWrt 21.02.1 r16325-88151b8303.
I went to configure the DSL WAN with the usual settings, but I have been met with: Error Network device is not present.

I have spent the last couple of days searching for a solution or material with which I can work out a solution that I could share. I have learnt a lot about the DSA changes in the latest releases and the change in syntax and structure (ifname to device), but there is a lot of early posts that refer to previous revisions - even the hardware device page is not current and I would append my findings there when I reach a remedy.
I have tried flashing different OpenWRT revisions to see how configuration and behaviour changes. Each flash was clean without configuration:
image
The lastest development release didn't present a browser interface, so I flashed a previous release using SSH.
The only revision that recognised the DSL was 18.06 which is years old, but made me think perhaps I have the name wrong, yet a post in the topic: HH5A - wan “device not present” after reboot this should work fine.

I can configure the WAN ethernet port using eth0.2 successfully as a test, but I want to use the internal DSL modem, yet it is not recognised.
image

Removing the test WAN my network config (set up for UK TalkTalk) MAC addresses replaced is:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd81:f7c2:61df::/48'

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr 'xxxxxxxxxxxxxxxx1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.0.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option device 'dsl0.101'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config device
	option name 'dsl0.101'
	option macaddr 'xxxxxxxxxxxxxx2'

I am at a loss what to try next and feel I am now going around in circles and so Iwould appreciate some direction on a possible remedy.

On brief inspection, I can't see anything obviously wrong with the config file, unless there is a syntax error.

No reason why the latest 21.02.1 shouldn't work with DSL.

Did you clear all settings before attempting to set up the DSL connection from scratch after flashing new firmware version as per guide?

https://openwrt.ebilan.co.uk/viewtopic.php?t=266

Only suggestion is reinstall 18.06 to get DSL and confirm internet working.
Then upgrade using LuCI with 'keep settings' to 19.07.

Repeat again to upgrade from 19.07 to 21.02 with 'keep settings'. This will convert the /etc/config/network file to new syntax.

HH5a stable releases do not support DSA.

ps. is dsl_control enabled as I note one of images shows eth0.2 interface?

Hi Bill,
Thank you for the rapid response.
All settings were cleared before setting up the DSL connection with many, many resets to test each change, so I was sure if I found the answer exactly how I arrived at it :slight_smile:

I attempted the migration path you suggest - and repeated it again just to be sure - and between 19 and 21 the configuration transfers, yet is modified during access of the LuCI Intefaces page.


18.06 network config relevant parts:

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option ds_snr_offset '0'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'dsl0.101'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr 'xxxxxxxxxxxxxx'

Importantly the interface dsl0.101 appears to be recognised:
image

Upgrading to 19.07 with config:


On the Interface page the WAN network device is not recognised similar to how it is in 21.02...

However, unlike 21.02 under theInterfaces>WAN>Physical Interfaces the device is not appearing as Device Absent:
image

Relevant parts of network config:

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option ds_snr_offset '0'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'dsl0.101'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'ac:3b:77:27:d4:ef'

The WAN device name changes slightly to "wan_dsl0_dev". I checked and tested this as the previous "wan_dev", but it appeared to make no difference.

Upgrading to 21.02 testing keeping the config:
image
Going to interfaces:
image
image


The DSL page looks fine, yet the devices page shows the dsl0 network device as not present:
image

So no improvement. Running a firstboot && reboot now, to clear the config clears the configuration, but the network devices remain as not present.

To answer you question:
" ps. is dsl_control enabled as I note one of images shows eth0.2 interface?"
I understand eth0.2 is the Red WAN port alongside the 4 Yellow LAN ports and can be configured as an additional LAN port if necessary or as a WAN port for connection to a VDSL model.
I am unaware of dsl_control and have not seen reference to it in my searches, except in pages for devs - requiring a little more headspace than I can cope with at the moment.

This should be option name 'dsl0'

This appears to be missing some options. (I do have newer firmware so that line can be ignored)

Mine is as follows.

config dsl 'dsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option ds_snr_offset '0'
	option tone 'a'
	option firmware '/lib/firmware/vr9-B-dsl-5.9.1.4.0.7.bin'

If you want to cross compare, my config file for my HH5A is below.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda6:5756:1e1d::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr 'MACADDRESS'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option igmp_snooping '1'

config device
	option name 'dsl0'
	option macaddr 'MACADDRESS'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config dsl 'dsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
	option ds_snr_offset '0'
	option tone 'a'
	option firmware '/lib/firmware/vr9-B-dsl-5.9.1.4.0.7.bin'

config interface 'wan'
	option device 'dsl0.101'
	option proto 'dhcp'
	option mtu '1500'
	option ipv6 '0'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option delegate '0'

(edit) I am on 21.02 not the 21.02.1 point release but the dsl interface should still be the same.

1 Like

as an addendum?

I use a script to re-setup the HH5 from a clean flash as by default it has a bridge port that requires deleting and then you create the DSL connection.

# === Set up the WAN (eth0) interface ==================
# Default is DHCP, this sets it to PPPoE (typical for DSL/ADSL) 
# From http://wiki.openwrt.org/doc/howto/internet.connection
#
# echo 'Configuring WAN link for PPPoE'

uci delete network.atm
uci delete network.dsl
uci delete network.wan

uci set network.globals.packet_steering='1' #Use every cpu to handle packet traffic

uci set network.dsl=dsl
uci set network.dsl.annex='b'
uci set network.dsl.xfer_mode='ptm'
uci set network.dsl.line_mode='vdsl'
uci set network.dsl.ds_snr_offset='0'
uci set network.dsl.tone='a'
uci set network.dsl.firmware='/lib/firmware/vr9-B-dsl-5.9.1.4.0.7.bin' #newer firmware

uci set network.lan.igmp_snooping='1' #for iptv

uci set network.wan=interface
uci set network.wan.device='dsl0.101'
uci set network.wan.proto='dhcp'
uci set network.wan.mtu='1500'
uci set network.wan.ipv6='0' #Talktalk still has no ip6
uci set network.wan.peerdns='0'


uci commit network
ifup wan
echo 'Waiting for link to initialize'
sleep 20
1 Like

Hi Bill,

Its @MattSouthgate with the issue. :slight_smile:

Your guides helped me from my first exploring of my HH5 years ago. Many thanks for those. I should dig out my backup one and see if 21.02.1 does change anything to 21.02. I checked my configs and the dsl device having the vlan attached when it should be referencing the base device is the only thing that stood out to me.

Matts is dsl0.101 and that VLAN should only be referenced as the WAN not the base DSL device correct?

1 Like

I'm puzzled why the upgrade from 18.06 to 19.07 would fail.

Well spotted by @mercygroundabyss . The 'dsl' section does look a bit bare.

Otherwise, ignoring 21.02 for the moment.

If you still have issues, can I suggest you put older 19.07.6 onto the HH5a?
Factory reset it to clear all openwrt settings.
Manually set up DSL connection using LuCI by following my guide.

My guide does suggest to set the encapsulation and DSL modes, but I said it was 'optional' (when the guide was first written for LEDE 17). Perhaps it is mandatory since 19.07?
0encap

If there were problems setting up DSL connection with 19.07, it would have been widely reported over the past 2 years.

ps. dsl_control is mentioned in section 7.13 of my guide.

The missing config options are absent because 'auto' was selected.

The changes to dsl0 related to changing all instances of dsl0 to dsl0.101. Having read and tried so many slightly different approaches, without success, and given I thought this would be straightforward - though not necessarily quick - I am now at the stage of not understanding the reasoning for some forum posts.
Many posts refer to much earlier versions of the firmware and I haven't found an up to date guide or documentation.

Regardless, I have reflashed (OpenWrt 21.02.1 r16325-88151b8303) and issued: firstboot && reboot now, to clear any configuration.
I have executed your UCI commands.
This is the first time I have encountered the entry for specifying a firmware, since this was not needed visible/needed for 18.06. I have searched and read the Lantiq recommended firmware thread. The thread covers a lot more than just a few reported firmwares.

I searched for and fund the xDarkLight github page for Lantiq xDSL firmware, but the link to the version of the firmware you use for Annex B is a broken 404 link.
I'm an electronics and embedded engineer, so I suspect I know the answer, but is the firmware required? I remember reading somewhere it is only needed for vectoring and could not be bundled with OpenWRT for license reasons. Yet, running the report command on my connected v18.06 BT HH5A produces:

 OpenWrt 18.06.4, r7808-ef686b7292
 -----------------------------------------------------
root@OpenWrt:~# echo; egrep '"id":' /etc/board.json | sed -nE 's/(\s*"id":\s")(.
*)(",)/\2/p'; egrep 'OPENWRT_RELEASE' /etc/os-release | sed -nE 's/(OPENWRT_RELE
ASE=")(.*)(")/\2/p'; /etc/init.d/dsl_control status | egrep 'ATU-C Vendor ID:|Fi
rmware Version:|Line Mode:|Annex:|Line Uptime:'

bt,homehub-v5a
ATU-C Vendor ID:                          Broadcom 164.161
Firmware Version:                         5.7.9.9.0.6
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Line Uptime:                              2d 20h 4m 14s

So the firmware in version 18.06 is embedded?

Anyway, back to the HH5A with 21.02.01 installed, the network interface is still showing as absent on the Devices and Interface pages.
image
image

I will install: 19.07.6 and report back, but I just wanted to provide a response because I have been unavailable for the past couple of days - I have long-COVID with brain fog. :frowning:
Matt

The lantiq firmware is included in all openwrt images for the HH5a from LEDE 17 to OpenWrt 21.

There is no need to specify path to alternative firmware unless you plan to use a later release extracted from another router.

That is good to know that modem firmware does not need to specified and is embedded.
I flashed the suggested 19.07.6 firmware and without success.

I apologise because I did not check that the DSL connection works, because I am in a house where it is constant use and complaints come thick and fast for even a brief hiccup. I trusted that the hardware would work if the interface appeared to be correct in the web GUI. I have flashed 18.06.9, configured, connected and nothing. Then the same firmware as on my other units 18.06.4, configured and the DSL interface remains at DOWN when connected to the line. I tried stopping, starting and reconnecting though LuCi. I have been searching for more info on dsl_control and contacted the vendor who supplied the flashed device.
image

I am starting to suspect the hardware.
I am going through the Ebilan forum guide for OpenWrt/LEDE Installation Guide for BT Home Hub 5A in case I missed something.

I spotted the Nov update for section 7.32 ‘Network device is not present’
Using 19.07.6 and explicitly setting the physical characteristics does not resolve the Network device is not present:
Network config:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb5:993b:d464::/48'

config dsl 'dsl'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option tone 'a'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'ac:3b:77:27:d4:ee'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'dsl0.101'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'ac:3b:77:27:d4:ef'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

I am happy to perform testing and so I've included MAC addresses, but my confidence has taken a knock and I am frustrated by my lack of progress.

EDIT:
I have spotted that the broadband led on the front of the unit has never illuminated.
Duplicate an existing setup that works: I have reflashed the firmware v18.06.04 that is on my main HH5A and backed up and applied the config to the new unit. No DSL activity whatsoever... Line state remains DOWN[0x0]

I have just attempted to replicate mercygroundabyss setup with the 21.02 branch and used the provided uci commands through ssh to configure.
Still no success.
I had used the same commands on many different versions.

Perhaps it is a version conversion, but the systems overview page shows the DSL status to be Silent, not DOWN - I had spotted this before and thought nothing of it:
image

ok. having looked at your config you posted that seems correct (it certainly matches mine). Your previous config, the only error i saw was naming the dsl device with the VLAN number (which you add via the WAN section instead)

So you have duplicated another HH5 to this HH5 and there is no DSL at all? This is beginning to sound like your backup HH5 DSL may be dead. Maybe time to pop the cover off that HH5 and examine the board for damage.

Regarding the firmware, Yes it is inbuild to the OpenWRT releases but i added in a newer firmware that was posted on bills forums. They are generally extracted from Friztboxs.

Edit (at risk of incuring wrath of those in your house. Maybe upgrade to 21.02.1 on your working HH5? or do you have another router for testing?)

Your DSL stats look like the phone line connection is missing.
My ISP uses VLAN35 in Ontario/Quebec
From a known working backup:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'aaaa:bbbb:cccc::/48'

config atm-bridge 'atm'
	option vpi '0'
	option vci '35'
	option encaps 'vc'
	option payload 'bridged'
	option nameprefix 'dsl0.35'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '00:11:22:33:44:55'

config interface 'wan'
	option ifname 'dsl0.35'
	option proto 'pppoe'
	option password 'password'
	option ipv6 '1'
	option username 'user@isp.com'

config device 'wan_dev'
	option name 'dsl0.35'
	option macaddr '00:11:22:33:44:56'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config interface 'wan6'
	option proto '6in4'
	option peeraddr '111.22.33.44'
	list ip6prefix '2001:111:222:333::/64'
	option ip6addr '2001:111:222:334::2/64'

Avoiding the wraith of the household was exactly why I ordered a spare to work on in the first place!

1 Like

so just to confirm. This backup HH5 has never got a dsl connection with any version of openwrt? I'd definatly be leaning towards faulty hardware if that is the case.

(edit) I assume you used your old HH5 dsl cable and power unit? (just to rule out faulty cables)

1 Like

I actually added tip to specify encapsulation following your observations last week. I will remove it later given it now looks like your HH5a may be defective....

1 Like

My backup HH5A sometimes doesn't find the DSL line.

@murraydr44 Plugging in the DSL line does nothing.
@mercygroundabyss I exchanged the PSUs as part of the initial fault finding.
@bill888 thank you for all your help.

This device has never connected to DSL and my default position is to assume it is something I have done.

Stating the obvious, but have you visually inspected and tried a different the DSL cable into the HH5a, and checked the RJ11 socket in HH5a for bent pins?

1 Like