21.02 Clean install no problem, Imagebuild with config files not running (Raspberry Pi 4 v1.2)

Raspberry Pi 4 v1.2
Managed switch SG105E

When I flash a clean image (21.02-SNAPSHOT for rasp Pi) on a micro sd card there's no problem. Then I can log in and configure everything without issues.

Then I copy the /etc files and make a list of installed packages for the imagebuilder.

When I use the imagebuilder (21.02-SNAPHOT for rasp Pi) and add al the packages en config files that I normally configure manual. (The build is running without any errors) I can as usual flash the firmware on the micro sd. But when I boot the Raspberry it boot until you can see the image in my screenshot. Hitting enter on the keyboard does nothing. So something is going wrong. Anyone any idea?

make command when using the imagebuilder.

make image PROFILE=rpi-4 PACKAGES="adblock banip etc etc" FILES=files/

I use the squashfs factory

It literally asks you to hit Enter. Did you do that?

I am not a OpenWrt Raspberry user, but the boot process looks pretty normal at the first glance.

First guess is that something in your added config is wrong.
Start simple. Add a few packages and test.
Add a few config items, build and test.
Try to identify the culprit config setting.


Likely yes

1 Like

My money is on the necessary input drivers missing.

Second I'd hook up a cable and SSH in, then start poking around. That's the default use case for OpenWrt.

1 Like

Thanks for your reply's so quicly :wink:

@hnyman I just did an image build with al the packages but without the FILES=files/ option.

That worked, so it must be in my config files. So I will try to find out what config breaks my config.

1 Like

fwiw... i've built(IB) with 21.02-SNAPSHOT and found no functional issues... ( which confirms your FILES theory )...

(prior to the recent kernel 111 commit it possa-probly had some utilisation issues but seems ok now)

that said... console serial is my (and 'the'?) preferred console interaction method... so usb keyboards+video out are a world unto their own... and likely not subject to a version related issue...

Thanks for the help. It seems to work (the basics) even with some config files.
The only thing left is that my tun0 (openvpn) is not comming up the right way.

If I config all from scratch is working, but when I make a build with the minimum config files it doesn't come up right.

I want to have it this way, so I can reset to " factory". Factory is then my minimum configured install.
If I doe a reset to factory now, It's a lot of work to config.

So for this threat it is resolved :wink: The build is running and the problem is/was the config files.

All is working now, accept one thing.

The tun0 didn't came up because a script in /etc/openvpn wasn't an executable after copying the config and build.

Is there a way to set the script(s) as executable before the build?

Sorry, figured it out. just set the chmod settings before build. So solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.