21.02.0 impact on Canon Wireless Printers

A standalone Canon MG5570 connected to the wireless network (via a Meraki MR33 originally running 19.07 latest stable version) was working perfectly with the printer and other wireless clients on the same network. Upgrading to 21.02.0 has resulted in the printer no longer being able to secure a wireless connection even though it can still see the ESSID. I have tried this with WPA2-PSK (as used previously in 19.07.x) and the newly inbuilt mixed mode with WPA3. All other clients (Windows, Mac, iPhone, Android) are working just fine.

The MR33's 3 antennae are all active and providing coverage across the acbgn networks and in the 2.4 and 5GHhz frequency ranges (each antenna has slightly different capabilities)

My question is... Is there any way I can debug this to figure out what might be happening?

Start by disabling WPA3 and using exclusively WPA2, quite a few (proprietary-) clients don't work properly in mixed mode.


The most likely culprit is 802.11w (Management Frame Protection), which is required by WPA3. Many problematic clients will silently fail to connect without producing any useful output due to firmware (as in the firmware that runs on the radio) bugs, even if 802.11w is set to optional. This is extremely common on Broadcom and Marvell radios. Try completely disabling 802.11w and restarting the printer, if that solves your problem and you would like to keep 802.11w, you can probably set up a different dedicated SSID on that discrete pcie 1x1 radio that your MR33 has (if you are not currently using it right now), as these IoT devices such as a printer won't require any high bandwidths anyway.


Appreciate the insight and guidance. I'll experiment with these settings and let you know!

Quick update.. Disabling 802.11w first, applying changes, then dropping back to WPA2-PSK (auto encryption) worked perfectly.

I guess this one's on Canon :wink: Thanks again for the assist!

1 Like

It is more on any old device driver.

The assumption that old devices can fulfill the new functionality requirements is wrong, as OEMs have no incentive to do major upgrades to the drivers in old devices. Your device is from early 2010s, right? Before 2013? Why update that? Canon would like to sell you new device instead.

So, some realism: with devices from year X, expect to stick to wifi protocols/features available in year X. Trying to use all functionalities of year 2021 OpenWrt with that year 2013 device, is just futile. :frowning:

Ps. 802.11w is problematic even for some new devices. E.g. the top-notch Linksys WRT3200ACM has trouble with WPA3, as the wifi firmware mishandles 802.11w.

Sadly even brand spanking new, just released, devices tend to be problematic, in particular the less interactively used/ upgradeable ones, like printers, scanners, infrastructure devices, surveillance cameras, the whole IoT universe (anything with esp8266/ esp8285 can't do WPA3 or 802.11w) has serious issues with standards compliance and modern features (IPv6, WPA3, …). Their embedded wireless modules/ stack usually lag behind significantly, both in terms wireless standards (it's not uncommon for those to be 1x1 2.4-GHz-only 802.11n based, if that) and support for less mainstream parts of the IEEE 802.11 protocol suite.

1 Like

Oh, I'm not complaining at all. I'll setup a separate wifi for the older devices. Sold my older Apple TV4 HD for this reason. Printers are cheap, I just feel bad about the mounting junk pile :wink:

Glad you got it working. Basically if anything mysteriously fails to connect on WPA3 (insisting the password is incorrect, or just giving you generic errors), even if you drop back down to WPA2, 802.11w might still have been set to optional. Some radio firmware and drivers just don't like 802.11w at all, and a lot of them are very unlikely to ever receive firmware updates to correct this. They should have ignored 802.11w and just not use it if it's optional, but in most of the cases I've seen, that is not the case at all.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.