2 WAN & OpenVPN & VPN Policy Routing problem

Hello community,

sorry, but I need some help.
I know, here're some guys with a excellent knowledge and hopefully you can help me.

I'm using OpenWRT OpenWrt 18.06.5

There're 2 WANs
WAN: PPPoE
WAN2 (mobile router, connected via cable in LAN port): DHCP client (this is managed via VLAN, see config below)

They're managed by VPN-Policy-Routing (lets call it VPR for a shorter text) and it works well.

Now I decided to use EXPRESSVPN, and this VPN provider must (and there is no other way) use only my WAN connection (not WAN2 in any case).
Unfortunately I do not understand the tunX stuff for OpenVPN connections.

What did I do:
In the ovpn file I added: "local balumba.no-ip.info" (that's my DDNS address, managed by OpenWRT).
So far, so good.
I can manage every connected device in LAN to use the defined WAN / VPN connection (defines in VPR).

As I said before, I also use DDNS, this is working as well.
balumba.no-ip.info is defined in DDNS and get my WAN IP.

But now, a router request with:

dig +short myip.opendns.com @resolver1.opendns.com

returns the IP of EXPRESSVPN (and not my WAN IP).
Due to this I'm unable to use port forwarding.

Maybe I'm doing this stuff wrong.
Thats the reason to ask for help here.

Maybe anybody give me a hint.

Thanks!

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd58:ef8e:91d5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '8.8.8.8 208.67.222.222 208.67.220.220'

config interface 'wan'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '*****'
        option password '*****'
        option ipv6 'auto'
        option ifname 'eth0.2'
        option keepalive '0'
        option metric '10'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.2'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '4 6t'

config interface 'wan2'
        option proto 'dhcp'
        option ifname 'eth0.3'
        option metric '20'

config interface 'vpn'
        option proto 'none'
        option ifname 'tun0'

config interface 'guest'
        option proto 'static'
        option ifname 'guest'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config interface 'wan26'
        option proto 'dhcpv6'
        option ifname 'eth0.3'
        option reqaddress 'try'
        option reqprefix 'auto'