2 separate connections on a single physical port

Hi. I am having a trouble configuring a WR841ND-v13 running openwrt v22, as follows. I have an ethernet cable coming from my ISP connected to the WAN port of the router. What i want to achive is have 2 separate connections to the ISP using only a single physical port, in my case the WAN port. One connection connects to the ISP using the pppoe and the other DHCP client. Then each connection should be in a separate VLAN, one is the default (VLAN1) and the other (VLAN5).

I am not sure if that is actually possible without using an additional switch, if it is possible please point me to a guide on how to do that.

I'm not sure openwrt will handle 2 isolated NAT translation layers

You could create a second (virtual) interface using macvlan.

https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3#single_wan_port

2 Likes

Thanks man. Now I am a step closer to what i am trying to do. The virtual Ethernet is what i was missing so far.

I have three separate connections on the same WAN port, as my provider runs internet (on PPPoE), VOiP (on DHCP), and IPTV, on three different VLANs (it's called "triple play"). Share your current network config files, and the details of your ISP.

Hi again. After some investigation it turned out that the router i was using (wr841n) does not support mixed ports (untagged for a vlan and taggeg for other) which was important for my setup, so i was stuck until found a suitable device. Now i have changed my goal a little bit. Instead of having 2 separate connections, I want 1 pppoe connection and 1 vlan bridge to the same wan port. Currently I did setup 2 macvlans on the physical wan port. First i created pppoe interface on it, and it works fine. For the second macvlan, i put it into the bridge and add VLAN 10 as untagged on it. When i connect a device over lan2, which is also on the same bridge and untagged for the same vlan 10, it successfully connects to the ISP using DHCP, and then pinging the default gateway does not work, and the captive portal does not as well. So i am not sure if macvlans support this task, which should be just a layer 2 switching between a vlan and a virtual port instead of a physical. No interface is assigned to the second macvlan nor to VLAN10. I tried configuring the macvlans in VEPA and bridge mode, and both do not work.

Can you please check my last post.

What I'm going to suggest is purely theoretical (because I can't test it) and it's based on the following assumptions:

  1. The router supports more than one bridge.
  2. In v13 the wan port is still connected to eth1 and the LAN switch to eth0.

You shouldn't need virtual interfaces at all.

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth0.10'

config interface 'wan'
        option proto 'pppoe'
        option device 'br-wan'
        option username 'user'
        option password 'secret'
	    ...

config switch_vlan
        option device 'switch0'
        option vlan '10'
        option ports '0t 3'
        option vid '10'

With this configuration (again in theory), the wan interface should get an IP address from the ISP via PPPoE, and the device connected to LAN2 should get an IP via DHCP.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.