2 Radios - Client and AP(master) - No SSID being Broadcast

It's taken me awhile but I finally got both radios up and running and I have radio1 connected to my WIFI network to act as my "wan". I am now trying to get radio0 to be an "ap" so that it can be connected to and then eventually masqueraded out through the wan. However I do not believe radio0 is fully up as I don't see any SSID being broadcast...

Here is my /etc/config/wireless :

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option disabled '0'
	option channel 'auto'
	option country 'CA'
	option legacy_rates '1'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan_wifi'
	option mode 'ap'
	option ssid 'Ares'
	option encryption 'psk2'
	option key 'HIDDEN'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option country 'CA'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'wan'
	option mode 'sta'
	option ssid 'Titan'
	option encryption 'psk2'
	option key 'HIDDEN'

And here is my /etc/config/network :

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda2:5bf1:ba3a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '78:54:2e:97:59:1a'

config interface 'wan'
	option proto 'dhcp'

config interface 'lan_wifi'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option type 'bridge'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

And finally my ifconfig :

br-lan    Link encap:Ethernet  HWaddr 78:54:2E:97:59:1A  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7a54:2eff:fe97:591a/64 Scope:Link
          inet6 addr: fda2:5bf1:ba3a::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2181 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1936 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:237316 (231.7 KiB)  TX bytes:493474 (481.9 KiB)

br-lan_wifi Link encap:Ethernet  HWaddr 00:0C:43:26:60:B8  
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 12:7D:D1:88:88:CC  
          inet6 addr: fe80::107d:d1ff:fe88:88cc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25604 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21870 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3024714 (2.8 MiB)  TX bytes:6320576 (6.0 MiB)
          Interrupt:5 

eth0.1    Link encap:Ethernet  HWaddr 78:54:2E:97:59:1A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2181 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1936 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:237316 (231.7 KiB)  TX bytes:493474 (481.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:883 errors:0 dropped:0 overruns:0 frame:0
          TX packets:883 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:99364 (97.0 KiB)  TX bytes:99364 (97.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:0C:43:26:60:B8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 78:54:2E:97:59:1A  
          inet addr:10.200.100.59  Bcast:10.200.255.255  Mask:255.255.0.0
          inet6 addr: fe80::7a54:2eff:fe97:591a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6367 errors:0 dropped:0 overruns:0 frame:0
          TX packets:177 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1559794 (1.4 MiB)  TX bytes:27686 (27.0 KiB)

Keep in mind most of the stuff in network was already there.. I only added the 'wan' and 'lan_wifi' interfaces. I've also tried not using the option type 'bridge' on the lan_wifi which works and just moves my static IP 192.168.10.1 to wlan0 in ifconfig. However I still do not get an SSID broadcast. When I say "broadcast" I mean not working at all. It's not that it's hidden, it's just not even transmitting as I can't connect to it manually by entering in the SSID on my laptop.

Welcome any help or insight here.

The 5 GHz radio needs to be set to option hwmode '11a', not g.

This is not the case with your config, but keep in mind that if you define both an AP and a STA on the same radio, the AP will not work unless the STA has made its connection.

Thank you mk24.

I made the change to 11a on radio0 Unfortunately this made no difference.

There are two different radios on this device (Dlink - DIR-510L). Hence the different "option path"s I believe?

Any other thoughts?

Hmm.. I take that back. It finally came up. Took 10 minutes to do so? Is that odd or normal behaviour? Perhaps it was just trying to find a channel space?

@etep15, welcome to the community!

Some upper 5.4 GHz channels require a radar scan before coming active.

See: http://wifi-insider.com/wlan/dfs.htm

@lleachii Thank you very much. That makes sense.

Another thing I noticed is that if I just "reboot" my router the 5GHz radio doesn't come back up. I have to hard reboot it. May be just something odd in the firmware. This is an old little mobile router.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.