2 question on 19.07.0 - SSH issue,Backup packages

Hi everyone, every time I update the firmware of my router I lose the additional apps that I have installed but not the settings. In fact once I re-install the applications I find the settings already made. I would therefore need (if feasible) that when I back up the settings, it would also backup the additional apps so that I don't have to manually reinstall them every time.

Second problem: Every time I do a factory reset I disable the dropbear. Now, however, out of necessity I would like to reinstall it but there is no way to do it. Once installed, Dropbear does not respond from SSH and on CMD say "ssh: connect to host xx.xx.x.x port 22: Connection refused" I tried openssh server and it works but despite I enter the correct password it always returns access denied incorrect password. I leave the error attached. I hope it is useful.

Thank youdrop

Which device?

If you're disabling dropbear through the config file (rather than by disabling the service), it will stay disabled after reinstall. Those messages are normal and telling you that it is going to continue to use the existing config file. If that file is a disabled or bad config it will stay disabled or bad.

When dropbear does answer your connection but rejects the password, make sure you are requesting a login as username root. The only active user is root.


Archer C7 v5

So what must or can i do? Because i use root user but nothing do do.

For the first problem, my suggestion is to learn how to use Image Builder in order to create the image with all the apps you need, so you don't have to reinstall them manually. It will also increase free space.

For the second problem: check the config file to see if it enabled on lan and use root@IP to login. If the service is stopped, " /etc/init.d/dropbear start " stars it even if it was disabled (to enable it: /etc/init.d/dropbear enable). Of course you can use luci too.

1 Like

For image builder I'm interested. Where can I find the instructions for doing this procedure?

For the drop-bear problem I tried to re-enable the graphical interface with drop-bear started but access is still denied by cmd / putty etc. Yes, as I would have been a little broke to try I think I will make a factory default but I also believe that somewhere there is a bug to solve. Thank you.


A factory default is useful to start fresh without the probable error in the configuration.


Thank you @SteMax97