2.4GHz radio not working on a Redmi AX6S

Hello everyone!

I am using Redmi AX6S with OpenWrt 23.05. After update (a month ago) everything worked fine, but yesterday my 2.4GHz radio suddenly stopped working after I enabled guest wifi. I have 2 networks on that radio - iot and guest. Was unable to find any solutions through googling, so I figured I corrupted something with this 2-network configuration and just flashed a new copy of OpenWrt. After that the radio started working again. But today it broke again after I rebooted the router.

Not sure if it is connected to the new firmware version. My router is around a year old, and was running previous version without any issues.

Rebooting the router or restarting the device doesn't help. So I am kindly asking your help here.

Here are configs and logs that seems relevant to the issue.

config device
        option name 'br-iot'
        option type 'bridge'
        list ports 'lan3'

config interface 'iot'
        option proto 'static'
        option device 'br-iot'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option channel 'auto'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'iot'
        option device 'radio0'
        option network 'iot'
        option mode 'ap'
        option ssid 'myssid-iot'
        option encryption 'psk2'
        option key '<key>'
        option wpa_disable_eapol_key_retries '1'
Sat Nov 11 19:31:57 2023 daemon.notice hostapd: Set new config for phy wl0:
Sat Nov 11 19:31:57 2023 daemon.notice wpa_supplicant[2512]: Set new config for phy wl0
Sat Nov 11 19:31:57 2023 daemon.notice netifd: Wireless device 'radio0' is now down
Sat Nov 11 19:31:57 2023 daemon.notice netifd: radio0 (4959): WARNING: Variable 'data' does not exist or is not an array/object
Sat Nov 11 19:31:57 2023 daemon.notice hostapd: Set new config for phy wl0:
Sat Nov 11 19:31:57 2023 daemon.notice wpa_supplicant[2512]: Set new config for phy wl0
Sat Nov 11 19:31:58 2023 daemon.notice wpa_supplicant[2512]: Set new config for phy wl0
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: Set new config for phy wl0: /var/run/hostapd-wl0.conf
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: Restart interface for phy wl0
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=RU ieee80211d=1 hw_mode=g supported_rates=60 90 120 180 240 360 480 540 basic_rates=60 120 240 beacon_int=100 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1] channel=acs_survey  interface=wl0-ap0 bssid=d4:da:21:73:de:e3 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=0 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=0 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 wpa_passphrase=ydhyXUjJfKssBDcgkBE3 wpa_psk_file=/var/run/hostapd-wl0-ap0.psk auth_algs=1 wpa=2 wpa_pairwise=CCMP ssid=fnet-iot bridge=br-iot wds_bridge= snoop_iface=br-iot wpa_disable_eapol_key_retries=1 wpa_key_mgmt=WPA-PSK okc=0 disable_pmksa_caching=1 dynamic_vlan=0 vlan_naming=1 vlan_no_bridge=1 vlan_file=/var/run/hostapd-wl0-ap0.vlan
Sat Nov 11 19:31:58 2023 daemon.err hostapd: Could not set interface wl0-ap0 flags (UP): I/O error
Sat Nov 11 19:31:58 2023 daemon.err hostapd: nl80211: Could not set interface 'wl0-ap0' UP
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: nl80211: deinit ifname=wl0-ap0 disabled_11b_rates=0
Sat Nov 11 19:31:58 2023 daemon.err hostapd: nl80211 driver initialization failed.
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: wl0-ap0: CTRL-EVENT-TERMINATING
Sat Nov 11 19:31:58 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface wl0-ap0 wasn't started
Sat Nov 11 19:31:58 2023 daemon.notice hostapd: hostapd.add_iface failed for phy wl0 ifname=wl0-ap0
Sat Nov 11 19:31:58 2023 kern.info kernel: [ 7007.735526] br-iot: port 2(wl0-ap0) entered blocking state
Sat Nov 11 19:31:58 2023 kern.info kernel: [ 7007.741132] br-iot: port 2(wl0-ap0) entered disabled state
Sat Nov 11 19:31:58 2023 kern.info kernel: [ 7007.746845] device wl0-ap0 entered promiscuous mode
Sat Nov 11 19:31:58 2023 kern.info kernel: [ 7007.760066] device wl0-ap0 left promiscuous mode
Sat Nov 11 19:31:58 2023 kern.info kernel: [ 7007.764788] br-iot: port 2(wl0-ap0) entered disabled state
Sat Nov 11 19:31:58 2023 daemon.notice netifd: Wireless device 'radio0' is now up

Same problem here - with 23.05 and Snapshot. Main network works ok, all additional 2/5G - no. Tried to figure out what can cause it - without success. Have no errors in log - all seems to be ok. Now reverted to 23.03.5. Using as pure AP with guest network (VLAN).

Have you tried 23.05.2? For me running smooth so far. Hopefully the issue is gone.

Thanks for the info. I haven't tried it yet - I use ax6s as my main home AP, will try it this weekend.

Tried 23.05.2 all possible ways - with the default prebuild image and my own, with the same result: no traffic between the bridge and the additional WLAN interfaces. Bridge, VLAN, etc. work fine.