2.4Ghz packet loss with TL-WR902AC

G'day everyone

New to OpenWRT so go easy on me please.

I've successfully installed OpenWRT 21.02.3 on my TL-WR902ACv3 device. It's being used as a Wi-Fi client for a dumb device that only has an ethernet port.

When I associate it to a 5Ghz access point, the throughput is great: 90Mbs or about 90% of what I get with other devices on my network. However if I use an AP configured for 2.4Ghz, then throughput is ~0.5Mbps. A Wireshark trace shows significant retransmissions and packet loss.

I've tried tweaking every possible setting in LuCI related to the 2.4Ghz Wi-Fi client config to no avail. The client device is 2m from the AP, with no radio interference going on. Note too that I have about 20x IoT devices that are using the same AP without issue (all 2.4Ghz).

root@OpenWrt:~# iwinfo
wlan0     ESSID: "IoT"
          Access Point: 14:EB:B6:48:05:12
          Mode: Client  Channel: 1 (2.412 GHz)
          Center Channel 1: 1 2: unknown
          Tx-Power: 24 dBm  Link Quality: 70/70
          Signal: -39 dBm  Noise: unknown
          Bit Rate: 144.4 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 14C3:7628 14C3:0004 [MediaTek MT76x8]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option band '2g'
        option country 'AU'
        option txpower '24'
        option cell_density '0'
        option htmode 'HT20'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'none'
        option disabled '1'
        option ssid 'OpenWRT'
        option disassoc_low_ack '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option cell_density '0'
        option htmode 'VHT20'
        option channel 'auto'
        option txpower '13'
        option disabled '1'
        option country 'AU'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'none'
        option ssid 'OpenWRT'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'IoT'
        option encryption 'psk2'
        option key '*'
        option disassoc_low_ack '0'
        option dtim_period '2'
        option skip_inactivity_poll '1'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'MySSID2'
        option encryption 'psk2'
        option key '*'
        option disabled '1'

My home network is Unifi, and the AP's are the U6-LITE.

Any pointers would be appreciated....

Try setting an actual channel, instead of using auto.

The issue is reproducible on my iPad if I force 2.4Ghz, so concluding it must be radio interference, even though my tools are showing very low bandwidth utilisation.

Thank you for your help - closing this one out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.