2.4GHz device and 5GHz device can't see each other in LAN

I have a router and 2 devices (2.4 and 5).
I want to drop a file from 2.4 device to the 5ghz device via Samba (which is running on 5ghz)
But devices can't see each other in LAN.
What to do?
If I switch from 5ghz to 2.4ghz, then all is fine.

Please post network & wireless files

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdf4:1e63:6e0c::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'xxxx'
	option password 'xxxx'
	option ipv6 'auto'
	option peerdns '0'
	option dns '9.9.9.9'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '2g'
	option cell_density '0'
	option htmode 'HT20'
	option channel 'auto'
	option txpower '13'
	option country 'GB'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'sae-mixed'
	option ssid 'abcdef'
	option key 'abcdef'
	option wpa_disable_eapol_key_retries '1'
	option macfilter 'deny'
	list maclist '44:F8:44:F8:44:F8'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option cell_density '0'
	option htmode 'VHT40'
	option channel '64'
	option txpower '14'
	option country 'GB'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option wpa_disable_eapol_key_retries '1'
	option encryption 'sae-mixed'
	option ssid 'abcdef'
	option key 'abcdef'

Ignore samba for now, try to ping the systems from each other (some operating systems/ firewalls ignore pings by default, so make sure that pings are allowed).

From a first glance, your configs appear to be fine - br-lan ties lan1, lan2, lan3 and both wireless AP interfaces together by bridging, that 'should' work. At least for testing, I would drop the MAC filter.

Funny how it works now. I have no further questions :smiley:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.