2.4 GHz Isn't working properly

I have installed openwrt, on TP Link Archer C6 V3, my 2.4 GHz network is not working properly, although I get singnal on the phone, after a while, the singnal is disappearing. And 5 GHZ signal is very strong. I am using openwrt latest version. How to solve it?

Let's start with your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

The above commands are to be run from your router after you ssh into it (if you're using Windows, most people use PuTTY; on Mac or Linux, just use a terminal). You'll ssh using user root, password is either blank by default or whatever you set.

1 Like

Please copy and paste the output and use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik
Please edit your post accordingly. Thank you! :slight_smile:

[

quote="psherman, post:2, topic:154881"]
`ubus call system board`
[/quote]

{
"kernel": "5.10.161",
"hostname": "JahidKhan",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "TP-Link Archer C6 v3",
"board_name": "tplink,archer-c6-v3",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "22.03.3",
"revision": "r20028-43d71ad93e",
"target": "ramips/mt7621",
"description": "OpenWrt 22.03.3 r20028-43d71ad93e"
}
}

run each command (each line) individually, then copy and paste it into this forum -- be sure to click the </> code block button in the formatting bar and paste the contents into place.

Meanwhile, what you PM'd me indicates you have 802.11r enabled... this doesn't work well with some devices. Turn it off and try again.

cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'
option ula_prefix 'fdb2:ced1:8e80::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'wan'
option proto 'pppoe'
option username 'Jahidkhan'
option password '1234'
option ipv6 'auto'
option type 'bridge'Preformatted text

cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option band '2g'
option htmode 'HT20'
option channel 'auto'
option cell_density '0'

config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option band '5g'
option cell_density '0'
option htmode 'VHT20'
option channel 'auto'

config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'Jahid Khan'
option network 'lan wan'
option encryption 'psk2'
option key '11112222@'

config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'Jahid Khan 5G'
option network 'lan wan'
option encryption 'psk2'
option key '11112222@'

type or paste code here

cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

type or paste code here

cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'Preformatted text

The networks here are wrong. Should be lan only, not lan wan.

Yes, I changed it, still 2.4g doesn't workPreformatted text

Can you elaborate on this... how far are you from the AP, what are the specific symptoms that make it clear the signal is 'disappearing'?

I can connect to 2.4G from very close to the router, which is about 25 square feet. 25 square feet are lost beyond signal feet. 5G signal is good up to 1200 square feet

Set your country code... that doesn't appear to be configured.

I did, sir. Not yet.
I understand need to revert to stock firmware.

The country code can be set in OpenWrt.

You may be best served by resetting your device to defaults, then setting only your basic wifi settings (country code + SSID + encryption type + password). Then test again.


I have changed country code, still not getting network at 2.4G.

Best option is to reset to defaults... make a backup, but don't restore your backup at this point.

settings basic wifi settings (country code + SSID + encryption type + password). Then test again but no improvements.![JahidKhan - Wireless - LuCI - Google Chrome 3_21_2023 4_23_03 AM|690x387](upload://6cmmhkbxgomdCuZLyDG8JKPi1ON.png)