19.07.x --> AR750S

I would like to install vanilla 19.07.7 (or .8) on my AR750S but I can't find a kernel for 19.07.x (or 18) anywhere.

I tried doing a LuCI-->system upgrade to 19.07.7 squash from the Gl-iNet factory image (3.104, 3.105, 3.201) to no avail.

I tried downgrading to 19.07.7 squash from 21.02.x kernel to no avail.

I have run both the 21.02.x kernels but they lack the ability to save settings. I didn't try the latest snapshots.

What is the correct procedure?


See hardware page - you may have to use the u-boot method.

Thank-you @pythonic but I need a vanilla 19.07.7 kernel - I can't just u-boot a sysupgrade if I am not mistaken. Also I haven't compiled my own images yet so I have something new to learn.

Can you explain more in detail why the installation methods mentioned on the devicepage do not work for you?

I believe I need a OpenWRT 19.07.7 kernel but I can't find one which I believe is due to the NOR/NAND issues with the device and the limited NOR.

I u-booted the Gl-iNet factory firmware (3.104/3.105 = 18.06.x) but then could not upgrade via LuCI to 19.07.7 or 19.07.8. It claimed it failed or the image was not supported.

The firmware selector only had sysupgrade files for 19.07.x.

Seems your are looking for this: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=9a9cdc65c4fd3b25d04e8f08efd5ec6fc7903988

AFAICS, this has not been backported from master to 19.07 (someone correct me if I'm wrong).

Thank-you @tmomas

If you just want to upload stable 19.07.7 or 19.07.8 to get rid of the most excellent Gl-Inet GUI / software (save ~27MB) just use the openwrt firmware selector...


Download the file and then install via the uboot method as outlined here...

GL.iNet Blog - WiFi for Things – 16 Mar 16

How to Enter the Uboot Web UI

Avoid flashing 21.02.x if you want a stable operational router.

Last step...

Prosper. No brick. Boot time reduced from ~2 mins to 45 seconds. :timer_clock:

Where can I order "I :heart: OpenWRT" stickers and fridge magnets?

Yeah... I was all stoked that I was able to get all the way to 21.02.rc4... but been having some problems - mainly that updating dnsmasq in the software section pretty much breaks the router. Whether that's a 21.02.rcx thing, or a dnsmasq thing, dunno. Time to debrick it 'back' to 19.07.x


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.