19.07 uptime support on Linksys WRT32X[SOLVED]

OpenWrt 19.07.0, r10860-a3ffeb413b
Device: Linksys WRT32X

All previous version of OpenWRT always supported command uptime
Even on this device: Linksys WRT32X

But now after update to OpenWrt 19.07.0

uptime: couldn't get boot time: Not supported

Even after install

opkg update && opkg install coreutils-uptime collectd-mod-uptime procps-ng-uptime
uptime: couldn't get boot time: Not supported

How to return uptime command support?

In the same time on
OpenWrt 19.07.0, r10860-a3ffeb413b
TP-LINK Archer C7 v5

uptime works as usual

weird, for me it is working...


1 Like

1 Like

On TP-Link Archer C7 its works well.

But on Linksys WRT32X


try this:


works for sure.

It's working for me.

 OpenWrt 19.07.0, r10860-a3ffeb413b
root@OpenWrt:/# uptime
13:11:04 up 9 days,  4:41,  load average: 0.43, 0.36, 0.36
root@OpenWrt:/# ubus call system board
        "kernel": "4.14.162",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "Linksys WRT32X",
        "board_name": "linksys,venom",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.0",
                "revision": "r10860-a3ffeb413b",
                "target": "mvebu/cortexa9",
                "description": "OpenWrt 19.07.0 r10860-a3ffeb413b"
1 Like


1 Like

Strange, because in LUCI web interface I see uptime too.

May be it's because I installed core-utils.

Could you please post result of:

# which uptime

and ls -l to result

# ls  -l /usr/bin/uptime
lrwxrwxrwx 1 root root 19 Jan 15 19:11 /usr/bin/uptime -> /usr/bin/gnu-uptime

i use the built in uptime in busybox.

1 Like

maybe opkg remove coreutils-uptime collectd-mod-uptime procps-ng-uptime

1 Like

i do not have any uptime needed:

root@hawk:~# opkg list-installed | grep uptime
1 Like

Thanks a lot!

Yes I tried:

ln /bin/busybox ./uptime

And now it works!

# ./uptime
 20:25:35 up  1:29,  load average: 0.00, 0.00, 0.00

Your proposition is right.
I removed it and everything is back to normal.

Thank You once again!

Sometimes the big size of flash memory it is not an advantage.
Because I installed everything i could :joy: :joy: :joy:

1 Like

yes, there is a limit...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.