19.07-snapshot Kernel & Kmods out of sync

Yesterday, I installed openwrt-19.07-snapshot-r10591-2155e94d4b-ipq806x-tplink_c2600-squashfs-sysupgrade (dated 10/14).

Then I tried to install the 6rd package via luci and was told of a dependency (kmod-sit), that:

The installed version of package *kernel* is not compatible, require 4.14.148-1-0894164c… while 4.14.141-1-59af6c05… is installed

The same thing happens when I try to install other packages involving a kernel module (for example kmod-sched-core when installing luci-app-sqm).

The same happens when I try to install using opkg in a ssh session.

Strangely, my opkg config lists:

src/gz openwrt_kmods http://downloads.openwrt.org/releases/19.07-SNAPSHOT/targets/ipq806x/generic/kmods/4.14.141-1-59af6c05c48bd57aceabd02fb462389d

I have updated the package lists multiple times. The behavior persists. I've never modified my opkg config.

I've been installing 19.07 snapshots for more than a month and never had anything like this happen before.

I've downloaded the packages in question and checked their control files and they list the right kernel version as a dependency. The same is true in the Packages and Packages.manifest files in https://downloads.openwrt.org/releases/19.07-SNAPSHOT/targets/ipq806x/generic/kmods/4.14.141-1-59af6c05c48bd57aceabd02fb462389d/

Is the problem on my end, or does it lie elsewhere.

Today's kernel modules are incompatible with yesterday's kernel.

1 Like

See also (untried by me)

1 Like

Thanks for the replies. I'm still a bit lost, though.

It's great that the kmods are versioned, but doesn't that mean I shouldn't be having this problem?

My /etc/opkg/distfeeds.conf points to 4.14.141-1-59af6c05c48bd57aceabd02fb462389d for kmods.

So, why is it complaining that my kernel (4.14.141) isn't compatable.

I downloaded kmod-sit with wget from the 4.14.141-1-59af6c05c48bd57aceabd02fb462389d directory and tried installing it from the command line and got the same incompatibility message above.

Will all resolve itself with a new build in a couple days? Or is there a glitch?

You need to install your kernel and your modules from the same snapshot, you cannot install a snapshot today and some kernel modules tomorrow.

It is an opkg bug which prevents the selection of the correct repository and package provider.


This issue was promptly raised to the openwrt-devel mailing list today by jow

opkg fails to select the correct provider package in case multiple
repositories provide the same kmod with different versions and only one
of the provider satisfied version dependency constraints.

so the most likely people to resolve it should now be aware of the issue.



I'd have filed a bug myself, but I was still trying to understand whether this was expected behavior.

I am on 19.07.0-rc2 and tried to install 6to4 package. It says it has dependency on kmod-sit which could not be installed. I get this error:

root@FriendlyWrt:~# opkg install 6to4
Installing 6to4 (12-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.0-rc2/packages/aarch64_cortex-a53/base/6to4_12-2_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for 6to4:
 *      kmod-sit
 * opkg_install_cmd: Cannot install package 6to4.

I couldn't find kmod-sit in any repositories. Hope it will be fixed.


Why haven't you upgraded to the final version?

You mean 19.07.0 ? This is the latest for aarch64_cortex-a53 architecture.
I will try downloading the package from here:
This file:

What I meant is that 19.07.0-rc2 is the second "release candidate", then there was 19.07.0 as the "stable release"; I would move to 19.07.0 instead of trying to fix 19.07.0-rc2. If you want to try the snapshot releases, flash the image then install the packages, do not merge packages from different releases.

1 Like

I found it at the correct kernel version:
kmod-sit for kernel 19.07.0-rc2

A post was split to a new topic: Can't get 6in4 tunnel working

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.