19.07 on R7800 - No 2.4GHz Radio Showing Up

For some reason, the 2.4GHz radio is not showing up on my R7800. The 5GHz radio shows up and appears to work fine. This is with 19.07 and I even tried doing a "Reset to defaults" and am still experiencing this problem.

Here is my kernel startup log: https://pastebin.com/FCBx9g9D

If I delete my /etc/config/wireless and run "wifi config", this is what is generated:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Has anyone experienced this before or have any suggestions for what might be the culprit? I tried doing a full power cycle but it made no difference. Any insight would be greatly appreciated!

Please test 18.06.6 (should be the same) and a current snapshot (respectively a master build from Build for Netgear R7800, which comes with kernel 4.19).

You problems seems to be with initializing the PCI bus correctly, which is unexpected.

Thank you for the quick reply!

I flashed 18.06.6, did not keep any settings, and even did a full power cycle with the same results. Here is the log: https://pastebin.com/z0pdikVD

I grabbed the latest master snapshot, flashed it, and still had the same issue: https://pastebin.com/YqBr0RbX

Sorry to bump this, but were there any possible remarks or additional feedback you might be able to provide from these logs? Is this a possible hardware issue?

The same kind of pcie phy link initialization failures seem to be happening on kernel 4.19 as well - which is strange (considering how many users are fine with the r7800), this kind of suggests hardware issues. Maybe try the OEM firmware again and go the RMA route, if that's failing as well.

I freshly installed the latest stable on my new R7800. Everything is working fine but 2.4GHz WiFi. It will only show up if 5GHz is disabled.