19.07 build on RTN66u cant install openvpn-openssl

Asus RTN66u |Architecture|Broadcom BCM5300|
|Firmware Version|OpenWrt SNAPSHOT r11219-34c4741da0 / LuCI Master (git-19.284.27115-3688774)|
|Kernel Version|4.14.148|

19.07 build on RTN66u cant install openvpn-openssl

158.9 KB
Open source VPN solution using OpenSSL

Message shows: Details for package openvpn-openssl

  • Version: 2.4.7-2
  • Size: ~158.3 KB installed
  • Dependencies:
    • kmod-tun (15.6 KB) NOT INSTALLED
    • liblzo2 (32.6 KB) NOT INSTALLED
    • libopenssl1.1 INSTALLED

Open source VPN solution using OpenSSL

  • The installed version of package kernel is not compatible, require 4.14.149-1-b36f54c4… while 4.14.148-1-b36f54c4… is installed.

So it looks like I need 4.14.149-1-b36f54c4 to install it and I'll try searching for how to do so via whatever snapshot is in the repo. Then I'll update ticket on how it goes.

https://downloads.openwrt.org/snapshots/targets/brcm47xx/mips74k/ nothing there beyond what I have installed so I'll search around on how to install alpha build. Or that compile process I'll review.

Initial problem was, that I had configured openvpn but got auth failed and then was advised to tick the Pull option to pull directives for Openvpn from server side as ther were some conflicting ones. Before I got that message to try that I installed 19.07 so I could simply import ovpn file to simplify process. Ovpn import has been added to Asuswrt and merlin and sabai and tons of other firmwares, but why not openwrt yet?

Another issue completely but would also like equivalent copy pasting for Wireguard config to a Window, kind of like the GliNet routers have https://support.strongvpn.com/hc/en-us/articles/360035942554-StrongVPN-WireGuard-Setup-for-GLiNet-routers. Will try requesting that elsewhere wherever thats done I guess

I have a similar issue with kmods on 19.07-snapshot. No resolution, yet.

You were told in the other thread to upgrade snapshots - then install the relevant kmods.

I know that's not acceptable for you; but may be a work around or solution for @nk72772. This was the known solution for years - prior to the creation of a kmods folder.

Asus RT-n66u doesnt have anything snapshot wise after 19.07 that I am seeing. Is there any other place to obtain snapshots other than https://downloads.openwrt.org/releases/19.07-SNAPSHOT/targets/brcm47xx/mips74k/ ? I need snapshot containing kernel of 4.14.149-1-b36f54c4 so I can meet the requirements for installingl openvpn-openssl

  • The installed version of package kernel is not compatible, require 4.14.149-1-b36f54c4.

OpenWrt builders provide "daily" snapshots off master (though they do not include LuCI)

master is over 1000 commits past 19.07 at this time and there are several things that haven't been ported back to 19.07, including:

  1. Blocker: LuCI master needs to be backported to 19.07
    Time estimate: 2-3 weeks

  2. Blocker: All relevant sub-components for WPA-3 + GUI support, such as
    hostapd, iwinfo etc. need to be backported to 19.07
    Time estimate: 2 weeks

  3. Blocker: Some weaknesses in libustream-ssl client certificate
    handling need to be addressed, which can only be solved by an API
    redesign. Band-aid fixes available but not merged, nobody worked
    on API redesign yet
    Time estimate: 1 week

  4. Blocker: Need to assert the state of the Dragonblood WPA3
    vulnerabilities in 19.07's hostapd
    Time estimate: a few days I guess

Source: openwrt-devel on October 11, 2019, Re: [OpenWrt-Devel] OpenWrt 19.07 release schedule ?

Local builds off master (or a branch of your choice) are one way to have self-consistent packages at your disposal.

It seems that this is the result of a bug after all.

Installed latest snapshot:
Firmware Version: OpenWrt SNAPSHOT r11240-9d5e266cb1 / LuCI Master (git-19.284.27115-3688774)
Kernel Version 4.14.149 installed now so thus the interface is updated to include OVPN configuration file upload utility. Tested a config import - it was slow to import the file but it Finally did. The web interface is now extremely slow, and the Openvpn Enabled button and Start function does not take. I am reading around various forum posts and not seeing what it is yet, but I'm sure there is some package or setting that fixes the web interface slowness and the vpn config not starting.

Could have sworn I read a post that advised some ipk's to install after installing a snapshot but I can't find where I read about it. I will also check out that imagebuilder thing because Id rather not have any packages that I dont want on the build. And, I'm happy to test and report on the functionality of this since snapshots are WIPs.

Any advise is appreciated.

turns out the config file uploader said it uploaded the file but when SFTP'ed in on SCP there was nothing there. I moved it to the folder from the comp. Still it was not acting as expected (starting) no connection log starting. I know that feature did just get added so will standby for a stable release /snapshot

I see kernel was updated on 18.06 https://github.com/openwrt/openwrt/tree/openwrt-18.06 and I guess that means openvpn-openssl can be installed
to it after I install the current stable build.
And that would then mean I dont have to install a snapshot https://downloads.openwrt.org/snapshots/targets/brcm47xx/mips74k/
(It was able to be installed at the snapshot the other day)

Wireguard client also appeared to be slightly redone in LuCi which is cool. Before my config at StrongVPN was not connecting and now its no problem. Good work , whoever of you did all of that.

Only getting 60-70 down 30-35 up on a 500/500 line - servers about 1200 miles away over an ocean. Its expected I guess, but I'm looking at way to improve performance. Kind of limited on RTN66u I guess.

Sorry this is actually two issues in one post I guess.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.